Page 1 of 4 123 ... LastLast
Results 1 to 10 of 33

Thread: How-To: Compile Amarok 1.4.10 in Ubuntu 10.04

  1. #1
    Join Date
    Oct 2005
    Location
    Milano, Italy
    Beans
    864
    Distro
    Ubuntu Jaunty Jackalope (testing)

    How-To: Compile Amarok 1.4.10 in Ubuntu 10.04

    I'm a big user of old Amarok and I still using in Lucid; here the how-to compile from source; based on this post http://ubuntuforums.org/showthread.php?t=1307737 (thx Seegorkesolot) with some new hints and modified patches.

    This works on Ubuntu (Gnome version) without the official repository version of Amarok installed.

    INSTALL DEPENDENCIES
    Code:
    sudo apt-get install libgpod-common libgpod-dev libgpod4 kdelibs4-dev libxine-dev libdbus-qt-1-dev libtag1-dev libsqlite3-dev libtunepimp-dev libmysqlclient15-dev libpq-dev libvisual-0.4-dev libsdl1.2-dev libifp-dev libxine1 libxine1-ffmpeg build-essential checkinstall ruby ruby-dev libruby libltdl-dev
    DOWNLOAD AMAROK SOURCE
    Code:
    cd ~/Downloads
    wget http://download.kde.org/stable/amarok/1.4.10/src/amarok-1.4.10.tar.bz2
    tar -xvf amarok-1.4.10.tar.bz2
    cd amarok-1.4.10
    PATCH FIX THE CODE (fix for GCC, Cover Manager and Wikipedia lookup)
    Code:
    wget http://yep.it/savedpatch/amarok-1.4.10-gcc44.patch -O amarok-1.4.10-gcc44.patch
    patch -p1 < amarok-1.4.10-gcc44.patch
    Code:
    wget http://yep.it/savedpatch/amarok-1.4.10-covermanager-fix.patch -O amarok-1.4.10-covermanager-fix.patch
    patch -p1 < amarok-1.4.10-covermanager-fix.patch
    Code:
    wget http://yep.it/savedpatch/amarok-1.4.10-wikipedia.patch -O amarok-1.4.10-wikipedia.patch
    patch -p1 < amarok-1.4.10-wikipedia.patch
    COMPILE & INSTALL THE APP
    Code:
    ./configure --without-arts
    make
    sudo make install
    RESTORE ORIGINAL APP ICONS (thx zenkaon)
    Code:
    cd ~/Downloads
    wget http://pprc.qmul.ac.uk/~jmorris/personal/amarok/amarok.icons.__usr.share.icons__.tar.gz -O amarok.icons.__usr.share.icons__.tar.gz
    sudo cp ~/Downloads/amarok.icons.__usr.share.icons__.tar.gz /usr/share/icons
    cd /usr/share/icons
    sudo tar zxvf amarok.icons.__usr.share.icons__.tar.gz
    Done! You can now launch Amarok

    NICE TO HAVE (Install when Amarok is executed)

    UltraLyricwiki, working script for lyrics:
    Notify OSD for Ubuntu integration:
    My favourite theme:
    under Amarok - Configure Amarok - Appareance - Download theme, then search for 3Dintegrity
    Attached Images Attached Images
    Last edited by dentaku65; October 20th, 2010 at 05:04 PM.
    ------------------------------------------------
    yep ”short and long URL„
    http://yep.it/
    ------------------------------------------------

  2. #2
    Join Date
    Oct 2009
    Location
    Switzerland
    Beans
    10
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: How-To: Compile Amarok 1.4.10 in Ubuntu 10.04

    Hi

    I just randomly googled the topic to check if my script still is in use anywhere and it is in fact Nice work and thx for keeping it alive

    Greetz

  3. #3
    Join Date
    Sep 2010
    Beans
    1

    Re: How-To: Compile Amarok 1.4.10 in Ubuntu 10.04

    Hi.. thanks to dentaku65 and Seegorkesolot for making my fav linux audio app (and it's right version.. lol) available in 10.04!!

    INSTALLATION: I followed instructions as per the first post; I ran into troubles, which i fixed by installing the following:
    1) ruby, ruby1.8 and ruby1.8-dev
    2) libltdl-dev

    REMARKS: I don't know if this case applies to everyone! But better to check if the above packages are installed before installing amarok.

  4. #4
    Join Date
    Jun 2007
    Beans
    13,314

    Re: How-To: Compile Amarok 1.4.10 in Ubuntu 10.04

    It will also build and run fine on 10.10 w/ a few minor changes, there's also the pana clone
    Atm have both installed, haven't decided which to keep.
    Attached Images Attached Images

  5. #5
    Join Date
    Oct 2005
    Location
    Milano, Italy
    Beans
    864
    Distro
    Ubuntu Jaunty Jackalope (testing)

    Re: How-To: Compile Amarok 1.4.10 in Ubuntu 10.04

    Thx all,
    I've updated the dependencies and did some screenshots

    bye
    ------------------------------------------------
    yep ”short and long URL„
    http://yep.it/
    ------------------------------------------------

  6. #6
    Join Date
    Oct 2008
    Beans
    286
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: How-To: Compile Amarok 1.4.10 in Ubuntu 10.04

    Problem start at compiling
    ./configure --without-arts
    make
    sudo make install
    having the problem compiling giving some error about ruby programming language which I am not sure which lib to install.

    http://pastebin.com/TjgDkmhR

    Thanks hope for solution

  7. #7
    Join Date
    Jun 2007
    Beans
    13,314

    Re: How-To: Compile Amarok 1.4.10 in Ubuntu 10.04

    I am not sure which lib to install.
    You need ruby, ruby1.8-dev, and their deps.
    run this
    Code:
    sudo apt-get install ruby ruby-dev libruby
    or
    Code:
    sudo apt-get install ruby ruby1.8-dev libruby1.8
    /usr/bin/ruby must link to ruby1.8, at least at build time

    Edit - what release of ubuntu are you using - assuming lucid?
    Last edited by mc4man; October 20th, 2010 at 09:10 PM.

  8. #8
    Join Date
    Oct 2005
    Location
    Milano, Italy
    Beans
    864
    Distro
    Ubuntu Jaunty Jackalope (testing)

    Re: How-To: Compile Amarok 1.4.10 in Ubuntu 10.04

    mmm...
    changed the dependencies of ruby in the #1 switched from ruby-8 to ruby; should the distribution now choose the version...
    ------------------------------------------------
    yep ”short and long URL„
    http://yep.it/
    ------------------------------------------------

  9. #9
    Join Date
    Oct 2008
    Beans
    286
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: How-To: Compile Amarok 1.4.10 in Ubuntu 10.04

    Quote Originally Posted by mc4man View Post
    You need ruby, ruby1.8-dev, and their deps.
    run this
    Code:
    sudo apt-get install ruby ruby-dev libruby
    or
    Code:
    sudo apt-get install ruby ruby1.8-dev libruby1.8
    (if you have ruby1.9.X-dev installed amarok will not build and /usr/bin/ruby must link to ruby1.8, at least at build time

    Edit - what release of ubuntu are you using - assuming lucid?


    Forgot to mention, using maverick right now (dual boot with hardy)

    I had uninstall version 1.9 ruby at synaptic but I still having some error during installation on ./configure --without-arts
    Here's the pastebin , The error seem like I need a xine library , and again , which library should I install ?
    http://pastebin.com/PNb4YiVQ

    Thanks
    Last edited by ubfu; October 20th, 2010 at 05:46 PM.

  10. #10
    Join Date
    Jun 2007
    Beans
    13,314

    Re: How-To: Compile Amarok 1.4.10 in Ubuntu 10.04

    which library should I install
    Well I built amarok 1.4 on maverick about 6 wks. ago, all went well. Rebuilding today a few things have changed, haven't the time to look into.
    (shouldn't be a concern if you don't need mtp support, should be a solution, note pana config

    you need libxine1 and libxine-dev (the 1.18.X ver.
    There is also a dev that's not available in maverick - whether it's needed not sure, when I first built on maverick I installed the lucid libs, a build without today showed no ill effect that I've seen - libdbus-qt-1-dev

    So a reasonable dep check would be to run this (obviously most are installed
    Code:
    sudo apt-get install libgpod-common libgpod-dev libgpod4 kdelibs4-dev libxine-dev \
    libtag1-dev libsqlite3-dev libtunepimp-dev libmysqlclient-dev libpq-dev \
    libvisual-0.4-dev libsdl1.2-dev libifp-dev libxine1 libxine1-ffmpeg build-essential \
    checkinstall ruby ruby-dev libruby libltdl-dev libmp4v2-dev
    Current plugin list from amarok 1.4 configure - using this
    ./configure --without-arts --with-mp4v2 --without-libmtp

    === Amarok - PLUGINS ================================================== ======
    ==========================
    =
    = The following extra functionality will NOT be included:
    = - NMM-engine
    = - Helix-engine
    = - yauap-engine
    = - MySql Support
    = - Postgresql Support
    = - Konqueror Sidebar
    = - MTP Device Support
    = - Rio Karma Support
    =
    = The following extra functionality will be included:
    = + xine-engine
    = + libvisual Support
    = + MusicBrainz Support
    = + MP4/AAC Tag Write Support
    = + iPod Support
    = + iRiver iFP Support
    = + Creative Nomad Jukebox Support
    = + DAAP Music Sharing Support
    Now as a comparison - recent Debian package set build of pana - from build log

    === Pana - PLUGINS ================================================== ======
    ==========================
    =
    = The following extra functionality will NOT be included:
    = - NMM-engine
    = - Helix-engine
    = - yauap-engine
    = - Konqueror Sidebar
    = - Rio Karma Support
    =
    = The following extra functionality will be included:
    = + xine-engine
    = + libvisual Support
    = + MySql Support
    = + Postgresql Support
    = + MusicBrainz Support
    = + MP4/AAC Tag Write Support
    = + iPod Support
    = + iRiver iFP Support
    = + Creative Nomad Jukebox Support
    = + MTP Device Support
    = + DAAP Music Sharing Support
    For install I prefer checkinstall for amarok14 - a simple command -
    Code:
    sudo checkinstall --pkgname amarok14 --pkgversion 1.4 --backup=no --default \
    --deldoc=yes --deldesc=yes --delspec=yes --fstrans=no
    Ot
    I use ruby 1.9.2 - amarok 1.4 seems to run fine when it is the default ruby, but as mentioned won't build unless 1.8 is the default (/usr/bin/ruby) at compile time.
    Last edited by mc4man; November 26th, 2010 at 09:53 AM. Reason: added dep

Page 1 of 4 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •