Page 4 of 4 FirstFirst ... 234
Results 31 to 33 of 33

Thread: Ugly text-mode splash with Nvidia drivers - this may help

  1. #31
    Join Date
    Jun 2007
    Beans
    13,014

    Re: Ugly text-mode splash with Nvidia drivers - this may help

    For those interested here is the orig. 'workaround' post and reasons for doing this way
    http://idyllictux.wordpress.com/2010...ricted-driver/

  2. #32
    Join Date
    Sep 2007
    Location
    Miami, FL
    Beans
    143

    Smile Re: Ugly text-mode splash with Nvidia drivers - this may help

    no longer participating in ubuntuforums.org
    Last edited by MarkieB; April 16th, 2012 at 01:13 AM.

  3. #33
    Join Date
    Jul 2005
    Beans
    204

    Re: Ugly text-mode splash with Nvidia drivers - this may help

    This fixes didnt work at all for me at 10.04. I now upgraded (with dist-upgrade) to 10.10 hoping it would be fixed, but no good. Still tried some more things, but it wont work at all.

    I have a Geforce GTX260 with a 1920x1080 native 22" LCD monitor. As this res is not supported, I chose 1680x1050. Grub apeears in high resolution, but right after it loads the kernel it changes back to 640.480 and only stretches the logo to fit in the whole screen, but still in low res.

    My hwinfo --framebuffer:

    Code:
    02: None 00.0: 11001 VESA Framebuffer                           
      [Created at bios.464]
      Unique ID: rdCR.VsfXBTyKB3F
      Hardware Class: framebuffer
      Model: "NVIDIA GT200 Board - 08970053"
      Vendor: "NVIDIA Corporation"
      Device: "GT200 Board - 08970053"
      SubVendor: "NVIDIA"
      SubDevice: 
      Revision: "Chip Rev"
      Memory Size: 14 MB
      Memory Range: 0xf9000000-0xf9dfffff (rw)
      Mode 0x0300: 640x400 (+640), 8 bits
      Mode 0x0301: 640x480 (+640), 8 bits
      Mode 0x0303: 800x600 (+800), 8 bits
      Mode 0x0305: 1024x768 (+1024), 8 bits
      Mode 0x0307: 1280x1024 (+1280), 8 bits
      Mode 0x030e: 320x200 (+640), 16 bits
      Mode 0x030f: 320x200 (+1280), 24 bits
      Mode 0x0311: 640x480 (+1280), 16 bits
      Mode 0x0312: 640x480 (+2560), 24 bits
      Mode 0x0314: 800x600 (+1600), 16 bits
      Mode 0x0315: 800x600 (+3200), 24 bits
      Mode 0x0317: 1024x768 (+2048), 16 bits
      Mode 0x0318: 1024x768 (+4096), 24 bits
      Mode 0x031a: 1280x1024 (+2560), 16 bits
      Mode 0x031b: 1280x1024 (+5120), 24 bits
      Mode 0x0330: 320x200 (+320), 8 bits
      Mode 0x0331: 320x400 (+320), 8 bits
      Mode 0x0332: 320x400 (+640), 16 bits
      Mode 0x0333: 320x400 (+1280), 24 bits
      Mode 0x0334: 320x240 (+320), 8 bits
      Mode 0x0335: 320x240 (+640), 16 bits
      Mode 0x0336: 320x240 (+1280), 24 bits
      Mode 0x033d: 640x400 (+1280), 16 bits
      Mode 0x033e: 640x400 (+2560), 24 bits
      Mode 0x0345: 1600x1200 (+1600), 8 bits
      Mode 0x0346: 1600x1200 (+3200), 16 bits
      Mode 0x0347: 1400x1050 (+1400), 8 bits
      Mode 0x0348: 1400x1050 (+2800), 16 bits
      Mode 0x0349: 1400x1050 (+5600), 24 bits
      Mode 0x034a: 1600x1200 (+6400), 24 bits
      Mode 0x0352: 2048x1536 (+8192), 24 bits
      Mode 0x0360: 1280x800 (+1280), 8 bits
      Mode 0x0361: 1280x800 (+5120), 24 bits
      Mode 0x0362: 768x480 (+768), 8 bits
      Mode 0x0364: 1440x900 (+1440), 8 bits
      Mode 0x0365: 1440x900 (+5760), 24 bits
      Mode 0x0368: 1680x1050 (+1680), 8 bits
      Mode 0x0369: 1680x1050 (+6720), 24 bits
      Mode 0x037b: 1280x720 (+5120), 24 bits
      Mode 0x037c: 1920x1200 (+1920), 8 bits
      Mode 0x037d: 1920x1200 (+7680), 24 bits
      Config Status: cfg=new, avail=yes, need=no, active=unknown
    My /etc/default/grub:

    Code:
    # If you change this file, run 'update-grub' afterwards to update
    # /boot/grub/grub.cfg.
    
    GRUB_DEFAULT=0
    #GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT=10
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset video=uvesafb:mode_option=1680x1050-24@60,mtrr=3,scroll=ywrap"
    GRUB_CMDLINE_LINUX=""
    
    # Uncomment to enable BadRAM filtering, modify to suit your needs
    # This works with Linux (no patch required) and with any kernel that obtains
    # the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
    #GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"
    
    # Uncomment to disable graphical terminal (grub-pc only)
    #GRUB_TERMINAL=console
    
    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    GRUB_GFXMODE=1680x1050
    
    # Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
    #GRUB_DISABLE_LINUX_UUID=true
    
    # Uncomment to disable generation of recovery mode menu entries
    #GRUB_DISABLE_LINUX_RECOVERY="true"
    
    # Uncomment to get a beep at grub start
    #GRUB_INIT_TUNE="480 440 1"
    my /etc/initramfs-tools/modules:

    Code:
    # List of modules that you want to include in your initramfs.
    #
    # Syntax:  module_name [args ...]
    #
    # You must run update-initramfs(8) to effect this change.
    #
    # Examples:
    #
    # raid1
    # sd_mod
    uvesafb mode_option=1680x1050-24@60 mtrr=3 scroll=ywrap
    This is the exactly same thing I had when I tried to fix this when 10.04 was out. I just kept on struggling to make it work and eventually gave up. I am about to do the same right now.

Page 4 of 4 FirstFirst ... 234

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •