Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 33

Thread: Ugly text-mode splash with Nvidia drivers - this may help

  1. #21
    Join Date
    Mar 2008
    Beans
    523
    Distro
    Ubuntu Development Release

    Re: Ugly text-mode splash with Nvidia drivers - this may help

    Quote Originally Posted by VinDSL View Post
    Sorry for being a stickler, but I had to install two packages:

    1. v86d
    2. hwinfo

    Not sure what it's a dependency of, but hwinfo must have been a dependency for something else I'd already installed. It was already on my system. Good to know that it isn't part of the default install.
    My blog about getting your life in gear: Growing Up After 30.

    My Photography: Stephen Michael Photography.

  2. #22
    Join Date
    Mar 2006
    Location
    Williams Lake
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Ugly text-mode splash with Nvidia drivers - this may help

    If you're not sure about dependencies, you can always open synaptic, highlight the package then click Properties->Dependencies.

  3. #23
    Join Date
    Mar 2008
    Beans
    523
    Distro
    Ubuntu Development Release

    Re: Ugly text-mode splash with Nvidia drivers - this may help

    Quote Originally Posted by cariboo907 View Post
    If you're not sure about dependencies, you can always open synaptic, highlight the package then click Properties->Dependencies.
    It's the other way around. I know what it's dependencies are, but don't know what it's a dependency OF. It was automatically installed for me as a dependency of something else, and I'm not sure what.
    My blog about getting your life in gear: Growing Up After 30.

    My Photography: Stephen Michael Photography.

  4. #24
    Join Date
    Sep 2008
    Beans
    1,024
    Distro
    Ubuntu Development Release

    Re: Ugly text-mode splash with Nvidia drivers - this may help

    Quote Originally Posted by VeeDubb View Post
    It's the other way around. I know what it's dependencies are, but don't know what it's a dependency OF.
    Same thing except on the dependencies tab you change it to show 'dependent packages'.

    Of if you want you could install apt-rdepends, open a terminal window and type:

    Code:
    apt-rdepends update
    apt-rdepends -r -f Depends,PreDepends,Recommends some-package
    or if you are logged in at the command line you probably want to do:

    Code:
    apt-rdepends -r -f Depends,PreDepends,Recommends some-package | less
    Later, Seeker
    Last edited by seeker5528; September 10th, 2010 at 10:04 PM.

  5. #25
    Join Date
    Mar 2008
    Location
    India
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Ugly text-mode splash with Nvidia drivers - this may help

    apt-rdepends is nice.

  6. #26
    Join Date
    Sep 2008
    Beans
    1,024
    Distro
    Ubuntu Development Release

    Re: Ugly text-mode splash with Nvidia drivers - this may help

    Quote Originally Posted by ktp View Post
    apt-rdepends is nice.
    Except I haven't quite figured out the logic that you have to specify '-r' to get the reverse depends. Isn't reverse what the R stands for in apt-rdepends?

    Later, Seeker

  7. #27
    Join Date
    Mar 2008
    Location
    India
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Ugly text-mode splash with Nvidia drivers - this may help

    hehe first thing that I thought when i first saw it.

  8. #28
    Join Date
    Aug 2010
    Beans
    10

    Re: Ugly text-mode splash with Nvidia drivers - this may help

    thanks a lot recluce it's working like a charm

  9. #29
    Join Date
    May 2007
    Beans
    13

    Re: Ugly text-mode splash with Nvidia drivers - this may help

    worked here for me too! thanks!

  10. #30
    Join Date
    Jun 2008
    Location
    British Columbia, Canada
    Beans
    420

    Re: Ugly text-mode splash with Nvidia drivers - this may help

    Quote Originally Posted by VeeDubb View Post
    caryb, you shoudl have read the whole post and not just the OP. The OP's directions seem to be incomplete.

    You need to modify your /etc/default/grub

    Find the line that says

    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    and replace it with

    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset video=uvesafb:mode_option=1366x768-32@60,mtrr=3,scroll=ywrap"
    Then run
    Code:
    sudo update-grub2
    Please not that this will probably not work. You may well have to change the "-32" in your grub file AND modules file to "-24" and update both again. As you can see from the results of hwinfo, your system does not appear to support 32bit framebuffers.
    Apparently, for some people changes to GRUB seem to be required to make it work. Certainly not for me, I am not even running GRUB2 - and my GRUB1 starts into the graphical splash screen just fine with just the options "quiet splash".

    I don't see the need to repeat the VESA graphics settings in GRUB, but I would suspect that "nomodeset" might be required for some chipsets.

    So my original "how to" should work for most people, if it doesn't, it is time to try VeeDub's additional modifications.

Page 3 of 4 FirstFirst 1234 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •