Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 33

Thread: Ugly text-mode splash with Nvidia drivers - this may help

  1. #11
    Join Date
    Aug 2010
    Location
    Arizona USA
    Beans
    2,800
    Distro
    Ubuntu Development Release

    Re: Ugly text-mode splash with Nvidia drivers - this may help

    Quote Originally Posted by caryb View Post
    [...]I got a trip down memory lane, CGA graphics (think 100 font size) I also tried 1024x768 with no real difference.[...]
    Did you run:

    Code:
    sudo hwinfo --framebuffer
    I just discovered there's no 32-bit mode at native res, on this machine -- even though it seemed to be working.

    Code:
    $ sudo hwinfo --framebuffer
    02: None 00.0: 11001 VESA Framebuffer                           
      [Created at bios.464]
      Hardware Class: framebuffer
      Model: "NVIDIA G73 Board - p456h0  "
      Vendor: "NVIDIA Corporation"
      Device: "G73 Board - p456h0  "
      SubVendor: "NVIDIA"
      SubDevice: 
      Revision: "Chip Rev"
      Memory Size: 256 MB
      Memory Range: 0xe0000000-0xefffffff (rw)
      Mode 0x0300: 640x400 (+640), 8 bits
      Mode 0x0301: 640x480 (+640), 8 bits
      Mode 0x0303: 800x600 (+800), 8 bits
      Mode 0x0305: 1024x768 (+1024), 8 bits
      Mode 0x0307: 1280x1024 (+1280), 8 bits
      Mode 0x030e: 320x200 (+640), 16 bits
      Mode 0x030f: 320x200 (+1280), 24 bits
      Mode 0x0311: 640x480 (+1280), 16 bits
      Mode 0x0312: 640x480 (+2560), 24 bits
      Mode 0x0314: 800x600 (+1600), 16 bits
      Mode 0x0315: 800x600 (+3200), 24 bits
      Mode 0x0317: 1024x768 (+2048), 16 bits
      Mode 0x0318: 1024x768 (+4096), 24 bits
      Mode 0x031a: 1280x1024 (+2560), 16 bits
      Mode 0x031b: 1280x1024 (+5120), 24 bits
      Mode 0x0330: 320x200 (+320), 8 bits
      Mode 0x0331: 320x400 (+320), 8 bits
      Mode 0x0332: 320x400 (+640), 16 bits
      Mode 0x0333: 320x400 (+1280), 24 bits
      Mode 0x0334: 320x240 (+320), 8 bits
      Mode 0x0335: 320x240 (+640), 16 bits
      Mode 0x0336: 320x240 (+1280), 24 bits
      Mode 0x033d: 640x400 (+1280), 16 bits
      Mode 0x033e: 640x400 (+2560), 24 bits
      Mode 0x0345: 1600x1200 (+1600), 8 bits
      Mode 0x0346: 1600x1200 (+3200), 16 bits
      Mode 0x0347: 1400x1050 (+1400), 8 bits
      Mode 0x0348: 1400x1050 (+2800), 16 bits
      Mode 0x0352: 2048x1536 (+8192), 24 bits
      Config Status: cfg=new, avail=yes, need=no, active=unknown
    EDIT

    I ran the commands again, and restarted.

    The splash screen looks better now (@ 24 bits)... =D>
    Last edited by VinDSL; September 9th, 2010 at 10:30 AM.

  2. #12
    Join Date
    Sep 2007
    Location
    Miami, FL
    Beans
    143

    Smile Re: Ugly text-mode splash with Nvidia drivers - this may help

    no longer participating in ubuntuforums.org
    Last edited by MarkieB; April 16th, 2012 at 01:16 AM.

  3. #13
    Join Date
    Mar 2008
    Beans
    523
    Distro
    Ubuntu Development Release

    Re: Ugly text-mode splash with Nvidia drivers - this may help

    Quote Originally Posted by MarkieB View Post
    ...is it really worth bothering?
    To me? Yes.

    The fix that I used, takes a total of 3-5 minutes total. Granted, it took the better part of half an hour to find the best fix, but once I found it, I only had to spend a few minutes doing the actual fixing.

    Install one package from the repos, run one command to make sure you pick sane options, edit two text files, run two more commands. Done.

    I have probably spent far more time discussing this here than it took me to actually get it fixed.
    My blog about getting your life in gear: Growing Up After 30.

    My Photography: Stephen Michael Photography.

  4. #14
    Join Date
    Mar 2008
    Beans
    523
    Distro
    Ubuntu Development Release

    Re: Ugly text-mode splash with Nvidia drivers - this may help

    Quote Originally Posted by caryb View Post
    I tried this on my stinkpad (1366x768) & I got a trip down memory lane, CGA graphics (think 100 font size) I also tried 1024x768 with no real difference.

    Bugger Cary
    Can you please post the contents of your /etc/default/grub and /etc/initramfs-tools/modules

    I suspect you have something configured incorrectly there, and if you post them I'd be happy to take a look.
    My blog about getting your life in gear: Growing Up After 30.

    My Photography: Stephen Michael Photography.

  5. #15
    Join Date
    Jun 2006
    Location
    GEORGE ZA
    Beans
    173
    Distro
    Ubuntu Development Release

    Re: Ugly text-mode splash with Nvidia drivers - this may help

    One can also fix this by installing StartUP-Manager from Software Center and choose your options in the program.
    Intel E5200Dual Core CPU, Gigabyte G31 mobo, 4 GB DDR800 mem, Intel graphics, 250 GB Seagate HDD, Liteon 22x DVD Rewriter, 17" HP LCD Ubuntu User # 17508

  6. #16
    Join Date
    Feb 2010
    Location
    /UK/Cambridge
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Ugly text-mode splash with Nvidia drivers - this may help

    Instead of fiddling with alternative framebuffer drivers, a simple line of GRUB_GFXPAYLOAD_LINUX=<whatever resolution> in /etc/default/grub did the trick for me in a much simpler way.
    The early bird gets the worm. . . But the second mouse gets the cheese, and the early worm gets eaten.
    Unwarranted Self Promotion

  7. #17
    Join Date
    Jun 2006
    Location
    Queensland Australia
    Beans
    706
    Distro
    Kubuntu Development Release

    Re: Ugly text-mode splash with Nvidia drivers - this may help

    I didn't install hwinfo as I'm running Kubuntu & thought it was a Gnome app that would install Gb's of data! WRONG have installed it now...

    root@stinkpad:~# hwinfo --framebuffer
    02: None 00.0: 11001 VESA Framebuffer
    [Created at bios.464]
    Unique ID: rdCR.NszzKie+Nl9
    Hardware Class: framebuffer
    Model: "NVIDIA Quadro NVS170M
    "
    Vendor: "NVIDIA Corporation"
    Device: "NVIDIA Quadro NVS170M
    "
    SubVendor: "NVIDIA"
    SubDevice:
    Revision: "Chip Rev"
    Memory Size: 14 MB
    Memory Range: 0xcf000000-0xcfdfffff (rw)
    Mode 0x0300: 640x400 (+640), 8 bits
    Mode 0x0301: 640x480 (+640), 8 bits
    Mode 0x0303: 800x600 (+800), 8 bits
    Mode 0x0305: 1024x768 (+1024), 8 bits
    Mode 0x0307: 1280x1024 (+1280), 8 bits
    Mode 0x030e: 320x200 (+640), 16 bits
    Mode 0x030f: 320x200 (+1280), 24 bits
    Mode 0x0311: 640x480 (+1280), 16 bits
    Mode 0x0312: 640x480 (+2560), 24 bits
    Mode 0x0314: 800x600 (+1600), 16 bits
    Mode 0x0315: 800x600 (+3200), 24 bits
    Mode 0x0317: 1024x768 (+2048), 16 bits
    Mode 0x0318: 1024x768 (+4096), 24 bits
    Mode 0x031a: 1280x1024 (+2560), 16 bits
    Mode 0x031b: 1280x1024 (+5120), 24 bits
    Mode 0x0330: 320x200 (+320), 8 bits
    Mode 0x0331: 320x400 (+320), 8 bits
    Mode 0x0332: 320x400 (+640), 16 bits
    Mode 0x0333: 320x400 (+1280), 24 bits
    Mode 0x0334: 320x240 (+320), 8 bits
    Mode 0x0335: 320x240 (+640), 16 bits
    Mode 0x0336: 320x240 (+1280), 24 bits
    Mode 0x033d: 640x400 (+1280), 16 bits
    Mode 0x033e: 640x400 (+2560), 24 bits
    Mode 0x0345: 1600x1200 (+1600), 8 bits
    Mode 0x0346: 1600x1200 (+3200), 16 bits
    Mode 0x034a: 1600x1200 (+6400), 24 bits
    Mode 0x0360: 1280x800 (+1280), 8 bits
    Mode 0x0361: 1280x800 (+5120), 24 bits
    Mode 0x0362: 768x480 (+768), 8 bits
    Mode 0x0363: 848x480 (+3392), 24 bits
    Config Status: cfg=new, avail=yes, need=no, active=unknown



    root@stinkpad:~# cat /etc/default/grub
    # If you change this file, run 'update-grub' afterwards to update
    # /boot/grub/grub.cfg.

    GRUB_DEFAULT=0
    #GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT=10
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    GRUB_CMDLINE_LINUX=""

    # Uncomment to enable BadRAM filtering, modify to suit your needs
    # This works with Linux (no patch required) and with any kernel that obtains
    # the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
    #GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xe fefefef"

    # Uncomment to disable graphical terminal (grub-pc only)
    #GRUB_TERMINAL=console

    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    #GRUB_GFXMODE=640x480

    # Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
    #GRUB_DISABLE_LINUX_UUID=true

    # Uncomment to disable generation of recovery mode menu entries
    #GRUB_DISABLE_LINUX_RECOVERY="true"

    # Uncomment to get a beep at grub start
    #GRUB_INIT_TUNE="480 440 1"

    root@stinkpad:~# cat /etc/initramfs-tools/modules
    # List of modules that you want to include in your initramfs.
    #
    # Syntax: module_name [args ...]
    #
    # You must run update-initramfs(8) to effect this change.
    #
    # Examples:
    #
    # raid1
    # sd_mod
    uvesafb mode_option=1366x768-32@60 mtrr=3 scroll=ywrap

    Just tried uvesafb mode_option=1600x1200-24@60 mtrr=3 scroll=ywrap

    Still GGA, it also starts X in low graphics mode with this enabled & I have to restart X to get back to 1366x768 mode.

    Cary
    Last edited by caryb; September 9th, 2010 at 11:28 PM.
    Ubuntu user 7859 registered Linux user 470405
    The Ubuntu Counter Project - user number # 7859"
    Lenovo T510 Kubuntu Trusty 64bit, Intel Core i5-560M, 8GB PC3-DDR3 SDRAM - 1067 MHz,
    NVIDIA NVS 3100m PCI Express, Wireless Centrino N 6300

  8. #18
    Join Date
    Sep 2008
    Beans
    1,024
    Distro
    Ubuntu Development Release

    Re: Ugly text-mode splash with Nvidia drivers - this may help

    Quote Originally Posted by VinDSL View Post
    I just discovered there's no 32-bit mode at native res, on this machine -- even though it seemed to be working.
    When hardware came along that claimed it had 32 bit color, some of the earlier Linux drivers provided a 32 bit option, but some literal minded person or group decided that 'Hey!! 32 bit still only has 24 bits of color, so you should only have to specify 24 bit and the +8 should be handled automatically when the hardware supports it.' so that's what was adopted for all the drivers.

    I'm sure there is a longer story out there somewhere, but do you really want to know?

    Later, Seeker

  9. #19
    Join Date
    Mar 2008
    Beans
    523
    Distro
    Ubuntu Development Release

    Re: Ugly text-mode splash with Nvidia drivers - this may help

    caryb, you shoudl have read the whole post and not just the OP. The OP's directions seem to be incomplete.

    You need to modify your /etc/default/grub

    Find the line that says

    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    and replace it with

    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset video=uvesafb:mode_option=1366x768-32@60,mtrr=3,scroll=ywrap"
    Then run
    Code:
    sudo update-grub2
    Please not that this will probably not work. You may well have to change the "-32" in your grub file AND modules file to "-24" and update both again. As you can see from the results of hwinfo, your system does not appear to support 32bit framebuffers.
    My blog about getting your life in gear: Growing Up After 30.

    My Photography: Stephen Michael Photography.

  10. #20
    Join Date
    Aug 2010
    Location
    Arizona USA
    Beans
    2,800
    Distro
    Ubuntu Development Release

    Re: Ugly text-mode splash with Nvidia drivers - this may help

    Quote Originally Posted by VeeDubb View Post
    To me? Yes.
    I think it's worth it too! I know it's only aesthetics, but...

    Quote Originally Posted by VeeDubb View Post
    Install one package from the repos...
    Sorry for being a stickler, but I had to install two packages:

    1. v86d
    2. hwinfo


Page 2 of 4 FirstFirst 1234 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •