Results 1 to 6 of 6

Thread: Nt_status_connection_refused

  1. #1
    Join Date
    Oct 2009
    Location
    Oxford, UK
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Nt_status_connection_refused

    Hi all, I am sharing a folder on my external drive using Samba. Others are unable to access it so I ran a few debug tests.

    Whilst trying to connect from my own machine, I get...

    smbclient -L my_ip
    Enter user password:
    Connection to my_ip failed (NT_STATUS_CONNECTION_REFUSED)

    I use UFW as my firewall
    sudo ufw status
    Samba ALLOW Anywhere

    So there shouldn't be a problem. Any thoughts?

  2. #2
    Join Date
    Oct 2009
    Location
    Oxford, UK
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Nt_status_connection_refused

    Update - this is only true for when I connect to my ip (eth0) same command but to localhost lists valid samba shares

    smbclient -L localhost -N
    Domain = etc OS = etc Server = etc

    which I guess means samba is failing to bind to eth0 but I have interfaces = eth0 lo .

  3. #3
    Join Date
    Oct 2009
    Location
    Oxford, UK
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Nt_status_connection_refused

    Update -

    Solved this one, just updating with solution for rest of the community

    lsof -ni:139 and 445 revealed samba was only binding to lo,

    set [bind to interfaces only] line in smb.conf to FALSE and reload samba, done the trick

  4. #4
    Join Date
    Nov 2006
    Beans
    13

    Smile Re: Nt_status_connection_refused

    Quote Originally Posted by karmic-koala View Post
    Update -

    Solved this one, just updating with solution for rest of the community

    lsof -ni:139 and 445 revealed samba was only binding to lo,

    set [bind to interfaces only] line in smb.conf to FALSE and reload samba, done the trick
    did the trick for me as well

  5. #5
    Join Date
    Jun 2009
    Beans
    3

    Re: Nt_status_connection_refused

    this works for me as well, after a few days trying without luck to diagnose the problem. the language is different in my smb.conf file: bind interfaces only = no ( default was set to 'yes' )

    everything works now, so i can get back to work too. thanks!

  6. #6
    Join Date
    Dec 2008
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Nt_status_connection_refused

    Quote Originally Posted by jimww View Post
    this works for me as well, after a few days trying without luck to diagnose the problem. the language is different in my smb.conf file: bind interfaces only = no ( default was set to 'yes' )

    everything works now, so i can get back to work too. thanks!
    The default is bind interfaces only = no.

    If a parameter is not listed, then the default is applied. If you found this in the smb.conf file it was set it that way. See here -- this is a complete listing of all the parameters.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •