Results 1 to 10 of 10

Thread: No Network Access on 10.04

  1. #1
    Join Date
    Aug 2008
    Beans
    78

    No Network Access on 10.04

    Hey guys,

    I purchased an Acer Aspire 7745G yesterday and installed Ubuntu as soon as I opened up the computer.

    There appears to be a big problem however. Neither the wireless nor the LAN / ethernet are working.

    'ifconfig -a' gives two items: lo and pan0. I believe pan0 is the bluetooth.

    The wireless icon at the top right says "No network devices available". Network Tools shows the same results.

    If I plug in an ethernet cord, nothing happens.

    This is a fresh Ubuntu 10.04.1 downloaded this morning from ubuntu.com. I tried installing three times (USB, CD, DVD) including data checks on the disks. Same problem all three times.

    I am guessing this is some kind of driver issue, but since I have no Internet access, I cannot do a Ubuntu Update and have Ubuntu find the drivers for me.

    Any ideas?

    EDIT: The wireless and ethernet are working in Windows 7.

  2. #2
    Join Date
    Mar 2007
    Location
    INDIA-Kerala
    Beans
    1,604
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: No Network Access on 10.04

    Code:
    sudo lshw -C network

  3. #3
    Join Date
    Aug 2008
    Beans
    78

    Re: No Network Access on 10.04

    Quote Originally Posted by dineshs View Post
    Code:
    sudo lshw -C network
    Thanks dineshs. Not sure what to make of the result:

    Code:
    chris@acer:~$ sudo lshw -C network
    [sudo] password for chris: 
      *-network UNCLAIMED     
           description: Ethernet controller
           product: AR8151 v1.0 Gigabit Ethernet
           vendor: Atheros Communications
           physical id: 0
           bus info: pci@0000:02:00.0
           version: c0
           width: 64 bits
           clock: 33MHz
           capabilities: pm msi pciexpress vpd bus_master cap_list
           configuration: latency=0
           resources: memory:f8000000-f803ffff ioport:3000(size=128)
      *-network UNCLAIMED
           description: Network controller
           product: Broadcom Corporation
           vendor: Broadcom Corporation
           physical id: 0
           bus info: pci@0000:09:00.0
           version: 01
           width: 64 bits
           clock: 33MHz
           capabilities: pm msi pciexpress bus_master cap_list
           configuration: latency=0
           resources: memory:f8200000-f8203fff

  4. #4
    Join Date
    Jan 2006
    Location
    Not heaven... Iowa
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: No Network Access on 10.04

    Perhaps I'm just mis-interpreting things this afternoon (long day...), but I don't notice a driver associated with either interface.
    Linux User #415691 Ubuntu User #8629
    Iowa Team (LoCo): [Wiki] [Launchpad] [Sub-forum]
    IRC channel: #ubuntu-us-ia on irc.freenode.net

  5. #5
    Join Date
    Aug 2008
    Beans
    78

    Re: No Network Access on 10.04

    Quote Originally Posted by Iowan View Post
    Perhaps I'm just mis-interpreting things this afternoon (long day...), but I don't notice a driver associated with either interface.
    Thanks Iowan. Yep, I think you are right. That seems to be the problem: For some reason Ubuntu did not install either the wireless or the ethernet drivers during the install. I am not sure how to get them and install them now. I have no Internet access on the computer.

  6. #6
    Join Date
    Mar 2007
    Location
    INDIA-Kerala
    Beans
    1,604
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: No Network Access on 10.04

    Try this link
    http://ubuntuforums.org/showthread.php?t=1476231
    Since you dont have internet it will be difficult to install build-essential
    Can you check whether build-essential is listed in synaptic package manager?
    If yes try this(see post #5)
    http://ubuntuforums.org/showthread.php?t=1553834

  7. #7
    Join Date
    Aug 2008
    Beans
    78

    Re: No Network Access on 10.04

    Quote Originally Posted by dineshs View Post
    Try this link
    http://ubuntuforums.org/showthread.php?t=1476231
    Since you dont have internet it will be difficult to install build-essential
    Can you check whether build-essential is listed in synaptic package manager?
    If yes try this(see post #5)
    http://ubuntuforums.org/showthread.php?t=1553834
    Thanks dineshs! I managed to get my ethernet connection working. No wireless yet...

    This is what I did:

    1. Installed build-essential from Live CD using:
    Code:
    sudo apt-cdrom add
    sudo apt-get update
    sudo apt-get install build-essential
    - source
    1b. Had some problems with the apt-cdrom command so used this as a fix:
    Code:
    sudo umount /dev/sr0
    sudo mount /dev/sr0 /media/apt/
    sudo apt-cdrom add
    - source
    2. Downloaded the Ethernet driver from here

    3. Used slightly modified steps from chili555's post here:
    Code:
    tar zxvf AR81Family-Linux-v1.0.1.9.tar.gz
    cd src
    sudo su
    make install
    modprobe atl1e
    exit
    EDIT: Once I had Internet access, I was prompted to download and install restricted drivers. Now the wireless is working fine. Thanks everyone!
    Last edited by 1awesomeguy; August 19th, 2010 at 07:50 AM.

  8. #8
    Join Date
    Mar 2007
    Location
    INDIA-Kerala
    Beans
    1,604
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: No Network Access on 10.04

    Happy to hear your problem is solved.Thank you for detailing this step by step procedure.Hope this will help others like V13 noob(The other thread I referred which is yet to be solved)
    Thanks to chili555 and lowan
    Last edited by dineshs; August 19th, 2010 at 02:50 PM.

  9. #9
    Join Date
    Sep 2010
    Beans
    2

    Smile Re: No Network Access on 10.04

    Yeah - - Worked like a charm. Many thanks for the clear, concise notes. For others please note that "atl1e" includes the letter "L" (lowercase) followed by the number "1". In my browser at least this was not obvious. Silly English alphabet.

  10. #10
    Join Date
    Sep 2011
    Beans
    1

    Re: No Network Access on 10.04

    Hi,

    Im having the same problem with this AR8151 driver from atheros.
    Though I can't seem to find the patch.

    I do have the AR81Family-linux-v1-1.0.1.14.patch but when i type "make install" i get this error:
    Code:
    make: *** No rule to make target ínstall'. Stop
    Anyone knows how to fix this?
    edit: linux 2.6.32-33-generic
    Last edited by jaspertb; September 10th, 2011 at 05:44 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •