Results 1 to 9 of 9

Thread: Ubuntu randomly moves the typing cursor.

  1. #1
    Join Date
    Feb 2010
    Location
    Hull
    Beans
    359

    Ubuntu randomly moves the typing cursor.

    Hi, I've had this problem ever since I first installed ubuntu (when karmic came out) but never bothered to get it fixed. When I'm typing, the blinking cursor that shows where i'm typing will sometimes randomly change position and i will start typing somewhere else. Below is an example sentence.

    What I'm trying to say
    Code:
    This is an example sentence.
    What It types
    Code:
    This is an examsentence.ple
    As you can see when I started to write sentence the cursor moved in the middle of the word example, and continued writing my sentence.

    I'm not sure how I can explain my problem further. Is this a known bug? Can it be fixed?


    Thanks.
    Signatures are a myth.

  2. #2
    Join Date
    Nov 2008
    Location
    Los Angeles
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Ubuntu randomly moves the typing cursor.

    Quote Originally Posted by Mr_VeRiTy View Post
    Hi, I've had this problem ever since I first installed ubuntu (when karmic came out) but never bothered to get it fixed. When I'm typing, the blinking cursor that shows where i'm typing will sometimes randomly change position and i will start typing somewhere else. Below is an example sentence.

    What I'm trying to say
    Code:
    This is an example sentence.
    What It types
    Code:
    This is an examsentence.ple
    As you can see when I started to write sentence the cursor moved in the middle of the word example, and continued writing my sentence.

    I'm not sure how I can explain my problem further. Is this a known bug? Can it be fixed?


    Thanks.
    are you using a touchpad/laptop

  3. #3
    Join Date
    Feb 2010
    Location
    Hull
    Beans
    359

    Re: Ubuntu randomly moves the typing cursor.

    Quote Originally Posted by carlee View Post
    are you using a touchpad/laptop
    Yes, but I have it set to "Disable touchpad while typing."
    Signatures are a myth.

  4. #4
    Join Date
    Feb 2010
    Location
    Hull
    Beans
    359

    Re: Ubuntu randomly moves the typing cursor.

    *bump*
    Signatures are a myth.

  5. #5
    Join Date
    Feb 2010
    Location
    Winchester
    Beans
    7,997
    Distro
    Ubuntu Development Release

    Re: Ubuntu randomly moves the typing cursor.

    Disable touch while typing is really sensitive. during that small bit of time between letters it will activate and move the cursor. You have to completely disable the touchpad or lift your hands above the touchpad while typing.

    Please do not bump your thread unless it has been dormant for more than 24 hours.
    Cheers & Beers,
    uRock™


  6. #6
    Join Date
    Feb 2010
    Location
    Hull
    Beans
    359

    Re: Ubuntu randomly moves the typing cursor.

    Quote Originally Posted by uRock View Post
    Disable touch while typing is really sensitive. during that small bit of time between letters it will activate and move the cursor. You have to completely disable the touchpad or lift your hands above the touchpad while typing.

    Please do not bump your thread unless it has been dormant for more than 24 hours.
    But I usualy lift my hands above it anyways, before posting this thread I made absolutely sure it was a bug and not just a pebkac (pebcak?) error. Is there anything else it could be?
    Signatures are a myth.

  7. #7
    Join Date
    Feb 2010
    Location
    Winchester
    Beans
    7,997
    Distro
    Ubuntu Development Release

    Re: Ubuntu randomly moves the typing cursor.

    I have the same problem all the time on my netbook. I wish I knew of a way to set the delay time between letters typed and when the I/O of the touchpad starts working. I guess it could be considered a bug being that the only way I have seen to disable the keyboard is temporary and only lasts a few minutes before it is reactivated.

    The following command is what I use to deactivate the touchpad;
    Code:
    synclient TouchpadOff=1
    Cheers & Beers,
    uRock™


  8. #8
    Join Date
    Feb 2010
    Location
    Hull
    Beans
    359

    Re: Ubuntu randomly moves the typing cursor.

    Also another reason I don't think it is because of the touchpad is that my mouse cursor is nowhere near the place where it randomly starts to type, and (I think) it does it on my desktop which is without a touchpad, but a solution to your problem is maybe disable tap to click, and just use the touchpad buttons to click instead and use your touchpad only to move the cursor.
    Signatures are a myth.

  9. #9
    Join Date
    Sep 2009
    Location
    Delhi
    Beans
    29
    Distro
    Kubuntu 13.04 Raring Ringtail

    Re: Ubuntu randomly moves the typing cursor.

    I also have same problem since ubuntu 11.04
    most of time my pointer's position changes to any random position itself. and sometime content of last copied lined get paste itself at current position. this spoils my text, I have to undo every time.
    I am very sure that I dont touch my touchpad.
    what can be wrong ? please suggest
    Join the next generation of computing, Open Source and Linux/GNU!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •