Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: How to get internal mic to work? (Toshiba Satellite L505D S5992)

  1. #1
    Join Date
    Sep 2008
    Location
    Ireland
    Beans
    27
    Distro
    Xubuntu 13.04 Raring Ringtail

    How to get internal mic to work? (Toshiba Satellite L505D S5992)

    I have a Toshiba Satellite L505D S5992 laptop, dualboot with Windows 7 64-bit and Ubuntu 10.04 64-bit. I installed the speed kernel of Ivanmmj: http://ubuntuforums.org/showthread.php?t=1301101&page=8

    Everything works fine, except the internal microphone, which is important to me as I use Skype a lot. Does anyone have the same problem, and better yet, a solution to this problem?

    Another thing that occurs, which may or may not be connected to the mic problem, is that at boot I get the following error message:

    pci 0000:03:00.0: BAR 6: no parent found for of device [0xfffe0000-0xfff]
    mount: mounting none on /dev failed: No such device
    init: ureadahead main process (350) terminated with status 5

    shpchp 0000.00:01.0 Cannot reserve MMIO region
    Any help would be very appreciated!

  2. #2
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,904
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: How to get internal mic to work? (Toshiba Satellite L505D S5992)

    First, for mic problem, check this.
    Gnome-alsamixer
    Using Alt+F2 run dialog
    Code:
     gnome-alsamixer
    Use 'Edit -> Sound Card Properties' menu to enable elements.
    Soundcard tab to select / adjust levels.
    To install:
    Code:
    sudo apt-get install gnome-alsamixer
    Then go to 'Sound Preferences' to select and unmute your mic in 'Input' tab.
    Use Pulse Audio Volume Control (pavucontrol) to unlock stereo sliders for the mic in 'Input Devices' tab.
    Drag the right slider down to zero. The mic is a mono device.

    From alsa documentation:
    Capture Problems
    ~~~~~~~~~~~~~~~~
    The capture problems are often because of missing setups of mixers.
    Thus, before submitting a bug report, make sure that you set up the
    mixer correctly. For example, both "Capture Volume" and "Capture
    Switch" have to be set properly in addition to the right "Capture
    Source" or "Input Source" selection. Some devices have "Mic Boost"
    volume or switch.

    When the PCM device is opened via "default" PCM (without pulse-audio
    plugin), you'll likely have "Digital Capture Volume" control as well.
    This is provided for the extra gain/attenuation of the signal in
    software, especially for the inputs without the hardware volume
    control such as digital microphones. Unless really needed, this
    should be set to exactly 50%, corresponding to 0dB -- neither extra
    gain nor attenuation. When you use "hw" PCM, i.e., a raw access PCM,
    this control will have no influence, though.

  3. #3
    Join Date
    Mar 2009
    Beans
    119

    Re: How to get internal mic to work? (Toshiba Satellite L505D S5992)

    I'm not an expert, but I had a similiar problem with a Toshiba M640.
    Try to go to the realtek website and download the latest alsa pack: realtek-linux-audiopack-5.15
    Follow UBUNTU instructions in the README file to install it.
    I hope it helps!

    Marcelo.

  4. #4
    Join Date
    Sep 2008
    Location
    Ireland
    Beans
    27
    Distro
    Xubuntu 13.04 Raring Ringtail

    Re: How to get internal mic to work? (Toshiba Satellite L505D S5992)

    Thanks a lot! I followed your advice by first installing the latest alsa pack, which I think I installed correctly. (Is there a way to check this?)

    Afterwards I installed GNOME ALSA Mixer and PulseAudio Volumecontrol and started trying out different settings. Two times I somehow got the mic to work with Sound Recorder and I could hear my voice played back. But every time I restarted I was literally back where I started. No mic, everything else working.

    My sound card has an ALC272 chipset and I read that more people have (had) problems with the mic and sound card. The frustrating thing is I don't remember what I did to make it work...
    Last edited by Comodín; August 17th, 2010 at 09:38 AM.

  5. #5
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,904
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: How to get internal mic to work? (Toshiba Satellite L505D S5992)

    Quote Originally Posted by Comodín View Post
    Thanks a lot! I followed your advice by first installing the latest alsa pack, which I think I installed correctly. (Is there a way to check this?)

    Afterwards I installed GNOME ALSA Mixer and PulseAudio Volumecontrol and started trying out different settings. Two times I somehow got the mic to work with Sound Recorder and I could hear my voice played back. But every time I restarted I was literally back where I started. No mic, everything else working.

    My sound card has an ALC272 chipset and I read that more people have (had) problems with the mic and sound card. The frustrating thing is I don't remember what I did to make it work...
    What are your motherboard specs:
    Code:
    sudo dmidecode -t bios
    sudo dmidecode -t baseboard

  6. #6
    Join Date
    Sep 2008
    Location
    Ireland
    Beans
    27
    Distro
    Xubuntu 13.04 Raring Ringtail

    Re: How to get internal mic to work? (Toshiba Satellite L505D S5992)

    The result of: sudo dmidecode -t bios

    Code:
    SMBIOS 2.6 present.
    
    Handle 0x0000, DMI type 0, 24 bytes
    BIOS Information
    	Vendor: Insyde Corp.
    	Version: 1.10
    	Release Date: 12/17/2009
    	ROM Size: 2048 kB
    	Characteristics:
    		PCI is supported
    		BIOS is upgradeable
    		BIOS shadowing is allowed
    		Boot from CD is supported
    		Selectable boot is supported
    		BIOS ROM is socketed
    		EDD is supported
    		Japanese floppy for NEC 9800 1.2 MB is supported (int 13h)
    		Japanese floppy for Toshiba 1.2 MB is supported (int 13h)
    		5.25"/360 KB floppy services are supported (int 13h)
    		5.25"/1.2 MB floppy services are supported (int 13h)
    		3.5"/720 KB floppy services are supported (int 13h)
    		3.5"/2.88 MB floppy services are supported (int 13h)
    		8042 keyboard services are supported (int 9h)
    		CGA/mono video services are supported (int 10h)
    		ACPI is supported
    		USB legacy is supported
    		Targeted content distribution is supported
    	BIOS Revision: 10.240
    And: sudo dmidecode -t baseboard

    Code:
    SMBIOS 2.6 present.
    
    Handle 0x0002, DMI type 2, 16 bytes
    Base Board Information
    	Manufacturer: TOSHIBA
    	Product Name: Portable PC
    	Version: Base Board Version
    	Serial Number: None
    	Asset Tag: No Asset Tag
    	Features:
    		Board is a hosting board
    		Board is replaceable
    	Location In Chassis: Base Board Chassis Location
    	Chassis Handle: 0x0003
    	Type: Motherboard
    	Contained Object Handles: 0

  7. #7
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,904
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: How to get internal mic to work? (Toshiba Satellite L505D S5992)

    Try this. Using a Terminal="Applications->Accessories->Terminal"
    Open this file for editing:
    Code:
     gksudo gedit /etc/modprobe.d/alsa-base.conf
    Insert this line at the bottom:
    Code:
     options snd-hda-intel model=auto
    Save. Close. Reboot. Check your levels in alsamixer.
    Code:
     alsamixer
    Press <F6> to select the correct soundcard.
    Press <F3> to show playback levels. <F4> selects capture levels [or use <Tab>]
    Use the left/right arrow keys to select and up/down arrow keys to change levels. <M> to mute/unmute.
    Go to "System ->Preferences ->Sound" and make sure the correct soundcard is default and adjust your profile on the hardware tab.
    On the output tab choose the correct device.

  8. #8
    Join Date
    Sep 2008
    Location
    Ireland
    Beans
    27
    Distro
    Xubuntu 13.04 Raring Ringtail

    Re: How to get internal mic to work? (Toshiba Satellite L505D S5992)

    Nope, didn't work either, but thanks for the effort. Apart from the mic not working, and the error message at boot, the Toshiba gets really hot using Ubuntu with speed kernel. I read that even this can be bypassed (tutning of visualization) but it's just not worth all the effort. I throw the towel in and sell this laptop and will never again buy a Toshiba.

    By the way, I'm not giving up on Ubuntu. I'm lovin'it. Am running Netbook Remix on my Acer Aspire ZG5 and Xubuntu on a old Armada M300.

  9. #9
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,904
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: How to get internal mic to work? (Toshiba Satellite L505D S5992)

    Try running this command in a terminal for 10.04 or later:
    Code:
    ubuntu-bug audio
    Reference the Ubuntu-Bug Audio link in my sig.

  10. #10
    Join Date
    Sep 2008
    Location
    Ireland
    Beans
    27
    Distro
    Xubuntu 13.04 Raring Ringtail

    Re: How to get internal mic to work? (Toshiba Satellite L505D S5992)

    I had a long break, but finally installed 10.10 and without any ACPI problem as described before (wit 10.04). The sound, however, is still an issue. I can't capture, have done all of the above (including the bug report) and was hoping you would still help me.

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •