Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 21

Thread: How to get internal mic to work? (Toshiba Satellite L505D S5992)

  1. #11
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,904
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: How to get internal mic to work? (Toshiba Satellite L505D S5992)

    Quote Originally Posted by Comodín View Post
    I had a long break, but finally installed 10.10 and without any ACPI problem as described before (wit 10.04). The sound, however, is still an issue. I can't capture, have done all of the above (including the bug report) and was hoping you would still help me.
    You may want to check for a bios update.Can you post the link to the bug report please? And for me this:
    Use the alsa-info-script to provide detailed information.
    Run this command in a terminal:
    Code:
    wget http://www.alsa-project.org/alsa-info.sh -O alsa-info.sh && bash alsa-info.sh
    Choose the upload option and provide a link for the output.
    [Terminal="Applications->Accessories->Terminal"]

  2. #12
    Join Date
    Sep 2008
    Location
    Ireland
    Beans
    27
    Distro
    Xubuntu 13.04 Raring Ringtail

    Re: How to get internal mic to work? (Toshiba Satellite L505D S5992)

    BIOS is up to date, if there's an update I should receive an e-mail from Toshiba. But I checked and I have the most recent BIOS. Strange thing is that I tried out the Live-CD of Mint 10 (64 bit) and the microphone captured out of the box, Skype worked. Strange, because I thought they derived Mint 10 from Ubuntu 10.10...

    Methinks this is what you asked for?:

    http://git.alsa-project.org/?p=alsa-...s/alsa-info.sh

  3. #13
    Join Date
    Sep 2008
    Location
    Ireland
    Beans
    27
    Distro
    Xubuntu 13.04 Raring Ringtail

    Re: How to get internal mic to work? (Toshiba Satellite L505D S5992)

    So, I thought maybe the Mint 10 Live-CD is working because it's a newer kernel or something. I downloaded the Ubuntu Live-CD (64 bit) again, installed it on a USB stick and if I run Ubuntu from the USB my mic is working and I can capture and Skype!! But alas, as soon as I install Ubuntu I'm back where I started, changing all the parameters but to no avail. The mic won't capture.

    Maybe it has to do with the comment I get before boot, the same one as in my first post, but only now this line:

    shpchp 0000.00:01.0 Cannot reserve MMIO region

  4. #14
    Join Date
    Oct 2006
    Location
    Milton Keynes, UK
    Beans
    1,141
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: How to get internal mic to work? (Toshiba Satellite L505D S5992)

    shpchp 0000.00:01.0 Cannot reserve MMIO region
    There is a but report on this here...

    https://bugs.launchpad.net/ubuntu/+s...ux/+bug/577842

    Does the id 00:01.0 relate to your sound card by any chance ?
    Check output of

    Code:
    lspci
    Linux Registered User #443947 Ubuntu Regestered User #12604

    Hakunamatata ...... No worries !

  5. #15
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,904
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: How to get internal mic to work? (Toshiba Satellite L505D S5992)

    Quote Originally Posted by Comodín View Post
    BIOS is up to date, if there's an update I should receive an e-mail from Toshiba. But I checked and I have the most recent BIOS. Strange thing is that I tried out the Live-CD of Mint 10 (64 bit) and the microphone captured out of the box, Skype worked. Strange, because I thought they derived Mint 10 from Ubuntu 10.10...

    Methinks this is what you asked for?:

    http://git.alsa-project.org/?p=alsa-...s/alsa-info.sh
    No. That's the script, I need the output.

  6. #16
    Join Date
    Sep 2008
    Location
    Ireland
    Beans
    27
    Distro
    Xubuntu 13.04 Raring Ringtail

    Re: How to get internal mic to work? (Toshiba Satellite L505D S5992)

    Sorry Lidex, I'm pretty new at Ubuntu, although the date I joined this community says different. Hopefully you meant this: https://docs.google.com/leaf?id=0Byu...thkey=CNWOur0B

    I restarted my laptop to see if the numbers of the MMIO region warning are still the same. In my last post I just copied these numbers from my first post, when I was still using 10.04. So I thought I'd check it. For some strange reason this time it did not show this comment, it booted straight from Grub to the desktop without any alert. And guess what, I tried out the sound recorder, opened Pulseaudio and Alsa Mixer and it recorded my voice.

    Afterwards I rebooted again and there was again unfortunately a (really quick) message of MMIO region, but I couldn't catch the numbers. And I booted again and again, always MMIO region warning and no capture.

    How do I boot with the command line (and with which command) so that I can see the whole boot sequence?

    How to check output of lspci???

  7. #17
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,904
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: How to get internal mic to work? (Toshiba Satellite L505D S5992)

    That's it. Try this then.
    Using a Terminal="Applications->Accessories->Terminal"
    Open this file for editing:
    Code:
     gksudo gedit /etc/modprobe.d/alsa-base.conf
    Insert this line at the bottom:
    Code:
     options snd-hda-intel model=auto
    Save. Close. Reboot.
    Check your levels in alsamixer.
    Code:
     alsamixer
    Press <F6> to select the correct soundcard.
    Press <F3> to show playback levels. <F4> selects capture levels [or use <Tab>]
    Use the left/right arrow keys to select and up/down arrow keys to change levels. <M> to mute/unmute.
    Go to "System ->Preferences ->Sound" and make sure the correct soundcard is default and adjust your profile on the hardware tab.
    On the output tab choose the correct device.

    If you run this command in a terminal, you can see the last boot sequence:
    Code:
    dmesg | less
    The above for scrolling, this next gives the whole thing at once:
    Code:
    dmesg
    lspci is done the same way, simply enter the command in a terminal and press enter.

    All your logs can be perused with log file viewer. It's good to have. The filename is gnome-system-log. To install:
    Code:
    sudo apt-get install gnome-system-log
    Resides in the 'Applications>System>Administration' menu

  8. #18
    Join Date
    Sep 2008
    Location
    Ireland
    Beans
    27
    Distro
    Xubuntu 13.04 Raring Ringtail

    Re: How to get internal mic to work? (Toshiba Satellite L505D S5992)

    Something seems to have worked, by inserting the extra line in alsa-base.conf. As soon as I reboot and open PulseAudio, I click on Input Device and select All Input Device, I can see that the microphone is capturing sound. (Both Front Right slides are silenced, by the way.)

    Unfortunately, as soon as I try to record with Soundrecorder, or change a setting with Alsamixer, the microphone freezes. I've tried this now several times.

    Thanks for the pointing out the existence of Log File Viewer, that comes in handy. The MMIO region comment seems to have something to do with r8187se, although I have a r8180?!?

    Code:
    [   13.935656] udev[437]: starting version 163
    [   14.014369] shpchp 0000:00:01.0: HPC vendor_id 1022 device_id 9602 ss_vid 1022 ss_did 9602
    [   14.014374] shpchp 0000:00:01.0: Cannot reserve MMIO region
    [   14.033273] r8187se: module is from the staging directory, the quality is unknown, you have been warned.

  9. #19
    Join Date
    Sep 2008
    Location
    Ireland
    Beans
    27
    Distro
    Xubuntu 13.04 Raring Ringtail

    Re: How to get internal mic to work? (Toshiba Satellite L505D S5992)

    The solution isn't the most elegant, but it works. I used the "solution" of uaaquarius in this post: http://ubuntuforums.org/showthread.php?p=10144940

    I added the extra line in alsa-base.conf and afterwards deleted Pulseaudio from Synaptic Package Manager. It worked and I can use Skype and record sound. Suddenly I have an extra slide in Alsa Mixer called Digital.

    Thank you for your assistance!
    Last edited by Comodín; December 24th, 2010 at 04:05 PM.

  10. #20
    Join Date
    Sep 2008
    Location
    Ireland
    Beans
    27
    Distro
    Xubuntu 13.04 Raring Ringtail

    Re: How to get internal mic to work? (Toshiba Satellite L505D S5992)

    The reason I haven't marked this Thread as solved is that I'm still trying to get Pulseaudio somehow to work. The solution mentioned above does work, though the quality of recording is much lower than the few times I got it to work with Pulseaudio and furthermore, the sound adjust button on my laptop doesn't work anymore.

    Every suggestion is welcome. Now planning to try and change model in alsa-base.conf randomly and see to what results that might lead.

Page 2 of 3 FirstFirst 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •