Results 1 to 4 of 4

Thread: Help Mounting CD-ROM on Server

  1. #1
    Join Date
    May 2007
    Beans
    5

    Help Mounting CD-ROM on Server

    I could use some help mounting a CD-ROM on Ubuntu 8.04 Server.

    The server is a virtual machine running on VMware ESXi 4.0. My goal is to install VMware tools. I have "inserted" the CD using VMware's management console.

    I've googled and tried several commands but I'm clueless... Help would be appreciated.

    Here's some output from "dmesg | less"
    ******
    [ 9.049123] ata1.00: ATAPI: VMware Virtual IDE CDROM Drive, 00000001, max UDMA/33
    [ 9.205070] ata1.00: configured for UDMA/33
    [ 9.205257] ata2: port disabled. ignoring.
    [ 9.205498] scsi 0:0:0:0: CD-ROM NECVMWar VMware IDE CDR00 1.00 PQ: 0 ANSI: 5
    [ 9.533754] Driver 'sr' needs updating - please use bus_type methods
    [ 9.535677] sr0: scsi3-mmc drive: 1x/1x xa/form2 cdda tray
    [ 9.535681] Uniform CD-ROM driver Revision: 3.20
    [ 9.535718] sr 0:0:0:0: Attached scsi CD-ROM sr0
    ******

    This is the output from "cat /proc/scsi/scsi"
    ******
    Attached devices:
    Host: scsi0 Channel: 00 Id: 00 Lun: 00
    Vendor: NECVMWar Model: VMware IDE CDR00 Rev: 1.00
    Type: CD-ROM ANSI SCSI revision: 05
    Host: scsi2 Channel: 00 Id: 00 Lun: 00
    Vendor: VMware Model: Virtual disk Rev: 1.0
    Type: Direct-Access ANSI SCSI revision: 02
    ******

  2. #2
    Join Date
    Oct 2006
    Beans
    4,619
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: Help Mounting CD-ROM on Server

    Try
    Code:
    sudo mount /dev/sr0 /media/cdrom
    Blog | Ubuntu User #15350 | Zsh FTW | Ubuntu Security | Nothing to hide?
    AMD Phenom II X6 1075T @ 3GHz, Nvidia GTX 650, 8GB DDR3 RAM, 2 X 1TB, 1 X 3TB HDD
    Please don't request support via PM


  3. #3
    Join Date
    May 2007
    Beans
    5

    Re: Help Mounting CD-ROM on Server

    FuturePilot, thanks for the response!

    Quote Originally Posted by FuturePilot View Post
    Try
    Code:
    sudo mount /dev/sr0 /media/cdrom
    When I try this I get:
    "mount: you must specify the filesystem type"

    So I googled and then tried:
    Code:
    sudo mount -t udf /dev/sr0 /media/cdrom
    mount: mount point /media/cdrom does not exist
    Any other thoughts?

  4. #4
    Join Date
    May 2007
    Beans
    5

    Re: Help Mounting CD-ROM on Server

    Ok, so overnight the VMware virtual CD ejected. I "re-inserted" so to speak and it is working. Here's what I had to do:

    create the subfolder "cdrom" under /media
    then:

    Code:
    sudo mount /dev/sr0 /media/cdrom
    This also worked:

    Code:
    sudo mount -t iso9660 /dev/sr0 /media/cdrom
    And for my fellow noobs out there, to unmount:

    Code:
    sudo umount /media/cdrom

    Thanks again for the assistance FuturePilot!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •