Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 26

Thread: D-link DWL-G122 revE1G not working on 10.04

  1. #11
    Join Date
    Oct 2006
    Location
    Sweden
    Beans
    14

    Re: D-link DWL-G122 revE1G not working on 10.04

    Working or atleast must be since im using it now hehe
    sometimes banging yer head helps...i'll try to clean this up and make a little guide tomorrow how i solved it

    many thx still kbratz im still rusty on ubuntu been away for too long i guess

  2. #12

    How to setup the USB NIC "D-link DWL-G122" on Ubuntu 10.04 (Lucid Lynx)

    Completing the Trazan's steps:

    1. Download Linux driver for RT3070USB from http://www.ralinktech.com/ (Software -> Linux)

    2. Unpack the tar & bz2 source package, be careful to don't leave spaces in the extracted directory name, open a terminal and go to contents' directory

    3.
    Code:
    cp RT2870STACard.dat RT3070STACard.dat
    cp RT2870STA.dat RT3070STA.dat
    cp common/rt2870.bin common/rt3070.bin
    sudo make
    sudo make install
    4. Add to /etc/modprobe.d/blacklist.conf
    Code:
    blacklist rt2800usb
    blacklist rt2x00usb
    blacklist rt2x00lib
    blacklist rt2870sta
    5. Make a new dir and copy a RT2870 file in it:
    Code:
    sudo mkdir /etc/Wireless/RT2870STA
    sudo cp /etc/Wireless/RT3070STA/RT3070STA.dat /etc/Wireless/RT2870STA/RT2870STA.dat
    6. Add RT3070STA in /etc/modules

    7. Restart the system

    As I see, Ralink corp published a RT2870 driver fo RT3070, that must be corrected and adapted to work with RT3070 USB device.
    Attached Files Attached Files
    Narcis Garcia

  3. #13
    Join Date
    Sep 2010
    Beans
    6

    Re: D-link DWL-G122 revE1G not working on 10.04

    Yes indeed.

    The Dlink Dwl-g122 rev.E1 drivers seem to be in disorder. The kernel regognizes this particular wlan stick and sets up a driver but that particular driver just don't work.

    I would like to set the right driver up in my xubuntu 10.04, according to the trazan-narcisgarcia -procedure, but I can't do it at the moment. It is because the xubuntu distro doesn't contain some necessary files in the /lib/modules/2.6.32-24-generic/build directory.

    If anybody knows their whereabouts I would be rather happy. I wont install any full ubuntu because my laptop is very old 700Mz 256Mb computer.

  4. #14

    Re: D-link DWL-G122 revE1G not working on 10.04

    If you have the "linux-generic" package installed, then try to install the "linux-headers-generic" also.

    The "build-essential" package may help too.
    Narcis Garcia

  5. #15
    Join Date
    Sep 2010
    Beans
    6

    Re: D-link DWL-G122 revE1G not working on 10.04

    Thank you all for the help. At this moment I am connected through the dwl-g122 rev.E1 wireless usb adapter. It seems to work and so my problem is solved.

    In xubuntu I had toi load the ccg compiler and the exactly same version of headerfiles as the kernel version I have before I was able to follow the peculiar prosedure of installing a working driver.

    I did encounter a small error at the following command

    sudo cp /etc/Wireless/RT3070STA/RT3070STA.dat /etc/Wireless/RT2870STA/RT2870STA.dat
    there was no such file (RT3070STA.dat) in the from directory, and so I just copied the one there was.

  6. #16
    Join Date
    Jan 2008
    Beans
    2

    Re: D-link DWL-G122 revE1G not working on 10.04

    Thanks!! It works!

    One small note, I think the module name should not be capatalized.
    So add rt3070sta instead of RT3070STA to /etc/modules

    At least
    Code:
    sudo modprobe rt3070sta
    worked for me (didn't reboot yet).

    Thanks again, I can finally remove the mess of cables running trough my room

  7. #17
    Join Date
    Jun 2007
    Beans
    2

    Re: D-link DWL-G122 revE1G not working on 10.04

    OK, some 10.10 specific initial results. It seems to work, but only after some tweaking, and honestly, I don't know if what I did was right.

    I tried the procedure described by narcisgarcia on 10.10, and run into some problems during the build process. I don't have the error message(s) at hand, but the functions usb_buffer_alloc and usb_buffer_free have something to do with the issue.

    ("Implicit declaration of usb_buffer_alloc" or something like that, and exiting with code 2.)

    From quick googling I concluded that those two functions have been renamed in the recent versions of the Linux kernel to usb_alloc_coherent and usb_free_coherent.

    Those function names are used in DPO_RT3070_LinuxSTA_V2.3.0.4_20100604/include/os/rt_linux.h. I simply changed usb_buffer_alloc into usb_alloc_coherent and usb_buffer_free to usb_free_coherent (lines 1014-1015) and retried make && make install. With this addition to narcisgarcia's instructions I got it working and am using it right now.

    HOWEVER, this is all based on very brief experimentation so I'd love to see someone more educated confirm that right things are being done here.

    I'm half guessing that the issue relates to changes in ther Linux kernel somewhere between versions 2.6.32 and 2.6.35, and not to Ubuntu alone.

    (Update: rephrased a bit for clarity)
    Last edited by jtirila; October 13th, 2010 at 01:12 PM.

  8. #18
    Join Date
    Nov 2008
    Location
    Flanders
    Beans
    35
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: D-link DWL-G122 revE1G not working on 10.04

    Hi Jtirila,

    Your suggestion is correct. The kernel is the problem with Ubuntu 10.10. My D-link DWL G-122 adapter is working fine since I changed my grub.

    Now the 32-kernel is loaded instead of the default 35-version. With the 35-version the adapter is detected but there's no connection.

  9. #19
    Join Date
    Jun 2007
    Beans
    2

    Re: D-link DWL-G122 revE1G not working on 10.04

    Quote Originally Posted by Magic_Spehar View Post

    Your suggestion is correct. The kernel is the problem with Ubuntu 10.10. My D-link DWL G-122 adapter is working fine since I changed my grub {to use kernel 2.6.32}.
    Yeah, so it seems. I considered that, too, but the newer kernel enables suspend for me so that's why went into modifying the DWL-G122 driver sources.

    It really seems to work fine after those two simple text edits and a rebuild.

  10. #20
    Join Date
    Nov 2010
    Beans
    1

    Re: D-link DWL-G122 revE1G not working on 10.04

    I had exactly the same problem with 10.04 but the above solution didn't work. After many hours I gave up and decided to try installing 10.10 and it worked right off the bat.

    Makes me wonder if the labelling of these wireless adapters is different from country to country (I bought mine in Spain).

    Anyway if your having problems with 10.04 try a copy of 10.10 as it may fix your problems.

Page 2 of 3 FirstFirst 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •