Results 1 to 6 of 6

Thread: How to "enable wireless" on startup"

  1. #1
    Join Date
    Aug 2010
    Location
    San Andreas, CA
    Beans
    23
    Distro
    Ubuntu 10.04 Lucid Lynx

    How to "enable wireless" on startup"

    My wireless works fine, but every time I boot I have to right click on the Network Manger Applet and enable wireless. Anybody know how to set this up?

  2. #2
    Join Date
    Jul 2005
    Location
    England
    Beans
    Hidden!

    Re: How to "enable wireless" on startup"

    Right click and choose edit connections. Highlight the active connaction and make sure the "connect automatically" box and "available to all users" are selected. That is normally all that is needed.
    DISTRO: Xubuntu 12.04-64bit --- Code-tags --- Boot-Repair --- Grub2 wiki & Grub2 Basics --- RootSudo

  3. #3
    Join Date
    Aug 2010
    Location
    San Andreas, CA
    Beans
    23
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: How to "enable wireless" on startup"

    yeah, tried that, but all it does is make my primary home wirless connect automatically...I still have to right click every time I startup.

  4. #4
    Join Date
    Aug 2010
    Location
    Elx
    Beans
    2

    Re: How to "enable wireless" on startup"

    Did you mean interface is down on startup?

    If that doesn't work, try to manually execute iwconfig activation command on init.d startup script

    iwconfig wlan0* up

    (*) whatever interface is

    if you don't know how to init.d works, look for example http://embraceubuntu.com/2005/09/07/...run-at-bootup/

  5. #5
    Join Date
    Jun 2010
    Location
    London, England
    Beans
    7,345
    Distro
    Ubuntu Development Release

    Re: How to "enable wireless" on startup"

    Another thing you may want to check is if you permission to use wireless in your user profile. System - Administration - Users and Groups - Advance settings - User privileges - Connect to wireless and ethernet networks. Somehow I got listed not under Administrator with access to everything but as having Custom privileges. It is possible that you are set up in the same way and not allowed access to networks. Just something to try.

    regards.

  6. #6
    Join Date
    Sep 2010
    Beans
    21

    Re: How to "enable wireless" on startup"

    try placing;
    nmcli nm wifi on
    in /etc/rc.local using;
    sudo nano /etc/rc.local
    -make sure to add the line before exit 0 in the file.
    -this will instruct network manager to enable wifi on every login
    -solved issue on Acer Aspire One 721, Ubuntu 10.10 x64

    (looks like (http://ubuntuforums.org/showthread.php?t=1563463) nmcli is only available in 10.10, I'd imagine you could accomplish the same thing using dbus-send in other versions)
    I am also using an Aspire one 721 and it worked

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •