Results 1 to 9 of 9

Thread: Ubuntu + Java Question

Hybrid View

  1. #1
    Join Date
    Aug 2010
    Location
    United States
    Beans
    12
    Distro
    Ubuntu 10.04 Lucid Lynx

    Ubuntu + Java Question

    Hey guys, I was wondering if I could get someone's help with something.

    A friend and I like to play those Yahoo! Games online and she's on a Mac and I'm on Ubuntu Linux. I tried on both Firefox and Google Chrome to get them to work, but with no luck. Apparently, from what I've read, JRE needs to be installed. I have that OpenJDK 6 thing but that was cause I installed something. As for official Sun stuff, how would I go about installing the real thing?

    I'm not too good with compiling, as I don't know how to yet, and I can't find a .deb of it anywhere. Is there a command line way to install it?

    Any help is much appreciated.

  2. #2
    Join Date
    Mar 2006
    Beans
    115
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Ubuntu + Java Question

    This looks like a winner of a solution :

    http://www.ubuntugeek.com/how-instal...ucid-lynx.html

  3. #3
    Join Date
    Aug 2010
    Location
    United States
    Beans
    12
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Ubuntu + Java Question

    Quote Originally Posted by flick View Post
    This looks like a winner of a solution :

    http://www.ubuntugeek.com/how-instal...ucid-lynx.html
    Thank you for the quick response. Problem though... When I try to follow those commands, from the get-go, the first one gives me this error: Error: need a repository as argument.

    What's that about? See, this is just my luck. What's simple for others is always broken or complicated for me lol.

  4. #4
    Join Date
    Mar 2006
    Beans
    115
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Ubuntu + Java Question

    sudo add-apt-repository “deb http://archive.canonical.com/ lucid partner”

    is what returned your error message of :

    Error: need a repository as argument

    ?

  5. #5
    Join Date
    Aug 2010
    Location
    United States
    Beans
    12
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Ubuntu + Java Question

    Quote Originally Posted by flick View Post
    sudo add-apt-repository “deb http://archive.canonical.com/ lucid partner”

    is what returned your error message of :

    Error: need a repository as argument

    ?
    Yep. I followed the directions on the site you referred me to to the t and they threw that error at me with the first Terminal command. But I think I figured it out.

    In the Software Sources, I can manually check and enable the "partner" repository. I did so, and then followed the second command (the apt-get-jre ones) and it's finally installing. Thank you for the help though, I appreciate it. I'll mark the thread as solved if it works when I try out the Yahoo! Games site.

  6. #6
    Join Date
    Mar 2006
    Beans
    115
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Ubuntu + Java Question

    Not sure why the add-apt-repository command is giving fits, but we'll just fix your problem :

    On your top panel, click System then click Administration then click Software Sources.

    It will ask for your password, give it.

    Click on the Other Software tab. You should see some entries for Lucid Partner repositories. Check their boxes. Click the close button. You'll get a message telling you to reload. Click the reload button. Wait a minute and that window will go away on its own.

    Then back in a terminal window :

    sudo apt-get update

    Followed by

    sudo apt-get install sun-java6-jre sun-java6-plugin sun-java6-fonts

  7. #7
    Join Date
    Aug 2010
    Location
    United States
    Beans
    12
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Ubuntu + Java Question

    Quote Originally Posted by flick View Post
    Not sure why the add-apt-repository command is giving fits, but we'll just fix your problem :

    On your top panel, click System then click Administration then click Software Sources.

    It will ask for your password, give it.

    Click on the Other Software tab. You should see some entries for Lucid Partner repositories. Check their boxes. Click the close button. You'll get a message telling you to reload. Click the reload button. Wait a minute and that window will go away on its own.

    Then back in a terminal window :

    sudo apt-get update

    Followed by

    sudo apt-get install sun-java6-jre sun-java6-plugin sun-java6-fonts
    Got it. It installed them already and I'm trying it out now. Firefox still doesn't seem to want to let any of the games work though and the pop-ups still show blank, grey windows instead of the things they're supposed to show.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •