Page 40 of 40 FirstFirst ... 30383940
Results 391 to 400 of 400

Thread: Howto: Build the svn MPlayer under the latest release version of Ubuntu

  1. #391
    Join Date
    Dec 2006
    Beans
    6,935

    Re: Howto: Build the svn MPlayer under the latest release version of Ubuntu

    Good to hear . My ~/.mplayer/config tends to be a little bare, has the following at the moment (for my slackware, vdpau-powered version):

    Code:
    # Andrew's choices for MPlayer defaults!
    
    # I prefer mpg123 playback for all mp3 files:
    #--------------
    [extension.mp3]
    profile-desc="profile for .mp3 files"
    ac=mpg123
    #--------------
    
    # Seems to work better for .mov files:
    #--------------
    [extension.mov]
    demuxer=mov
    #--------------
    
    # Try FFmpeg/libavcodec codecs first, they usually work best:
    #--------------
    afm=ffmpeg
    vfm=ffmpeg
    #--------------
    
    
    # If I use vdpau I prefer these video codecs:
    #--------------
    [vo.vdpau]
    vc=ffmpeg12vdpau,ffwmv3vdpau,ffvc1vdpau,ffh264vdpau,ffodivxvdpau,
    #--------------
    Any other settings I add from the commandline. The mpg123 setting is set to become the default soon enough when the default mp3lib is finally removed.
    You think that's air you're breathing now?

  2. #392
    Join Date
    Mar 2006
    Beans
    Hidden!

    Re: Howto: Build the svn MPlayer under the latest release version of Ubuntu

    Hmmm...problems with mplayer.

    Resizing the window will cause the picture/playback to seize up, unrecoverable and window either closes or has to be closed.

    Open a video file picture/playback will seize after a few frames, requires right arrow to get it going again

    If video playback is paused for @ 5 minutes, picture/playback seizes, cannot be recovered.

    (this happens with media files and dvb output)

    Xubuntu 12.04
    NVidia Ion proprietary drivers
    No Compositor

    Not had this before on previous installations (although haven't always compiled, just used the repo)

    Any suggestions welcome. May try reverting to repo version?
    Last edited by Jose Catre-Vandis; May 7th, 2012 at 10:49 PM. Reason: speelnig
    No longer participating......

  3. #393
    Join Date
    Dec 2006
    Beans
    6,935

    Re: Howto: Build the svn MPlayer under the latest release version of Ubuntu

    Which -vo are you using? Certainly might be worthwhile trying a different one:

    Code:
    andrew@skamandros~$ mplayer -vo help
    MPlayer SVN-r34885-4.7.0 (C) 2000-2012 MPlayer Team
    Available video output drivers:
    	vdpau	VDPAU with X11
    	xv	X11/Xv
    	gl_nosw	OpenGL no software rendering
    	x11	X11 ( XImage/Shm )
    	xover	General X11 driver for overlay capable video output drivers
    	sdl	SDL YUV/RGB/BGR renderer (SDL v1.1.7+ only!)
    	gl	OpenGL
    	gl2	X11 (OpenGL) - multiple textures version
    	dga	DGA ( Direct Graphic Access V2.0 )
    	fbdev	Framebuffer Device
    	fbdev2	Framebuffer Device
    	svga	SVGAlib
    	matrixview	MatrixView (OpenGL)
    	aa	AAlib
    	caca	libcaca
    	v4l2	V4L2 MPEG Video Decoder Output
    	xvidix	X11 (VIDIX)
    	cvidix	console VIDIX
    	null	Null video output
    	mpegpes	MPEG-PES to DVB card
    	yuv4mpeg	yuv4mpeg output for mjpegtools
    	png	PNG file
    	jpeg	JPEG file
    	gif89a	animated GIF output
    	tga	Targa output
    	pnm	PPM/PGM/PGMYUV file
    	md5sum	md5sum of each frame
    	mng	MNG file
    and it certainly would not hurt to try the repository MPlayer, but my suspicions lie with your video output device....
    You think that's air you're breathing now?

  4. #394
    Join Date
    Mar 2006
    Beans
    Hidden!

    Re: Howto: Build the svn MPlayer under the latest release version of Ubuntu

    Am in the wrong place at present, but from memory I have:
    Code:
    vo=vdpau,xv,gl
    in my config file. Same as with 11.10. I'll have a play around later.

    EDIT (didn't have any vo configured in mplayer config)

    Tried various -vo settings, none made any difference. Uninstalled compiled version, installed from repo, still no change.

    vlc and parole are fine.

    Video driver settings?
    Last edited by Jose Catre-Vandis; May 8th, 2012 at 07:12 PM. Reason: update
    No longer participating......

  5. #395
    Join Date
    Dec 2006
    Beans
    6,935

    Re: Howto: Build the svn MPlayer under the latest release version of Ubuntu

    If you run vdpau best to specify the -vc as well, an example a couple of posts up (in my ~/.mplayer/config. Other than this I am not sure what the problem could be I'm afaraid .
    You think that's air you're breathing now?

  6. #396
    Join Date
    Mar 2006
    Beans
    Hidden!

    Re: Howto: Build the svn MPlayer under the latest release version of Ubuntu

    Here are some errors when it seizes and is restarted using right arrow. These come at startup of film, and from moving the window.

    Code:
    mplayer A.Movie.mkv
    MPlayer svn r34540 (Ubuntu), built with gcc-4.6 (C) 2000-2012 MPlayer Team
    Loading extension-related profile 'extension.mkv'
    Loading extension-related profile 'vo.vdpau'
    
    Playing A.Movie.mkv.
    Cache fill:  0.00% (0 bytes)   
    
    libavformat version 53.21.0 (external)
    Mismatching header version 53.19.0
    libavformat file format detected.
    [matroska,webm @ 0x10c3d80]Estimating duration from bitrate, this may be inaccurate
    [lavf] stream 0: video (h264), -vid 0
    [lavf] stream 1: audio (aac), -aid 0
    [lavf] stream 2: subtitle (text), -sid 0
    VIDEO:  [H264]  1280x720  0bpp  23.976 fps    0.0 kbps ( 0.0 kbyte/s)
    Clip info:
     title: A.Movie.mkv
    Load subtitles in ./
    ==========================================================================
    Forced video codec: ffmpeg12vdpau
    Forced video codec: ffwmv3vdpau
    Forced video codec: ffvc1vdpau
    Forced video codec: ffh264vdpau
    Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
    libavcodec version 53.35.0 (external)
    Mismatching header version 53.32.2
    Selected video codec: [ffh264vdpau] vfm: ffmpeg (FFmpeg H.264 (VDPAU))
    ==========================================================================
    ==========================================================================
    Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
    AUDIO: 48000 Hz, 2 ch, s16le, 0.0 kbit/0.00% (ratio: 0->192000)
    Selected audio codec: [ffaac] afm: ffmpeg (FFmpeg AAC (MPEG-2/MPEG-4 Audio))
    ==========================================================================
    AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
    Starting playback...
    [VD_FFMPEG] Trying pixfmt=0.
    Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
    VO: [vdpau] 1280x720 => 1280x720 H.264 VDPAU acceleration 
    [VD_FFMPEG] XVMC-accelerated MPEG-2.
    A:  17.4 V:  17.4 A-V: -0.073 ct:  0.341   0/  0  0% 33%  2.8% 8 0 92% 
    [h264_vdpau @ 0x5eb06a0]Missing reference picture
    [h264_vdpau @ 0x5eb06a0]Missing reference picture
    [h264_vdpau @ 0x5eb06a0]Missing reference picture
    A:  28.1 V:  27.9 A-V:  0.160 ct:  0.020   0/  0 ??% ??% ??,?% 0 0 83% 
    [h264_vdpau @ 0x5eb06a0]Missing reference picture
    [h264_vdpau @ 0x5eb06a0]Missing reference picture
    [h264_vdpau @ 0x5eb06a0]Missing reference picture
    A:  28.1 V:  28.0 A-V:  0.148 ct:  0.024   0/  0 ??% ??% ??,?% 0 0 83% 
    [h264_vdpau @ 0x5eb06a0]mmco: unref short failure
    [h264_vdpau @ 0x5eb06a0]mmco: unref short failure
    [h264_vdpau @ 0x5eb06a0]mmco: unref short failure
    [h264_vdpau @ 0x5eb06a0]mmco: unref short failure
    A:  32.4 V:  32.4 A-V:  0.001 ct:  0.170   0/  0  0%  8%  3.1% 0 0 81% 
    
    Exiting... (Quit)
    Doesn't seem to matter which -vo I use, I get the same behaviour. Thanks for you help Andrew
    Last edited by Jose Catre-Vandis; May 9th, 2012 at 05:32 PM.
    No longer participating......

  7. #397
    Join Date
    Mar 2006
    Beans
    Hidden!

    Talking [SOLVED] freezing seizing mplayer

    Found the problem:
    Code:
    ao=alsa
    fix one thing, break another

    Recommended fix to compile with "--enable-pulse" ???
    No longer participating......

  8. #398
    Join Date
    Dec 2006
    Beans
    6,935

    Re: Howto: Build the svn MPlayer under the latest release version of Ubuntu

    That is a little odd, but you should have access to pulse as an ao following this guide so no need to recompile. For most of the libraries which MPlayer the --enable xxxxx option is not usually needed or indeed recommended.
    You think that's air you're breathing now?

  9. #399
    Join Date
    Mar 2006
    Beans
    Hidden!

    Re: Howto: Build the svn MPlayer under the latest release version of Ubuntu

    Agreed there is no need to compile for pulse. .mplayer/config now pared right back to:

    lirc=no
    vf=yadif

    and all is well

    No longer participating......

  10. #400
    Join Date
    Mar 2006
    Location
    Williams Lake
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Howto: Build the svn MPlayer under the latest release version of Ubuntu

    Closed, by request.

Page 40 of 40 FirstFirst ... 30383940

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •