Page 4 of 40 FirstFirst ... 2345614 ... LastLast
Results 31 to 40 of 400

Thread: Howto: Build the svn MPlayer under the latest release version of Ubuntu

  1. #31
    Join Date
    Dec 2006
    Beans
    6,935

    Re: Howto: Build the svn MPlayer under the latest release version of Ubuntu

    Hi mc4man,

    Quote Originally Posted by mc4man View Post
    As to whether a good idea to add or replace libass - can't say really, don't have a file to test with the rather short list of gstreamer players that would use libass
    Looks like the internal libass has pretty much caught up anyway:

    Code:
    andrew@skamandros~$ svn log -r r31932 svn://svn.mplayerhq.hu/mplayer/trunk
    ------------------------------------------------------------------------
    r31932 | greg | 2010-08-07 07:13:41 +1000 (Sat, 07 Aug 2010) | 1 line
    
    Import libass 0.9.10
    ------------------------------------------------------------------------
    Andrew
    You think that's air you're breathing now?

  2. #32
    Join Date
    Dec 2009
    Beans
    Hidden!
    Distro
    Kubuntu 10.04 Lucid Lynx

    Re: Howto: Build the svn MPlayer under the latest release version of Ubuntu

    I just wanted to add to this already excellent guide. Mencoder is the backbone of many great Linux video utilities. Removing it or not including it means many apps like Acidrip, K9, DeVeDe and more won't work. There is a simple solution to this. Compile x264 following FakeOutdoorsman's excellent guide here at http://ubuntuforums.org/showthread.php?t=786095

    Then follow andrew46's instructions to a T, when it comes to configure and install, its there you need to make the necessary changes.

    in ./configure, remove the disable x264 and disable mencoder lines

    It should look like

    Code:
    ./configure --confdir=/etc/mplayer
    then do a make, if you have dual core or more add the -jx command with x representing the number of cores. This speeds up the compile.

    After that the install code has to be

    Code:
    sudo checkinstall -D --install=yes --fstrans=no --pakdir "$HOME/Desktop" \
       --pkgname mplayer --backup=no --deldoc=yes --deldesc=yes --delspec=yes --default \
       --pkgversion "3:1.0~svn-`grep "#define VERSION" version.h | cut -d"-" -f2`" --provides "mplayer,mencoder"
    mplayer picks up the static ffmpeg and x264 build when its pre-installed and lets mencoder use them.

    After this your mencoder will be latest along with mplayer and use latest x264 and ffmpeg. I have tested this on Acidrip, DeVeDe and K9, using latest x264 speeds up conversion greatly as its optimized for your CPU unlike the older one in the repos. Even WinFF works fine once you edit out the 'b' in 'kB' from the presets.

    Make sure to lock ffmpeg, x264 and mplayer in synaptic.

    andrew, feel free to edit or remove this post if you don't find it pertinent to this thread and thank you again for your excellent guide.
    The finding of unity in variety is really what we call knowledge..... Vivekananda.

  3. #33
    Join Date
    Jul 2006
    Location
    Lancashire
    Beans
    Hidden!
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Howto: Build the svn MPlayer under the latest release version of Ubuntu

    Quote Originally Posted by Linuxforall View Post

    Make sure to lock ffmpeg, x264 and mplayer in synaptic.
    What does this mean?

  4. #34
    Join Date
    Dec 2009
    Beans
    Hidden!
    Distro
    Kubuntu 10.04 Lucid Lynx

    Re: Howto: Build the svn MPlayer under the latest release version of Ubuntu

    Quote Originally Posted by ron999 View Post
    What does this mean?
    In synaptic, highlight these packages and then select lock in properties.
    The finding of unity in variety is really what we call knowledge..... Vivekananda.

  5. #35
    Join Date
    Jul 2006
    Location
    Lancashire
    Beans
    Hidden!
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Howto: Build the svn MPlayer under the latest release version of Ubuntu

    Quote Originally Posted by Linuxforall View Post
    In synaptic, highlight these packages and then select lock in properties.
    I don't see an option to lock in Properties.
    Just:-
    Common
    Dependencies
    Installed Files
    Versions
    Description

  6. #36
    Join Date
    Jun 2007
    Beans
    13,064

    Re: Howto: Build the svn MPlayer under the latest release version of Ubuntu

    In synaptic, highlight these packages and then select lock in properties.
    There should be no need to do this - mplayer, x264, ect. builds from these guides should be versioned higher than any ubuntu versions.

    (the option is seen when highlighting a package - then click on the package tab in synaptic

  7. #37
    Join Date
    Jul 2006
    Location
    Lancashire
    Beans
    Hidden!
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Howto: Build the svn MPlayer under the latest release version of Ubuntu

    Quote Originally Posted by mc4man View Post
    (the option is seen when highlighting a package - then click on the package tab in synaptic
    Yes, in 'Package' it shows 'Lock Version'.

  8. #38
    Join Date
    Dec 2006
    Beans
    6,935

    Re: Howto: Build the svn MPlayer under the latest release version of Ubuntu

    Hi Linuxforall,

    Thanks for adding in the MEncoder details . I will admit my enthusiasm for MEncoder died a while back when FakeOutdoorsman's guide introduced me to FFmpeg. It died a little further when I realised that there is little active development of MEncoder and that the program is really only aimed at using the avi container, I realise other containers are possible but not well supported. Having said that I acknowledge that many fine programs use MEncoder as their backend, as you have mentioned.

    You might consider adding to your post the vital -dev files for faac and lame which enable transcoding to aac and mp3 respectively. MEncoder can of course be tested for transcoding options as follows:

    Code:
    andrew@skamandros~$ mencoder -ovc help
    MEncoder SVN-r31983-4.4.4 (C) 2000-2010 MPlayer Team
    
    Available codecs:
       copy     - frame copy, without re-encoding. Doesn't work with filters.
       frameno  - special audio-only file for 3-pass encoding, see DOCS.
       raw      - uncompressed video. Use fourcc option to set format explicitly.
       nuv      - nuppel video
       lavc     - libavcodec codecs - best quality!
       vfw      - VfW DLLs, read DOCS/HTML/en/encoding-guide.html.
       qtvideo  - QuickTime DLLs, currently only SVQ1/3 are supported.
       x264     - H.264 encoding
    
    andrew@skamandros~$ mencoder -oac help
    MEncoder SVN-r31983-4.4.4 (C) 2000-2010 MPlayer Team
    
    Available codecs:
       copy     - frame copy, without re-encoding (useful for AC3)
       pcm      - uncompressed PCM audio
       mp3lame  - cbr/abr/vbr MP3 using libmp3lame
       lavc     - FFmpeg audio encoder (MP2, AC3, ...)
       faac     - FAAC AAC audio encoder
    Thanks for your very helpful post!

    Andrew
    You think that's air you're breathing now?

  9. #39
    Join Date
    Dec 2009
    Beans
    Hidden!
    Distro
    Kubuntu 10.04 Lucid Lynx

    Re: Howto: Build the svn MPlayer under the latest release version of Ubuntu

    Thanks andrew, can you tell me which other dev files to add specifically.
    The finding of unity in variety is really what we call knowledge..... Vivekananda.

  10. #40
    Join Date
    Dec 2009
    Beans
    Hidden!
    Distro
    Kubuntu 10.04 Lucid Lynx

    Re: Howto: Build the svn MPlayer under the latest release version of Ubuntu

    Quote Originally Posted by mc4man View Post
    There should be no need to do this - mplayer, x264, ect. builds from these guides should be versioned higher than any ubuntu versions.

    (the option is seen when highlighting a package - then click on the package tab in synaptic
    The reason to take this safeguard is when you add ppas from other sources, the vlc c.korn ppa has newer ffmpeg which it might try and update, same goes for other ppas.
    The finding of unity in variety is really what we call knowledge..... Vivekananda.

Page 4 of 40 FirstFirst ... 2345614 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •