Page 11 of 40 FirstFirst ... 91011121321 ... LastLast
Results 101 to 110 of 400

Thread: Howto: Build the svn MPlayer under the latest release version of Ubuntu

  1. #101
    Join Date
    Dec 2005
    Beans
    12
    Distro
    Kubuntu 9.10 Karmic Koala

    Re: Howto: Build the svn MPlayer under the latest release version of Ubuntu

    Could be mplayer itself (svn buggy code). I compiled mplayer on 10.10 (version) at 10.10 (date) without problems. Today i got the same errors as you.

  2. #102
    Join Date
    Jul 2006
    Location
    Lancashire
    Beans
    Hidden!
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Howto: Build the svn MPlayer under the latest release version of Ubuntu

    Yes, me too.
    Tried to update today.
    Buggy code.

    Code:
    ffmpeg/libavcodec/libavcodec.a(ffv1.o): In function `decode_frame':
    ffv1.c:(.text+0xfb3): undefined reference to `init_slice_state'
    ffmpeg/libavcodec/libavcodec.a(ffv1.o): In function `decode_init':
    ffv1.c:(.text.unlikely+0x402): undefined reference to `init_slice_contexts'
    collect2: ld returned 1 exit status
    make: *** [mplayer] Error 1
    ron@ubuntu:~/mplayer$

  3. #103
    Join Date
    Oct 2010
    Location
    United Kingdom
    Beans
    1

    Re: Howto: Build the svn MPlayer under the latest release version of Ubuntu

    Code:
    ffv1.c:(.text.unlikely+0x402): undefined reference to `init_slice_contexts'
    collect2: ld returned 1 exit status
    make: *** [mplayer] Error 1
    A couple of days ago I checked out Revision: 32483 and it builds fine with these instructions.

    Revision: 32493 checked out today fails with the above error, so yes, it's the mplayer repo not the instructions

  4. #104
    Join Date
    Dec 2006
    Beans
    7,197

    Re: Howto: Build the svn MPlayer under the latest release version of Ubuntu

    Good news, the following compiled:

    Code:
    andrew@skamandros~$ mplayer | head -n 1
    MPlayer SVN-r32493-4.3.3 (C) 2000-2010 MPlayer Team
    But not for sminki?

    Edit: I see the confusion on my part, I was using an older gcc. Using Maverick's default gcc build still fails:

    Code:
    ffmpeg/libavcodec/libavcodec.a(ffv1.o): In function `decode_frame':
    ffv1.c:(.text+0x10cf): undefined reference to `init_slice_state'
    ffmpeg/libavcodec/libavcodec.a(ffv1.o): In function `decode_init':
    ffv1.c:(.text.unlikely+0x563): undefined reference to `init_slice_contexts'
    collect2: ld returned 1 exit status
    make: *** [mplayer] Error 1
    I will see if #mplayer might be interested.....

    Andrew
    Last edited by andrew.46; October 16th, 2010 at 03:29 AM.
    You think that's air you're breathing now?

  5. #105
    Join Date
    Dec 2006
    Beans
    7,197

    Re: Howto: Build the svn MPlayer under the latest release version of Ubuntu

    A temporary workaround:

    Code:
    svn up -r 23802 $HOME/mplayer_build/mplayer/ffmpeg/libavcodec/ffv1.c
    and compilation will succeed. Hopefully this will be fixed soon, remember svn up will overwrite this reversion...

    Andrew
    Last edited by andrew.46; October 16th, 2010 at 05:10 AM.
    You think that's air you're breathing now?

  6. #106
    Join Date
    Jun 2007
    Beans
    14,127

    Re: Howto: Build the svn MPlayer under the latest release version of Ubuntu

    Hopefully this will be fixed soon
    I would think so - just a bit of a warning becoming a linking error, if your were to enable mencoder/x264 it shouldn't happen

  7. #107
    Join Date
    Dec 2006
    Beans
    7,197

    Re: Howto: Build the svn MPlayer under the latest release version of Ubuntu

    Hi mc4man,

    Quote Originally Posted by mc4man View Post
    I would think so - just a bit of a warning becoming a linking error, if your were to enable mencoder/x264 it shouldn't happen
    Indeed, and this solves the puzzle as to why it compiles on my Slackware computer and not on my wife's 64bit computer: I compile MEncoder on Slackware but not on Ubuntu. Call for help here.

    Andrew
    Last edited by andrew.46; October 16th, 2010 at 08:44 AM.
    You think that's air you're breathing now?

  8. #108
    Join Date
    Dec 2009
    Beans
    Hidden!
    Distro
    Kubuntu 10.04 Lucid Lynx

    Re: Howto: Build the svn MPlayer under the latest release version of Ubuntu

    Quote Originally Posted by andrew.46 View Post
    Hi mc4man,



    Indeed, and this solves the puzzle as to why it compiles on my Slackware computer and not on my wife's 64bit computer: I compile MEncoder on Slackware but not on Ubuntu. Call for help here.

    Andrew
    I always compile with mencoder so it never ever fails here, I do compile x264 and ffmpeg first.
    The finding of unity in variety is really what we call knowledge..... Vivekananda.

  9. #109
    Join Date
    Dec 2006
    Beans
    7,197

    Re: Howto: Build the svn MPlayer under the latest release version of Ubuntu

    Hi Linuxforall,

    Quote Originally Posted by Linuxforall View Post
    I always compile with mencoder so it never ever fails here, I do compile x264 and ffmpeg first.
    This guide used to compile MEncoder and x264 before but I will admit that I tired of wrestling with the nest of dependencies created by the dependency tracking scheme, a cleaner option was to compile MPlayer alone. Then there was the issue of lack of development of MEncoder, its use of avi as its native container, lack of time on my part and a few other reasons...

    Andrew
    You think that's air you're breathing now?

  10. #110
    Join Date
    Dec 2009
    Beans
    Hidden!
    Distro
    Kubuntu 10.04 Lucid Lynx

    Re: Howto: Build the svn MPlayer under the latest release version of Ubuntu

    As I mentioned before almost any and every DVD conversion program in Linux depends on mencoder, be it K9 in KDE or Acidrip in Gnome or more so I got no choice here. Your guide with just the minor ommision in ./configure and an addition in checkinstall works out mighty fine.
    The finding of unity in variety is really what we call knowledge..... Vivekananda.

Page 11 of 40 FirstFirst ... 91011121321 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •