Results 1 to 6 of 6

Thread: 10.04 only showing 3.2GB memory w/4GB installed

  1. #1
    Join Date
    Dec 2006
    Beans
    19
    Distro
    Ubuntu 10.04 Lucid Lynx

    Question 10.04 only showing 3.2GB memory w/4GB installed

    As the title states, I'm only seeing 3.2GB of memory with 4GB installed.

    Code:
    --> free -m
                 total       used       free     shared    buffers     cached
    Mem:          3277        990       2286          0         58        388
    -/+ buffers/cache:        543       2733
    Swap:         2933          0       2933
    -->
    My mainboard is a MSI K8N Neo4 Platinum. I have 4GB of OCZ memory installed. 2GB just recently installed. In the bios, I've enabled the memory hole remapping for both HW/SW. It is not a shared memory with the onboard video. I have the onboard video disabled. I have a dedicated Nvidia card. The Bios does show a full 4GB in the system information section.

    So... my question is. I thought that 10.04, was supposed to have the pae kernel enabled by default. Is that not the case?

    Code:
    --> uname -r
    2.6.32-24-generic
    -->
    Is the fix to install the pae kernel?

    Thanks for any input!

  2. #2
    prodigy_ is offline May the Ubuntu Be With You!
    Join Date
    Mar 2008
    Beans
    1,219

    Re: 10.04 only showing 3.2GB memory w/4GB installed

    You've installed a 32-bit version without PAE kernel. If you want to get the "missing" RAM back, you need to either move to PAE kernel (this is the officially recommended solution) or download a native 64-bit version of Ubuntu and reinstall (but keep in mind that native 64-bit versions have some very annoying issues like the lack of proper Flash support).
    Last edited by prodigy_; July 28th, 2010 at 01:49 PM.

  3. #3
    Join Date
    Nov 2007
    Location
    Les Gets, France
    Beans
    721
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: 10.04 only showing 3.2GB memory w/4GB installed

    Acer Aspire 1353 Bodhilinux 2.4.0
    Toshiba A200 14.04(64 bit)
    Asus EeePC 1011PX 14.04 (32 bit) dual boot W7

  4. #4
    Join Date
    Dec 2006
    Beans
    19
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: 10.04 only showing 3.2GB memory w/4GB installed

    I know how to enable the pae kernel... I had just heard reports that it was there by default when 10.04 was installed.

    I had enabled the pae kernel earlier this week, but still only saw 3.2GB of memory. I'm pretty sure that was caused by not having the memory hole mapping settings correct in the BIOS. As the bios only showed 3.2GB until I changed that.

    So, I'm guessing that installing pae this time around will give me my full 4GB of memory now.

    When I did install the pae kernel earlier this week, I ran into a little snafu. When it came up, it put me into low video mode (800x600). It couldn't find a valid Nvidia driver.

    Does anyone know if this is resolved? I've searched, but haven't found anything but what looks like a hack that someone has propagated to just about every forum that pops up on a search.

    I'm not sure if I want the trouble of messing with trying to get a Nvidia driver working, versus the extra 700MB of memory that I'll gain...

    Thoughts?

  5. #5
    prodigy_ is offline May the Ubuntu Be With You!
    Join Date
    Mar 2008
    Beans
    1,219

    Re: 10.04 only showing 3.2GB memory w/4GB installed

    Quote Originally Posted by terry_opie View Post
    I had just heard reports that it was there by default when 10.04 was installed.
    It's not included on the CD. You need to have a working Internet connection during the installation to get PAE kernel installed by default.

  6. #6
    Join Date
    Dec 2006
    Beans
    19
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: 10.04 only showing 3.2GB memory w/4GB installed

    Marked this as solved, since running pae kernel solved the issue.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •