Results 1 to 4 of 4

Thread: android SDK problems

  1. #1
    Join Date
    May 2009
    Location
    E-Quad
    Beans
    16
    Distro
    Ubuntu 10.04 Lucid Lynx

    Exclamation android SDK problems

    Hi, I am having some minor issues with the android SDK. Specifically in the tools directory of the sdk if i try to run the command android without any arguments to launch the GUI SDK and AVD manager I get the following error:


    Code:
    Exception in thread "main" java.lang.UnsatisfiedLinkError: no swt-gtk-3550 or swt-gtk in swt.library.path, java.library.path or the jar file
    	at org.eclipse.swt.internal.Library.loadLibrary(Unknown Source)
    	at org.eclipse.swt.internal.Library.loadLibrary(Unknown Source)
    	at org.eclipse.swt.internal.C.<clinit>(Unknown Source)
    	at org.eclipse.swt.internal.Converter.wcsToMbcs(Unknown Source)
    	at org.eclipse.swt.internal.Converter.wcsToMbcs(Unknown Source)
    	at org.eclipse.swt.widgets.Display.<clinit>(Unknown Source)
    	at com.android.sdkmanager.Main.showMainWindow(Main.java:265)
    	at com.android.sdkmanager.Main.doAction(Main.java:249)
    	at com.android.sdkmanager.Main.run(Main.java:94)
    	at com.android.sdkmanager.Main.main(Main.java:83)
    the command
    Code:
    android list
    seems to work fine, and I have installed Eclipse 3.5 and the ADT plugin and I can launch the android SDK and AVD manager from there without problems. I am running Lucid (10.04) on an i686 Thinkpad T60. I have installed both sun-java6-jdk and openjdk6 and tried switching between them but still no dice.

  2. #2
    Join Date
    Apr 2009
    Location
    Papakura, NEW ZEALAND
    Beans
    42
    Distro
    Ubuntu Development Release

    Re: android SDK problems

    Did you ever solve this? I had the same issue 12 months on. I discovered that it was because I had made the /tmp directory "noexec" as soon as I made it executable, we were fine.
    Code:
    sudo mount -o remount,exec /tmp
    Hope this helps someone.
    Last edited by dionblundell; July 29th, 2011 at 09:30 PM.
    Ubuntu 10.04 NBR on Asus EeePC 1005PE

    If you don't hear back from me, I forgot to subscribe to the thread, sorry... send me a message, to give me a poke and wake me up.

  3. #3
    Join Date
    Sep 2006
    Beans
    2

    Re: android SDK problems

    Quote Originally Posted by dionblundell View Post
    Did you ever solve this? I had the same issue 12 months on. I discovered that it was because I had made the /tmp directory "noexec" as soon as I made it executable, we were fine.
    Code:
    sudo mount -o remount,exec /tmp
    Hope this helps someone.
    YES! Thank you! (How on earth did you figure this one out???)

    Been scratching my head over this all day 'til I found your lone little note. Fixed the problem immediately. (Kubuntu with tmpfs /tmp noexec..)

  4. #4
    Join Date
    Nov 2010
    Beans
    4

    Re: android SDK problems

    Thank you!!!!
    How on earth did you figure it???
    Anyway thanks!!!!!!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •