Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 28

Thread: Grub2 problems - Ubuntu won't start

  1. #11
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,175
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Grub2 problems - Ubuntu won't start

    Quote Originally Posted by olamina View Post
    This leads me to believe that there are no boot files on sdb or sdc. Why is this the case? Shouldn't the Ubuntu install have sorted this all out
    Hmmmm.... the long array of drives/partitions is making it a bit confusing for me, but here's what I guess to be your problem....

    Currently you have two internal HDDs (1TB & 160GB) and an external one (20GB??). Now Grub2 is installed (only) on 1TB drive (sda) and (if consulted) will look for boot files on the same drive. But there aren't any boot files on it!!

    Next, your 160GB drive (sdb) is the only one which has 'No boot loader' on its MBR. However it does have the boot files. I guess this is the drive where Lucid got installed somehow, whereas Grub got installed on sda due to some mistake or misconfiguration.

    Let's forget about the external drive (sdc) for sometime.

    Now combining this situation with the error message you are getting-
    On reboot I get a "no boot signature in partition".
    - it seems like your computer is trying to boot from the 160GB drive (sdb) where there is no boot loader.

    Now if this is right, here's a quick fix-

    1. disconnect the external drive and boot off a live cd
    2. install GRUB on sdb (using sudo fdisk -l command, make sure sdb is the 160GB drive)
    3. run sudo update-grub.
    4. reboot and see if it boots into Lucid. You may connect your external HDD then.
    Last edited by varunendra; July 29th, 2010 at 06:44 AM. Reason: to highlight fdisk command.

  2. #12
    Join Date
    Jul 2010
    Location
    Radovljica, Slovenia
    Beans
    38
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Grub2 problems - Ubuntu won't start

    Currently you have two internal HDDs (1TB & 160GB) and an external one (20GB??). Now Grub2 is installed (only) on 1TB drive (sda) and (if consulted) will look for boot files on the same drive. But there aren't any boot files on it!!
    Well I have one internal HD (20GB( and two external (160 GB and 1 TB). Ubuntu was previously running on the 160GB drive when it was partitioned. I thought the new Ubuntu install erased everything on that drive and gave me everything I needed, but it didn't. I have no idea what Grub2 is doing on the 1TB drive

    Now if this is right, here's a quick fix-

    1. disconnect the external drive and boot off a live cd
    2. install GRUB on sdb (using sudo fdisk -l command, make sure sdb is the 160GB drive)
    3. run sudo update-grub.
    4. reboot and see if it boots into Lucid. You may connect your external HDD then.
    As I mentioned sdc is the only INTERNAL drive in the lineup. Should I still go in and disconnect it. I am running off the Live Disk at the moment, isn't there anyway I can go do something like a good old fashioned dos "CD" command and install that way? Thanks for all your help. I'm doing nothing til I hear back from you.

  3. #13
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,175
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Grub2 problems - Ubuntu won't start

    So which drive do you wish to install Lucid in? I'd suggest the one with maximum free space.
    You can check it with gparted.

  4. #14
    Join Date
    Jul 2010
    Location
    Radovljica, Slovenia
    Beans
    38
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Grub2 problems - Ubuntu won't start

    Ubuntu should "already" be installed on the 160GB external drive. I went through the installation process on it. Not sure what happened. If it's not installed, then that is where i *want* it to be.

  5. #15
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,175
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Grub2 problems - Ubuntu won't start

    Quote Originally Posted by olamina View Post
    Ubuntu should "already" be installed on the 160GB external drive. I went through the installation process on it. Not sure what happened. If it's not installed, then that is where i *want* it to be.
    I can see two possibilities. Try any one of them:

    1. To install Grub on sdb itself, disconnect all except sdb (160GB) and reinstall grub on it booting off LiveCD. Then reboot without connecting others and post the result.
    2. To install Grub on the fixed drive (sdc-20GB) disconnect only sda (1TB) and do the following:


    • Booting off live CD, remove LILO first
      Code:
      lilo -u /dev/sdx
      where x has to be replaced by the letter your fixed HDD has been assigned. (check it with sudo fdisk -l command)
    • Install Grub2 on it
      Code:
      sudo grub-install /dev/sdx
      (in case you are having problem uninstalling lilo, just skip previous step and come directly to this one. Grub may simply overwrite lilo)
    • Run
      Code:
      sudo update-grub
    • Reboot and post here what happens.

    I'd recommend to go with option 1 because in option 2, booting will fail everytime the external drive is removed.
    Last edited by varunendra; July 29th, 2010 at 12:16 PM. Reason: major correction!

  6. #16
    Join Date
    Jul 2010
    Location
    Radovljica, Slovenia
    Beans
    38
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Grub2 problems - Ubuntu won't start

    i tried option 2. alas i don't think it worked. here is what i got.

    ubuntu@ubuntu:~$ lilo -u /dev/sda
    The program 'lilo' is currently not installed. You can install it by typing:
    sudo apt-get install lilo
    ubuntu@ubuntu:~$ sudo bash ~/Desktop/boot_info_script*.sh
    Identifying MBRs...
    Computing Partition Table of /dev/sda...
    Searching sda1 for information...
    Searching sda2 for information...
    Searching sda5 for information...
    Finished. The results are in the file RESULTS1.txt located in /home/ubuntu/Desktop
    ubuntu@ubuntu:~$ lilo -u /dev/sda1
    The program 'lilo' is currently not installed. You can install it by typing:
    sudo apt-get install lilo
    ubuntu@ubuntu:~$ sudo grub-install /dev/sda
    /usr/sbin/grub-probe: error: cannot find a device for /boot/grub (is /dev mounted?).
    No path or device is specified.
    Try `/usr/sbin/grub-probe --help' for more information.
    Auto-detection of a filesystem module failed.
    Please specify the module with the option `--modules' explicitly.
    ubuntu@ubuntu:~$ sudo update-grub
    /usr/sbin/grub-probe: error: cannot find a device for / (is /dev mounted?).
    looking forward to hearing from you when you have more time. thanks so much for your effort. this makes the switch to linux a bit less frightening.

  7. #17
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,175
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Grub2 problems - Ubuntu won't start

    To uninstall lilo, try the method you used to uninstall it from sdb.

    Before installing Grub, the destination drive needs to be mounted.
    First, make sure the drive is detected as sda (and installation partition is detected as sda1) Use:
    Code:
    sudo fdisk -l
    To install grub, you may need to chroot. Follow instructions as given here.

  8. #18
    Join Date
    Jul 2010
    Beans
    6
    Distro
    Ubuntu Development Release

    Re: Grub2 problems - Ubuntu won't start

    http://support.microsoft.com/kb/330184

    I think this might help you to rebuild your Boot.ini because it looks like your Boot.ini is missing (might be missing; not so sure)but make sure you have existing installation of Windows XP your computer
    Last edited by chong601; July 29th, 2010 at 09:50 AM. Reason: not so clear

  9. #19
    Join Date
    Jul 2010
    Location
    Radovljica, Slovenia
    Beans
    38
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Grub2 problems - Ubuntu won't start

    To uninstall lilo, try the method you used to uninstall it from sdb.
    I didn't uninstall lilo from sdb. When I installed Ubuntu to sdb, I think it removed Lilo by default. How do I remove Lilo? I've tried just about everything.

    Before installing Grub, the destination drive needs to be mounted.
    To install grub, you may need to chroot. Follow instructions as given here.
    well this is what i got when i tried that...

    ubuntu@ubuntu:~$ sudo mount /dev/sda1/mnt
    mount: can't find /dev/sda1/mnt in /etc/fstab or /etc/mtab

    what now? i don't even know what linux is doing on sda. should i remove it? how?

    I think this might help you to rebuild your Boot.ini because it looks like your Boot.ini is missing (might be missing; not so sure)but make sure you have existing installation of Windows XP your computer
    I don't have a windows boot disk at the moment. i downloaded one but i cannot burn it to dvd until i get my ubuntu back up and running since the only dvd drive i have is on this machine.

    thanks so much!

  10. #20
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,175
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Grub2 problems - Ubuntu won't start

    what now? i don't even know what linux is doing on sda. should i remove it? how?
    Ohh.... Big mistake on my part!!
    While suggesting option 2, I forgot that you want to install Lucid in your 160GB drive (sdb). So you MUST leave that one connected!!

    In this situation, option 1 is the best way to go (leave ONLY sdb connected) if you are sure that Lucid was installed there. Since it is an external drive, it is best that you have Grub installed on it rather than the fixed drive. You can always change the booting device from boot device menu or in the BIOS itself.
    So do it now and follow the GRUB installation method from the link I provided.

    And oh, there is a space between /dev/sda1 and /mnt. Try copy-pasting commands to avoid typo/syntax errors.

    Sorry for the confusing suggestion earlier. I'll be here till it is done (if YOU don't give up first of-course). And no need to thank me.... its kinda fun-activity for me

    I'm going to edit my earlier post to make it correct.

Page 2 of 3 FirstFirst 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •