Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: Large *.mp4 Files in gtkpod

  1. #1
    Join Date
    Jul 2010
    Location
    Ohio
    Beans
    50
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Large *.mp4 Files in gtkpod

    Hi, guys.

    I'm fairly new to Ubuntu, but I've been able to resolve most of my problems with a little searching and this site has been invaluable to me. Finally, however, I have come across something that nobody else seems to have asked.

    Currently, I am dual booting XP and Ubuntu 10.04, but in the future I will be getting a new machine and I will only be running Ubuntu and won't have access to iTunes. Because I have an iPod Touch, I have been trying to find workarounds for syncing everything that iTunes took care of in the past. One problem I have is managing movies.


    I have looked through various media players/iPod management tools (Amarok, Rhythmbox, gtkpod) and I am using Rhythmbox to sync my music and and attempting to use gtkpod to sync my movies.

    gtkpod is able to sync songs (Tested with a few minute test clip) and short *.mp4 files (15mb I know for sure from test).

    I am unable, however, to get it to sync a movie (~700mb)


    I am able to drag it onto my iPod in gtkpod, but when I try to save the changes and write the files, it hangs at "Copying Tracks" at 0%. It eventually crashes during the couple times I have tried to wait it out.

    So this being my situation, my question is, is there a size limit to the *.mp4 files I can sync to my iPod Touch via gtkpod? Also appreciated, is there any other tools that you know of that I can sync videos to my iPod with?



    Thanks for the help, guys. I know that iPhone support isn't the best in Ubuntu, but you seem to be very helpful to everyone else I've seen here.

  2. #2
    Join Date
    Jul 2010
    Location
    Ohio
    Beans
    50
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Large *.mp4 Files in gtkpod

    If it is relevant to any suggested program, I do have my iPod Touch jailbroken. Also fairly important is it's model.

    Second Generation
    16 GB
    Non-MC Model
    Can SSH into filesystem


    If worse comes to worst, I can SSH the movies into the /var/moble/Library/Downloads folder of my iPod and use dTunes to play them, but dTunes's movie player isn't as good as the default one (resume where you left off, thumbnails, etc.)

    EDIT:

    Took a picture of the difference between two files. One syncs fine and plays, the other does not sync at all.

    Last edited by Deersindal; July 27th, 2010 at 03:43 PM.

  3. #3
    Join Date
    Jul 2010
    Location
    Ohio
    Beans
    50
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Large *.mp4 Files in gtkpod

    Looking at these files, I thought that it might be possible that the DVD ripper I used to get the nonfunctional movies might be causing the problems. I am ripping a movie with OGMRip to see how that might help things.


    EDIT: OGMRip wasn't working. it kept freezing while "extracting audio track 1." I am trying with k9copy and it's slow, but I would have to return to my original question and ask if anyone else can sync ripped dvds to their ipods/iphones via gtkpod?
    Last edited by Deersindal; July 27th, 2010 at 11:30 PM.

  4. #4
    Join Date
    Jul 2010
    Location
    Ohio
    Beans
    50
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Large *.mp4 Files in gtkpod

    Tonight I will try to rip a DVD with handbrake and see if that makes any difference.

  5. #5
    Join Date
    Dec 2009
    Beans
    Hidden!

    Re: Large *.mp4 Files in gtkpod

    gtkpod is what I use and it works perfect for both movies and music. iPod videos can't just be any video shoved in an .mp4 container. Depending on the video encoding and the iPod version they require specific audio and video bitrates to actually go onto the iPod. Try converting the videos properly with a tool like Ibulk, listed on my signature, or another tool like arista transcoder, mp4ize, ect.

  6. #6
    Join Date
    Jul 2010
    Location
    Ohio
    Beans
    50
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Large *.mp4 Files in gtkpod

    I was thinking that it might be a problem like that. I converted them on XP with Magic DVD on iPhone settings which usually works, but I had been running them through iTunes which might have done something to them. I will try Ibulk and let you know how it works out.

  7. #7
    Join Date
    Jul 2010
    Location
    Ohio
    Beans
    50
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Large *.mp4 Files in gtkpod

    Alright I'm back. I downloaded and installed Ibulk as per the included instructions and I ran
    Code:
    sudo ibulk -H -P
    which returned
    Code:
    FFmpeg version SVN-r0.5.1-4:0.5.1-1ubuntu1, Copyright (c) 2000-2009 Fabrice Bellard, et al.
      configuration: --extra-version=4:0.5.1-1ubuntu1 --prefix=/usr --enable-avfilter --enable-avfilter-lavf --enable-vdpau --enable-bzlib --enable-libgsm --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-pthreads --enable-zlib --disable-stripping --disable-vhook --enable-runtime-cpudetect --enable-gpl --enable-postproc --enable-swscale --enable-x11grab --enable-libdc1394 --enable-shared --disable-static
      libavutil     49.15. 0 / 49.15. 0
      libavcodec    52.20. 1 / 52.20. 1
      libavformat   52.31. 0 / 52.31. 0
      libavdevice   52. 1. 0 / 52. 1. 0
      libavfilter    0. 4. 0 /  0. 4. 0
      libswscale     0. 7. 1 /  0. 7. 1
      libpostproc   51. 2. 0 / 51. 2. 0
      built on Mar  4 2010 12:35:30, gcc: 4.4.3
    Input #0, mov,mp4,m4a,3gp,3g2,mj2, from 'fullmetaljacket.mp4':
      Duration: 01:56:31.01, start: 0.000000, bitrate: 871 kb/s
        Stream #0.0(eng): Video: mpeg4, yuv420p, 424x320 [PAR 1:1 DAR 53:40], 29.97 tbr, 29.97 tbn, 29.97 tbc
        Stream #0.1(eng): Audio: aac, 48000 Hz, stereo, s16
    WARNING: The bitrate parameter is set too low. It takes bits/s as argument, not kbits/s
    Unknown encoder 'libx264'
    find: `/home/jonathan/Ibulk/output/*': No such file or directory
    find: `/home/jonathan/Ibulk/output/*': No such file or directory
    FFmpeg version SVN-r0.5.1-4:0.5.1-1ubuntu1, Copyright (c) 2000-2009 Fabrice Bellard, et al.
      configuration: --extra-version=4:0.5.1-1ubuntu1 --prefix=/usr --enable-avfilter --enable-avfilter-lavf --enable-vdpau --enable-bzlib --enable-libgsm --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-pthreads --enable-zlib --disable-stripping --disable-vhook --enable-runtime-cpudetect --enable-gpl --enable-postproc --enable-swscale --enable-x11grab --enable-libdc1394 --enable-shared --disable-static
      libavutil     49.15. 0 / 49.15. 0
      libavcodec    52.20. 1 / 52.20. 1
      libavformat   52.31. 0 / 52.31. 0
      libavdevice   52. 1. 0 / 52. 1. 0
      libavfilter    0. 4. 0 /  0. 4. 0
      libswscale     0. 7. 1 /  0. 7. 1
      libpostproc   51. 2. 0 / 51. 2. 0
      built on Mar  4 2010 12:35:30, gcc: 4.4.3
    *: no such file or directory
    find: `/home/jonathan/Ibulk/output/*': No such file or directory
    
    Ibulk has finished. Enjoy your new videos. Please
    remove all files from ~/Ibulk/input & output folders
    
    find: `/home/jonathan/Ibulk/output/*': No such file or directory
    along with no converted file.

  8. #8
    Join Date
    Dec 2009
    Beans
    Hidden!

    Re: Large *.mp4 Files in gtkpod

    right, in the Read Me it will tell you, that you have to first run ibulk as:
    Code:
    ibulk -r
    This will create the directories ibulk will use to convert the videos. use:
    Code:
    ibulk -h
    for more info.

    after you use "ibulk -r", you can either convert several videos by placing them in ~/Ibulk/input and then running the code you attempted earlier or to convert a single video, set the -S flag.
    Last edited by d3v1150m471c; July 29th, 2010 at 02:30 AM.

  9. #9
    Join Date
    Jul 2010
    Location
    Ohio
    Beans
    50
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Large *.mp4 Files in gtkpod

    I did run
    Code:
    ibulk -r
    and i do have the directories
    Code:
    ~/Ibulk/input
    ~/Ibulk/output
    both of these directories are only accessible by root, though, hence why i ran
    Code:
    sudo ibulk -H -P
    instead of
    Code:
    ibulk -H -P

  10. #10
    Join Date
    Dec 2009
    Beans
    Hidden!

    Re: Large *.mp4 Files in gtkpod

    Code:
    Unknown encoder 'libx264'
    


    That's the problem. Ibulk cannot find any videos in output because ffmpeg doesn't have the H.264 library, thus it never actually made any videos. You'll need to install that. Sorry I didn't notice that earlier. I'll have to update the dependencies on ibulk so I'm glad you caught that.

    Code:
    sudo apt-get install libx264-67
    that should solve the problem.
    Last edited by d3v1150m471c; July 29th, 2010 at 03:01 AM.

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •