Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: DVD won't play in VLC or MPlayer

  1. #1
    Join Date
    Feb 2009
    Beans
    10
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Angry DVD won't play in VLC or MPlayer

    Sorry if this is a repost, but I can't seem to find the magic Google search syntax that will give me the answer to my question from anywhere.

    I'm using 10.04, trying to play a DVD on my drive. I downloaded both VLC and MPlayer including all of the restricted codecs available in synaptic. Also tried installing ffplayer, but that was just a cluster.

    When I press play the DVD plays for about 1 second on a black screen and then stops in VLC. MPlayer at least tries to scroll through all the files, but the same thing happens on each "chapter" of the disc.

    Since I can't seem to find anything anywhere on any forums about this, someone please, please, please, please help me out. I'm not much of a multimedia guru, but I know enough to know that I need a codec to play filetypes. I also know how to install them.

  2. #2
    Join Date
    Jul 2005
    Location
    England
    Beans
    Hidden!

    Re: DVD won't play in VLC or MPlayer

    libdvdcss2 installed?

    If not enable medibuntu and follow the instructions on http://www.medibuntu.org/

    EDIT:
    wojox's answer below is another way of getting to the same place without medibuntu.
    Last edited by ajgreeny; July 22nd, 2010 at 09:07 PM.

  3. #3
    wojox is offline I Ubuntu, Therefore, I Am
    Join Date
    Apr 2009
    Beans
    8,630

    Re: DVD won't play in VLC or MPlayer

    Code:
    sudo apt-get install libdvdread4
    Code:
    sudo /usr/share/doc/libdvdread4/install-css.sh
    Rebooting may be necessary.

  4. #4
    Join Date
    Mar 2010
    Location
    Minnesota
    Beans
    857
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: DVD won't play in VLC or MPlayer

    You may need to install Ubuntu restricted extras

    something like

    Code:
    sudo apt-get install ubuntu-restricted-extras
    You can follow me at my blog.

  5. #5
    Join Date
    Dec 2006
    Beans
    6,853

    Re: DVD won't play in VLC or MPlayer

    Hi JRod,

    Quote Originally Posted by JRod37 View Post
    When I press play the DVD plays for about 1 second on a black screen and then stops in VLC. MPlayer at least tries to scroll through all the files, but the same thing happens on each "chapter" of the disc.
    Could you try playing the dvd from the commandline in the following manner:

    Code:
    mplayer -v dvd://1
    and then post the full terminal output here? The error messages should give a good indication of what is going wrong...

    Andrew
    You think that's air you're breathing now?

  6. #6
    Join Date
    Feb 2009
    Beans
    10
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: DVD won't play in VLC or MPlayer

    Thanks gang. Can't get to it at the moment. Stay tuned.

  7. #7
    Join Date
    Feb 2009
    Beans
    10
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: DVD won't play in VLC or MPlayer

    Ok, folks. I'm back.

    I did this: mplayer -v dvd://1 and got the following message:

    Playing dvd://1.
    get_path('sub/') -> '/home/leder/.mplayer/sub/'
    URL: dvd://1
    libdvdread: Encrypted DVD support unavailable.
    ************************************************
    ** **
    ** No css library available. See **
    ** /usr/share/doc/libdvdread4/README.Debian **
    ** for more information. **
    ** **
    ************************************************
    Reading disc structure, please wait...
    There are 12 titles on this DVD.
    There are 1 angles in this DVD title.
    DVD successfully opened.
    audio stream: 0 format: ac3 (5.1) language: en aid: 128.
    audio stream: 1 format: ac3 (stereo) language: en aid: 129.
    number of audio channels on disk: 2.
    subtitle ( sid ): 0 language: en
    subtitle ( sid ): 1 language: fr
    subtitle ( sid ): 2 language: es
    number of subtitles on disk: 3
    DVD start cell: 0 pack: 0x0-0x102A8
    DVD start=0 end=3850416
    STREAM: [null] dvd://1
    STREAM: Description: DVD stream
    STREAM: Author:
    STREAM: Comment:
    DVD Seek! lba=0x0 cell=0 packs: 0x0-0x102A8
    stream_seek: WARNING! Can't seek to 0x0 !
    DVD Seek! lba=0x0 cell=0 packs: 0x0-0x102A8
    stream_seek: WARNING! Can't seek to 0x0 !
    MPEG Stream reached EOF
    ds_fill_buffer: EOF reached (stream: video)
    MPEG packet stats: p100: 0 p101: 0 p1B6: 0 p12x: 0 sli: 0 a: 0 b: 0 c: 0 idr: 0 sps: 0 pps: 0 PES: 0 MP3: 0, synced: 0
    Not MPEG System Stream format... (maybe Transport Stream?)
    DVD Seek! lba=0x0 cell=0 packs: 0x0-0x102A8
    stream_seek: WARNING! Can't seek to 0x0 !

    vo: x11 uninit called but X11 not initialized..

    Exiting... (End of file)


    So I did what wojox suggested and ran sudo /usr/share/doc/libdvdread4/install-css.sh without the reboot.

    After that MPlayer, GNOME MPlayer and the default movie player all did something similar. They would play everything until the main menu. I reran mplayer -v dvd://1 with this output:

    MPlayer SVN-r1.0~rc3+svn20090426-4.4.3 (C) 2000-2009 MPlayer Team
    CPU vendor name: AuthenticAMD max cpuid level: 1
    CPU: AMD Athlon(tm) XP 2400+ (Family: 6, Model: 8, Stepping: 1)
    extended cpuid-level: 8
    extended cache-info: 16810304
    Detected cache-line size is 64 bytes
    Testing OS support for SSE... yes.
    Tests of OS support for SSE passed.
    CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNowExt: 1 SSE: 1 SSE2: 0 SSSE3: 0
    Compiled with runtime CPU detection.
    get_path('codecs.conf') -> '/home/leder/.mplayer/codecs.conf'
    Reading /home/leder/.mplayer/codecs.conf: Can't open '/home/leder/.mplayer/codecs.conf': No such file or directory
    Reading /etc/mplayer/codecs.conf: Can't open '/etc/mplayer/codecs.conf': No such file or directory
    Using built-in default codecs.conf.
    Configuration: --prefix=/usr --confdir=/etc/mplayer --enable-xvmc --enable-menu --enable-largefiles --language=all --disable-libdvdcss-internal --disable-dvdread-internal --disable-libavutil_a --disable-libavcodec_a --disable-libavformat_a --disable-libpostproc_a --disable-libswscale_a --target=i586-linux --enable-runtime-cpudetection --enable-debug --enable-mga --enable-3dfx --enable-tdfxfb --disable-gui
    CommandLine: '-v' 'dvd://1'
    init_freetype
    Using MMX (with tiny bit MMX2) Optimized OnScreenDisplay
    get_path('fonts') -> '/home/leder/.mplayer/fonts'
    Using nanosleep() timing
    get_path('input.conf') -> '/home/leder/.mplayer/input.conf'
    Can't open input config file /home/leder/.mplayer/input.conf: No such file or directory
    Parsing input config file /etc/mplayer/input.conf
    Input config file /etc/mplayer/input.conf parsed: 89 binds
    Setting up LIRC support...
    mplayer: could not connect to socket
    mplayer: No such file or directory
    Failed to open LIRC support. You will not be able to use your remote control.
    get_path('1.conf') -> '/home/leder/.mplayer/1.conf'

    Playing dvd://1.
    get_path('sub/') -> '/home/leder/.mplayer/sub/'
    URL: dvd://1
    libdvdread: Using libdvdcss version 1.2.10 for DVD access
    Reading disc structure, please wait...
    There are 12 titles on this DVD.
    There are 1 angles in this DVD title.
    libdvdread: Invalid title IFO (VTS_03_0.IFO).
    Cannot open the IFO file for DVD title 3.
    No stream found to handle url dvd://1

    vo: x11 uninit called but X11 not initialized..

    Exiting... (End of file)

    Any ideas? After I post this I will reboot and post an update ONLY if this fixes the problem. If no further post assume the problem still exists.

  8. #8
    Join Date
    Jul 2007
    Location
    Poland
    Beans
    4,162
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: DVD won't play in VLC or MPlayer

    from https://help.ubuntu.com/community/RestrictedFormats

    Code:
    sudo /usr/share/doc/libdvdread4/install-css.sh

  9. #9
    Join Date
    Feb 2009
    Beans
    10
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: DVD won't play in VLC or MPlayer

    I was able to get the DVD to play in Movie Player. I'm going to uninstall MPlayer and reinstall to see if that fixes MPlayer. I am also going to now install VLC and see if the issue still exists there.

    Looks like it was the css issue.

    Thanks, everyone. I'll post a followup for VLC and MPlayer.

  10. #10
    Join Date
    Feb 2009
    Beans
    10
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Talking Re: DVD won't play in VLC or MPlayer

    It did not fix the issue for MPlayer, but VLC is working great! That's my player of choice anyway. I'm going to let the MPlayer issue lie.

    Thanks everyone for all of your help. I'll try to change the heading of this post to SOLVED, but since this is my first resolved issue it may take me a little to figure it out.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •