View Poll Results: Do you thin its the bes way to get XGL Working?

Voters
18. You may not vote on this poll
  • Yes

    15 83.33%
  • No

    3 16.67%
Page 1 of 8 123 ... LastLast
Results 1 to 10 of 77

Thread: HOW TO : XGL/Compiz Nvidia Cards

  1. #1
    Join Date
    Mar 2006
    Location
    Sherbrooke Québec (Canada
    Beans
    84

    Lightbulb HOW TO : XGL/Compiz Nvidia Cards i386

    Hello,

    For those who have nVidia cards and Ubuntu, here is a small howto. This howto configure your gdm to use Xgl. Xgl is run by root, not the user. (not startxgl.sh script). This howto is based on RacerII and mstlyevil howto.

    1. Configure nVidia acceleration

    If you do not have nVidia 3D acceleration enable, follow this steps :

    1.1. Install packages

    You must install restricted modules for your kernel to have the nVidia blob. You may prefer use linux-686, linux-686-smp (for core duo) or linux-k7 to optimise with your cpu. Be sure you have restricted repo enable. You might also want to install nvidia-glx-legacy for no more supported nVidia cards.

    Do it with System->Adminitration->Synaptic Package Manager or with the following cmd line :

    Code:
    sudo apt-get install nvidia-glx nvidia-kernel-common linux-386
    1.2. Configure Xorg

    Code:
    sudo gedit /etc/X11/xorg.conf
    Then do the following changes :

    1.2.1 Modules

    Int the "Module" section comment lines for GLcore and dri and set the glx directive.

    Code:
    Section "Module"
     Load "bitmap"
     Load "ddc"
    # Load "dri"
     Load "extmod"
     Load "freetype"
     Load "glx"
     Load "int10"
     Load "type1"
     Load "vbe"
    EndSection
    1.2.2 nVidia's driver

    In the "Device" section set :

    Code:
     Driver "nvidia"
     Option "NoLogo" # This option disable the startup logo. optional.
     Option "RenderAccel" "true"
     Option "Triplebuffer" "true"
    1.2.3 Screen depth

    In the "Screen" section set :

    Code:
    DefaultDepth 24
    Done.

    2 Install great stuffs

    2.1 Enable extra repos

    Code:
    sudo gedit /etc/apt/sources.list
    Add this:
    Code:
    deb http://www.beerorkid.com/compiz dapper main aiglx
    deb http://media.blutkind.org/xgl/ dapper main aiglx
    deb http://ubuntu.compiz.net/ dapper main aiglx
    Receive quinn GPG key for package check. You may do it with System->Administration->Software Properties. Download Quinn key file at http://www.beerorkid.com/compiz/quinn.key.asc and add it with the "Import Key File" button. Or simply do :

    Code:
    wget http://www.beerorkid.com/compiz/quinn.key.asc -O - | sudo apt-key add -
    wget http://media.blutkind.org/xgl/quinn.key.asc -O - | sudo apt-key add -
    wget http://ubuntu.compiz.net/quinn.key.asc -O - | sudo apt-key add -
    Update package list, Reload with synaptic or do :

    Code:
    sudo apt-get update
    2.2 Install the packages

    Now you need to install those packages :

    Code:
    sudo apt-get install xserver-xgl compiz compiz-core compiz-plugins compiz-gnome gnome-compiz-manager cgwd cgwd-themes
    Remember to keep your packages up to date.

    2.3 Keep up to date

    Upgrade all packages using Synaptic, update-manager or :
    Code:
    sudo apt-get dist-upgrade
    3. Configure GDM

    Code:
    sudo gedit /etc/gdm/gdm.conf-custom
    And complete the servers section

    Code:
    [servers]
    0=Xgl 
    
    [server-Xgl] 
    name=Xgl server 
    command=/usr/bin/Xgl :0 -fullscreen -ac -accel glx:pbuffer -accel xv:pbuffer
    flexible=true
    Now restart your computer.

    GDM should launch normally. Alt Gr might not work on some keyboard (e.g. french keyboard). If you need Alt Gr to type your password, you'd better change your passowrd. To do so, switch to VT1 with Ctrl+Alt+F1. Login. Change your password with

    Code:
    passwd
    answer questions and switch back to VT7 with Alt+F7.

    4. Launch compiz

    Once you're logged in, metacity is still your window manager. You may want to reconfigure your keyboard layout with System->Preference->Keyboard , tab Layout. You'll have an icon im notification aera right click on it and select : GL Desktop

    Now you can start and stop compiz as you wish
    You have more option in preferences you can set plugins and change windows decoration

    That's all guys.&

    Thanks to all people that made it possible. First David Reveman and QuinnStorm.

    I run this on Athlon 64 3000+ with 1GB of ram and a 7800GT

    Review and comments are very welcomes.

    Here the link that i have taken the sources to make the HOWTO
    http://www.compiz.net/viewtopic.php?id=652
    i just wanted to make it more easy

    Here A link to the wiki page for configuring Compiz in Gconf-editor
    https://help.ubuntu.com/community/Co...ngCompiz#xprop

    Edit: (Friday, 25 August 2006) : Big update!!!! I modified the sources for more package and aiglx(not tested) and removed The compiz-start script an replaced it with gnome-compiz-manager so no need to have a script!

    Have Fun!!!
    Attached Images Attached Images  
    Last edited by chokes; August 30th, 2006 at 09:58 AM.

  2. #2
    Join Date
    Jul 2005
    Location
    Slovenia
    Beans
    14
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: HOW TO : XGL/Compiz Nvidia Cards

    Thank you, it was very helpful to me so everything works now.

  3. #3
    Join Date
    Mar 2006
    Location
    Faroe Islands
    Beans
    917

    Re: HOW TO : XGL/Compiz Nvidia Cards

    Yeah I followed a similar HOWTO I found somewhere else. This is the right way to do it

  4. #4
    Join Date
    Aug 2006
    Beans
    28

    Re: HOW TO : XGL/Compiz Nvidia Cards

    mike@mike:~$ sudo apt-get install xserver-xgl compiz-gnome gset-compiz
    Reading package lists... Done
    Building dependency tree... Done
    E: Couldn't find package gset-compiz
    mike@mike:~$


    ?? Can't find it?


    EDIT: Nevermind, I went and found another mirror that had the file. It's all installed except for the decorations, anyone have an idea?
    Code:
    mike@mike:~$ sudo apt-get install cgwd gcompizthemer gcompizthemer-themes
    Reading package lists... Done
    Building dependency tree... Done
    cgwd is already the newest version.
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
      cgwd: Conflicts: gcompizthemer
      gcompizthemer-themes: Depends: gcompizthemer (>= 0.18)
    E: Broken packages
    Last edited by MikeEnIke; August 12th, 2006 at 02:13 AM.

  5. #5
    Join Date
    Mar 2006
    Location
    Sherbrooke Québec (Canada
    Beans
    84

    Re: HOW TO : XGL/Compiz Nvidia Cards

    oh! sorry you have to install the package : cgwd-themes i didnt edit the tread sice they merge gcompizthemer directly in cgwd
    Last edited by chokes; August 12th, 2006 at 03:40 AM.

  6. #6
    Join Date
    Mar 2006
    Location
    Houston, TX
    Beans
    95
    Distro
    Dapper Drake Testing/

    Re: HOW TO : XGL/Compiz Nvidia Cards

    how do i set it to allow full screen 3d apps to have direct rendering?

    isnt there a way?
    Left here since creation...
    Forgotten in the river of time...

  7. #7
    Join Date
    Jun 2006
    Beans
    2

    Re: HOW TO : XGL/Compiz Nvidia Cards

    hic.
    I've got my X Desktop crashed

  8. #8
    Join Date
    Aug 2006
    Beans
    28

    Re: HOW TO : XGL/Compiz Nvidia Cards

    Quote Originally Posted by Intangir View Post
    how do i set it to allow full screen 3d apps to have direct rendering?

    isnt there a way?
    http://ubuntuforums.org/showthread.p...t=xgl%2Fcompiz

    Doing that should should work. Worked fine for me.

  9. #9
    Join Date
    Dec 2005
    Location
    Boston, MA, USA
    Beans
    260
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: HOW TO : XGL/Compiz Nvidia Cards

    Quote Originally Posted by MikeEnIke View Post
    mike@mike:~$ sudo apt-get install xserver-xgl compiz-gnome gset-compiz
    Reading package lists... Done
    Building dependency tree... Done
    E: Couldn't find package gset-compiz
    mike@mike:~$


    ?? Can't find it?


    EDIT: Nevermind, I went and found another mirror that had the file.
    I am having this same problem, but I can't seem to find the gset-compiz deb anywhere. How did you find it?

    Thanks,
    Matt

  10. #10
    Join Date
    Mar 2006
    Location
    Faroe Islands
    Beans
    917

    Re: HOW TO : XGL/Compiz Nvidia Cards

    Did you enable the extra repositories like decribed in step 2.1 in the howto?

Page 1 of 8 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •