Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17

Thread: Diablo 2 - No sound in-game

  1. #11
    Join Date
    May 2008
    Location
    Novi Sad, Vojvodina
    Beans
    12
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Diablo 2 - No sound in-game

    Thanks man, adding prefix worked as a charm

  2. #12
    Join Date
    Jul 2011
    Beans
    2
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Diablo 2 - No sound in-game

    Quote Originally Posted by rebelrex View Post
    switching to oss didnt helped me
    what did help me was changing Direct sound to "Emulation"
    Applications->wine-> wine configuration->audio-> Direct Sound- "Emulation"
    This is what fixed it for me, thanks.

  3. #13
    Join Date
    Jan 2010
    Beans
    177
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Diablo 2 - No sound in-game

    Quote Originally Posted by rebelrex View Post
    switching to oss didnt helped me
    what did help me was changing Direct sound to "Emulation"
    Applications->wine-> wine configuration->audio-> Direct Sound- "Emulation"
    Thanks...this fixed my vanishing sound also after a WINE upgrade. I have no clue what is causing this issue though. Esp. since D2 has always worked perfectly under WINE with different versions.
    Xubuntu 12.04 x64 // AMD E-350 (2x1.6 GHz) // 8 GB DDR3 RAM // GeForce 9500GT (1GB) with passive cooling

  4. #14
    Join Date
    Oct 2010
    Beans
    7

    Re: Diablo 2 - No sound in-game

    I've actually go the same problem but the prefix didn't help.

    padsp: in winecfg audio tests for all combinations fail, prefix for d2 command produces no sound, even in the initial menus

    otherwise, alsa with emulation or full, either one, produces sound in initial menus, no sound in-game, and any combination involving OSS, prefixed or otherwise, fails.

    the prefixed command produces

    errss:AUDDRV_GetEndpointIDs OSS /dev/mixer doesn't seem to exist

    which I can only find mentioned in what look like patch notes of some sort.

    Any ideas?

  5. #15
    Join Date
    Mar 2008
    Location
    by a river
    Beans
    Hidden!
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: Diablo 2 - No sound in-game

    In order to get Diablo2 sound working completely in Ubuntu 10.10 and 11.04, I found it necessary to install a Wine version that has been modified to include Pulseaudio support (it adds that option in the wine configuration utility, audio section). It is version 1.3 from the c-korn repository. First, add the repository by entering this in the terminal:
    Code:
    sudo add-apt-repository ppa:c-korn/ppa
    then update your sources by entering:
    Code:
    sudo apt-get update
    then you can either install wine 1.3 by using Synaptic Pkg Mgr or by entering in the terminal:
    Code:
    sudo apt-get upgrade
    i5 2500k | Gigabyte Z68 UD3p | Corsair 1600LP 8gb | MSI HD6870 TwinFrozer | Samsung 830 SSD/WD Black | Seasonic 520w modular
    http://spankmon.wordpress.com

  6. #16
    Join Date
    Oct 2010
    Beans
    7

    Re: Diablo 2 - No sound in-game

    Success!

    I only ran into one hitch though, my wine1.3 was already 1.3.25, but the c-korn version was 1.3.18, and therefore wouldn't let me just upgrade to it. So Just a heads up if anyone ends up reading through this thread in the future, in synaptic package manager, I had to go to the installed package, open 'Package -> Force version', then choose 1.3.18.
    Opened winecfg to a plethora of driver options, pulseaudio among them, and now everything works like a charm ^^


    Much appreciated all, especially 4Orbs

  7. #17
    Join Date
    Sep 2011
    Beans
    8

    Re: Diablo 2 - No sound in-game

    These solutions did not work for me. After downgrading to the proper Wine version and selecting PulseAudio in the setup, I tested the game. Not only was there still no sound, but the screen was showing the desktop through the opening scenes. Alt-Tab would bring the game back to the foreground. The game would halt at the main menu screen. Upgraded to latest Wine again. I can play the game just without sound.

    So this thread should be downgraded to [Un-Solved].

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •