Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Diablo 2 - No sound in-game

  1. #1
    Join Date
    Oct 2009
    Beans
    88

    Diablo 2 - No sound in-game

    Hi everyone,

    I am trying to get Diablo II: Lord of Destruction working in Wine and I've almost got it perfect, but I'm experiencing some issues with the sound.

    When I run the program, I can hear the sound at first, but once I enter a game there is no more sound. And even if I exit back to the menu, there is still no sound, but if I close the program and re-open it then same like before (sound until I enter a game).

    I'm using wine-1.2. If I run the game from terminal, I get the following output
    Code:
    fixme:exec:SHELL_execute flags ignored: 0x00000100
    fixme:exec:SHELL_execute flags ignored: 0x00004100
    $ fixme:advapi:SetSecurityInfo stub
    fixme:dsalsa:IDsDriverBufferImpl_SetVolumePan (0x13c778,0x13c6d8): stub
    fixme:dsalsa:IDsDriverBufferImpl_SetVolumePan (0x13c778,0x13c6d8): stub
    fixme:dsalsa:IDsDriverBufferImpl_SetVolumePan (0x13c778,0x13c6d8): stub
    but this output happens right away and I don't get additional output when the sound gets "lost".

    Has anyone gotten this to work, or anyone have any ideas?

  2. #2
    Join Date
    Feb 2010
    Location
    Texas, USA
    Beans
    63
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Diablo 2 - No sound in-game

    Once in game, try ESC and go to Options/Settings etc. I haven't played Diablo 2 in a while but there should be settings there for display and sound.

    I'll try later today, see where it gets me, and post.
    Help yourself: Use the forum search
    Help us help you: Use descriptive titles and detailed posts.
    Help others: Mark threads as [Solved] once it is.
    Twitter Facebook Blog

  3. #3
    Join Date
    Oct 2009
    Beans
    88

    Re: Diablo 2 - No sound in-game

    Thanks for the reply, valbaca.

    Unfortunately, it's not because of the in-game settings. Sound was at max and Music at half. Changing their values also doesn't help. I do appreciate the suggestion tho, it was worth a try.

    Any other ideas out there?

  4. #4
    Join Date
    Feb 2010
    Location
    Texas, USA
    Beans
    63
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Diablo 2 - No sound in-game

    A couple more "shots from the hip" that are crazy enough to work
    • Try turning up the volume using volume keys or hitting mute
    • See if there is any sound coming from the headphone jack
    Now I'm really eager to get home and pop in those old discs (Skelemancers ftw!)
    Help yourself: Use the forum search
    Help us help you: Use descriptive titles and detailed posts.
    Help others: Mark threads as [Solved] once it is.
    Twitter Facebook Blog

  5. #5
    Join Date
    Oct 2009
    Beans
    88

    Re: Diablo 2 - No sound in-game

    Thanks, but I still can't get it to work, unfortunately. Tried changing my system's volume, mute/unmute, plugging in headphones, etc. No dice :\

  6. #6
    Join Date
    Sep 2009
    Beans
    115
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Diablo 2 - No sound in-game

    I can verify that the game does work under Wine with sound. Played it not to long ago. Have any other sound issues? And have you tried playing with Wine's sound settings?

  7. #7
    Join Date
    Sep 2007
    Beans
    911
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Diablo 2 - No sound in-game

    pulseaudio may be the problem, try suspending or killing it

  8. #8
    Join Date
    Oct 2009
    Beans
    88

    Re: Diablo 2 - No sound in-game

    Hi, thanks for the replies. With some research and experimentation, I think I've got a solution now.

    The sound seems to work ok when only the OSS Driver is selected in winecfg (Audio tab). But then it doesn't let other sources (like firefox, for example) play sound. To fix this, I found this while searching, and by putting padsp in front of the command used to launch Diablo 2 it seems to work. For example, my launcher command is:
    Code:
    padsp env WINEPREFIX="/home/???/.wine" wine C:\\windows\\command\\start.exe /Unix /home/???/.wine/dosdevices/c:/users/???/Start\ Menu/Programs/Diablo\ II/Diablo\ II\ -\ Lord\ of\ Destruction.lnk -w
    (username replaced with question-marks for the purpose of posting)

    Marking thread as solved.
    Cheers

  9. #9
    Join Date
    Oct 2008
    Beans
    14

    Re: Diablo 2 - No sound in-game

    switching to oss didnt helped me
    what did help me was changing Direct sound to "Emulation"
    Applications->wine-> wine configuration->audio-> Direct Sound- "Emulation"

  10. #10
    Join Date
    Jan 2011
    Beans
    1

    Re: Diablo 2 - No sound in-game

    Cool, Thanks for the fix. I added that prefix and it didn't work at first so I enabled BOTH ALSA and OSS drivers because my other games need ALSA. Now it works!

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •