Results 1 to 8 of 8

Thread: Setting permissions in gedit

  1. #1
    Join Date
    Jun 2010
    Location
    Canada
    Beans
    41
    Distro
    Ubuntu 11.04 Natty Narwhal

    Setting permissions in gedit

    I want to save a PHP file in /opt/lampp/htdocs/ but it says I don't have the permissions in order to do so. How would I be able to fix this?
    Make a wish... it'll be your last

  2. #2
    Join Date
    Jul 2009
    Location
    Dayton Ohio USA
    Beans
    1,070
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: Setting permissions in gedit

    Start your process with sudo gedit.
    It's okay, I'm a limo driver

  3. #3
    Join Date
    Jun 2010
    Location
    Canada
    Beans
    41
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Setting permissions in gedit

    Great, that worked perfectly.
    Make a wish... it'll be your last

  4. #4
    Join Date
    Oct 2009
    Beans
    244

    Re: Setting permissions in gedit

    Use gksudo gedit.

    It's generally good practice to use gksudo instead of sudo for graphical apps.

  5. #5
    Join Date
    May 2008
    Location
    Michigan, USA
    Beans
    145
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Setting permissions in gedit

    You need to start gedit as root - click on Applications -> Accessories -> Terminal; at the command line type 'sudo gedit' and hit <enter>. When you are asked for a password, key in the password with which you log in. You will see the gedit window. Edit your file, and then save it. As root, you should be able to save it wherever you want.

  6. #6
    Join Date
    Jun 2010
    Location
    Canada
    Beans
    41
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Setting permissions in gedit

    Quote Originally Posted by aphatak View Post
    You need to start gedit as root - click on Applications -> Accessories -> Terminal; at the command line type 'sudo gedit' and hit <enter>. When you are asked for a password, key in the password with which you log in...
    I wrote sudo but I wasn't asked to enter a password, gedit just started normally and I was able to save where I wanted.
    Make a wish... it'll be your last

  7. #7
    Join Date
    Jul 2010
    Beans
    62
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Setting permissions in gedit

    Quote Originally Posted by Apostolique View Post
    I wrote sudo but I wasn't asked to enter a password, gedit just started normally and I was able to save where I wanted.
    If you've verified your sudo within 15 minutes prior (that's the default, right?) it won't ask you again.

  8. #8
    Join Date
    Jun 2010
    Location
    Canada
    Beans
    41
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Setting permissions in gedit

    Quote Originally Posted by new__buntu View Post
    If you've verified your sudo within 15 minutes prior (that's the default, right?) it won't ask you again.
    That's right, I forgot about that!
    Make a wish... it'll be your last

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •