Results 1 to 9 of 9

Thread: Error mounting: Exit Code 12 (Failed to read)

  1. #1
    Join Date
    Apr 2008
    Beans
    38
    Distro
    Ubuntu 11.04 Natty Narwhal

    Unhappy Error mounting: Exit Code 12 (Failed to read)

    I am running Ubuntu 10.04 on a 64-bit Sony Vaio CS, and everything was working fine until about 10 minutes ago when I put the system on standby, and when it came back and I tried accessing a drive partition, I got the following error:

    Error mounting: mount exited with exit code 12: Failed to read last sector ( 403879528 ): Invalid argument
    HINTS: Either the volume is a RAID/LDM but it wasn't setup yet,
    or it was not setup correctly (e.g. by not using mdadm --build ...),
    or a wrong device is tried to be mounted,
    or the partition table is corrupt (partition is smaller than NTFS),
    or the NTFS boot sector is corrupt (NTFS size is not valid).
    Failed to mount '/dev/sda2': Invalid argument
    The device '/dev/sda2' doesn't seem to have a valid NTFS.
    Maybe the wrong device is used? Or the whole disk instead of a
    partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?


    Does anyone know what could have gone wrong? I'm an ubuntu newb, and any help would be appreciated. Thanks in advance!

  2. #2
    Join Date
    Apr 2008
    Beans
    38
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Error mounting: Exit Code 12 (Failed to read)

    Bump. =[

  3. #3
    Join Date
    Apr 2008
    Beans
    38
    Distro
    Ubuntu 11.04 Natty Narwhal

    Cool Re: Error mounting: Exit Code 12 (Failed to read)

    Bump again! I haven't found a solution for this one yet..

  4. #4
    Join Date
    Sep 2009
    Location
    Russia
    Beans
    318

    Re: Error mounting: Exit Code 12 (Failed to read)

    Hello, probable something broken in pm-utils package. Look at this: https://launchpad.net/ubuntu/+source/pm-utils/+bugs and at this: http://bugs.debian.org/cgi-bin/pkgre...;dist=unstable
    Debian GNU/Linux user

  5. #5
    Join Date
    Apr 2006
    Location
    UK
    Beans
    41

    Re: Error mounting: Exit Code 12 (Failed to read)

    Quote Originally Posted by Danish989 View Post
    Bump. =[
    i've got this problem but i'm not sure what caused it, but it's not a problem with pm-utils, when i make progress i'll let you know.

    Normally with corrupt boot partions i use testdisk but with this drive it crashes! only drive i've see it crash with!

    any how, whatch this space

  6. #6
    Join Date
    Oct 2007
    Beans
    86
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Error mounting: Exit Code 12 (Failed to read)

    I just bought a brand new 2 TB drive and it comes up consistently with precisely the above problem with a different last sector number. Connected on USB, running 10.04, 32 bit. The same drive seems ok on XP.

    Will post again if I fix it or get more info. but not feeling that confident.
    regards,
    ubuntu 12.04 with full encryption, an SSD and dual monitors

  7. #7
    Join Date
    Oct 2007
    Beans
    86
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Error mounting: Exit Code 12 (Failed to read)

    Well I fixed mine just by reformatting the drive. Used GPARTED and NTFS. Had no data on it. Now working fine.
    regards,
    ubuntu 12.04 with full encryption, an SSD and dual monitors

  8. #8
    Join Date
    Nov 2012
    Beans
    1

    Re: Error mounting: Exit Code 12 (Failed to read)

    The linux command "ntfsfix" rectified this problem for me.

    Example: sudo ntfsfix /dev/sda2

    See this post for details!
    http://ubuntuforums.org/showpost.php...46&postcount=5

  9. #9
    Join Date
    Sep 2013
    Beans
    1

    Re: Error mounting: Exit Code 12 (Failed to read)

    thanks man. i was getting same error with my 1TB NTFS HDD. you saved me

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •