Page 1 of 4 123 ... LastLast
Results 1 to 10 of 36

Thread: Ubuntu 11.04 with Gnome on Dell 6510: cannot disable touchpad

  1. #1
    Join Date
    May 2011
    Location
    USA
    Beans
    115
    Distro
    Ubuntu 12.04 Precise Pangolin

    Ubuntu 11.04 with Gnome on Dell E6510: cannot disable touchpad

    I cannot disable touchpad. If I go to mouse preferences, there is no Touchpad tab.

    I used this package but it does not install at all.

    sudo add-apt-repository ppa:atareao/atareao
    sudo apt-get install touchpad-indicator

    Do you have any other suggestions, please?

    TIA!!
    Last edited by vincegata; May 14th, 2011 at 12:25 AM.

  2. #2
    Join Date
    May 2011
    Location
    USA
    Beans
    115
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Ubuntu 11.04 with Gnome on Dell E6510: cannot disable touchpad

    This command:

    sudo synclient TouchpadOff=1

    gives me:

    Couldn't find synaptics properties. No synaptics driver loaded?


    Any other suggestions, please?

  3. #3
    Join Date
    May 2010
    Location
    Kenya
    Beans
    22
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Ubuntu 11.04 with Gnome on Dell E6510: cannot disable touchpad

    I also have the same problem!

  4. #4
    Join Date
    May 2007
    Location
    Belgrade, Serbia
    Beans
    10
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Ubuntu 11.04 with Gnome on Dell 6510: cannot disable touchpad

    I own a DELL INSPIRON N5110. It uses Alps touchpad, and that's a problem because it's recognized as a mouse. So touchpad cannot be disabled and/or configured as a touchpad.

    I'm not sure how to solve this issue, but it might be the real issue for you two as well.

    If you do `xinput list` and see:

    Code:
    ....
    ⎜   ↳ ImPS/2 ALPS GlidePoint                  	id=19	[slave  pointer  (2)]
    ....
    it means you have the crappy ALPS touchpad.

  5. #5
    Join Date
    Jan 2011
    Beans
    2

    Re: Ubuntu 11.04 with Gnome on Dell 6510: cannot disable touchpad

    This is the script I use on my N5110 on every startup (in order to set correct touchpad state) and assigned it for touchpad enable/disable keyboard shortcut. Customize it for your needs as I did
    Attached Files Attached Files
    Last edited by d.burba; May 31st, 2011 at 01:41 PM.

  6. #6
    Join Date
    May 2011
    Location
    USA
    Beans
    115
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Ubuntu 11.04 with Gnome on Dell 6510: cannot disable touchpad

    @d.burba, the script does not work on my Dell E6510

    Is there anything else, please?
    I tried Unity. I tried GNOME 3. I did not like neither of them. Now running Ubuntu 12.04 in Fallback mode.

  7. #7
    Join Date
    Jun 2011
    Location
    Bucharest
    Beans
    3

    Re: Ubuntu 11.04 with Gnome on Dell 6510: cannot disable touchpad

    @d.burba thanks sooo much, it works on my dell n5110, and it was really pissing me off.
    @vincegata i'm sure it has to be something very similar to this, but i'm sorry i can't help you.

    alex

  8. #8
    Join Date
    Sep 2009
    Location
    UK
    Beans
    435
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Ubuntu 11.04 with Gnome on Dell 6510: cannot disable touchpad

    @vincegata

    try this;

    Code:
    #!/bin/bash
    cd $HOME
    
    function messageUser()
    {
        if [ "$(which notify-send)" == "" ]; then
            echo "requires... libnotify-bin for messages..."
        elif [ "$1" == "on" ]; then
            notify-send -t 800 -i /home/mike/myicon.png "Touchpad enabled..." "mike reprogramed the calculator button :)"
        elif [ "$1" == "off" ]; then
            notify-send -t 800 -i /home/mike/myicon.png "Touchpad disabled..." "mike reprogramed the calculator button :)"
        fi
    }
    
    touchPadId=$(xinput list | grep -i synaptics | grep -i touch | grep PS | cut -d "=" -f 2 | cut -b 1-2)
    if [ "$touchPadId" == "" ]; then
        echo "Unable to identify device id..."
    else
        if [ -a ".mike-touchPadOnOff" ]; then
            rm -rfv ".mike-touchPadOnOff"
            xinput set-prop $touchPadId 125 1
            messageUser "on"
        else
            touch ".mike-touchPadOnOff"
            xinput set-prop $touchPadId 125 0
            messageUser "off"
        fi
    fi
    i wrote this to use across multiple partitions of linux systems, which could mount the same code/files but would have different device ids... (it greps xinput for touch, get's it's id and disables or enables based on that...), you can disable the message stuff i just like a sys message poping up telling me whats going on (shortcutted to my calculator button )

    note, you should change some of the greps to match the device you have, (if you don't have a synap touchp)
    Last edited by mikejonesey; June 22nd, 2011 at 09:27 AM.

  9. #9
    Join Date
    May 2011
    Location
    USA
    Beans
    115
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Ubuntu 11.04 with Gnome on Dell 6510: cannot disable touchpad

    All got is Unable to identify device id... Does not work either.

    I have ALPS.
    I tried Unity. I tried GNOME 3. I did not like neither of them. Now running Ubuntu 12.04 in Fallback mode.

  10. #10
    Join Date
    Jun 2011
    Location
    Bucharest
    Beans
    3

    Re: Ubuntu 11.04 with Gnome on Dell 6510: cannot disable touchpad

    @vincegata:
    your original solution also works for me.

    if i run a
    Code:
    sudo find / -name "touchpad-indicator"
    it returns:
    Code:
    /usr/share/touchpad-indicator
    /usr/share/doc/touchpad-indicator
    /home/user/.gconf/apps/touchpad-indicator
    and i can use it properly.

Page 1 of 4 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •