Results 1 to 3 of 3

Thread: Segmentation fault when using libavg on Ubuntu?

  1. #1
    Join Date
    Jul 2010
    Beans
    2

    Segmentation fault when using libavg on Ubuntu?

    I have been in search of a tool to develop multi touch applications on linux. I happened to come across libavg a few days ago, but when I tried to run a sample program using libavg the program showed segmentation fault. I am using Ubuntu 10.04. When I looked it up on libavg's Wiki page they had given a few workarounds, but none of them worked. What should I do? Has anyone else come across similar problems with libavg on linux? Here's the code:

    #!/usr/bin/env python
    # -*- coding: utf-8 -*-

    from libavg import avg

    player = avg.Player.get()
    player.loadFile("text.avg")
    player.play()


    Contents of avg file:

    <?xml version="1.0"?>
    <avg width="640" height="480">
    <words id="ClashText" x="10" y="10" font="arial" text="Should I stay or should I go?"/>
    </avg>


    I got this code from here
    Please help.


  2. #2
    Join Date
    Jul 2007
    Location
    Austin, TX
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Segmentation fault when using libavg on Ubuntu?

    Are you trying to use a 32 bit library on a 64 bit machine?

  3. #3
    Join Date
    Jul 2010
    Beans
    2

    Re: Segmentation fault when using libavg on Ubuntu?

    Yes mine is a 64 bit machine(Intel Atom CPU 230 @1.60 GHz)
    But my ubuntu is 32 bit.
    Why?
    Is that a problem?

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •