I have been able to get sound working in general, but I can only control the volume under alsamixer (or gnome-alsamixer,) as opposed to the the sound preferences or the regular speaker icon that is near the top right in gnome. Also, when I check the sound preferences, there is no hardware listed and the only output is "Dummy Output."

Any help would be greatly appreciated.

Thanks