Hi,

I've just got a Samsung SyncMaster 2233RZ monitor. It is a 3D vision ready model, but this issue has nothing to do with its 3D capacity.

I'd like to use it as second monitor in TwinView. But the problem is that nvidia-settings only allows to select 640x480 max resolution.

Here's my xorg.conf file which was generated by nvidia-settings and I edited manually to add the proper HorizSync, VertRefresh and Modeline values. Yet after rebooting it appeared in 640x480, and nvidia-settings remained the same limiting the resolution options to max 640x480.

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildd@yellow) Fri Apr 9 11:51:21 UTC 2010


Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "SamSung"
ModelName "SyncMaster 2233RZ"
HorizSync 30.0 - 190.0
VertRefresh 56.0 - 125.0
ModeLine "1680x1050_120" 238.46 1680 1728 1760 1840 1050 1053 1059 1080 +hsync +vsync
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 8600M GS"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "UseEDID" "false"
Option "NoBandWidthTest" "true"
Option "ExactModeTimingsDVI" "true"
Option "ModeValidation" "DFP-0: NoEdidModes, AllowNon60HzDFPModes, NoMaxSizeCheck, NoMaxPClkCheck, NoMaxSizeCheck, NoXServerModes, NoPredefinedModes"
Option "TwinView" "1"
Option "TwinViewXineramaInfoOrder" "DFP-0"
Option "metamodes" "CRT: nvidia-auto-select +0+0, DFP: nvidia-auto-select +1680+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection
http://ubuntuforums.org/showthread.php?t=1169410 - I've seen this thread but it's different as it recognized the resolution while this mine doesn't even recognize.

I've also tried to remove reboot and reinstall nvidia driver but still it offers resolutions up to 640x480 only.

I'm using Ubuntu 10.04 64bit version with the latest nvidia driver offered by jockey.
Somebody who has the same model working please help me to configure!

Note that I recently used the same distro with the same driver with another monitor successfully.

Thank you!