Page 3 of 3 FirstFirst 123
Results 21 to 26 of 26

Thread: Acer Aspire TimelineX AS1830T Thread

  1. #21
    Join Date
    May 2011
    Beans
    3

    Re: Acer Aspire TimelineX AS1830T Thread

    I wanted to thank everyone here.. this worked for me..

    SUPER SPECIAL THANKS goes out to
    il1019 and EASYFRAGGER


    Here's how I got wifi working in 11.04 beta on a similar laptop:

    * make sure you have the latest linux-firmware installed (1.52)
    * remove all packages with b43 in their names
    * remove broadcom-sta-common and broadcom-sta-source
    * install bcmwl-kernel-source
    * put acer-wmi on the blacklist

    Hope it works for you as well!

  2. #22
    Join Date
    Jun 2007
    Beans
    15

    Re: Acer Aspire TimelineX AS1830T Thread

    With a clean install of 11.04 all I needed to do to get the wifi working was to add the following to /etc/modprobe.d/blacklist.conf
    Code:
    blacklist acer_wmi
    I have the 1830T-3730. I also find that the network connection is slow/not aggressive enough sometimes (especially when there are loads of macbooks around...). This also keeps NXclient from timing out.

    Code:
    sudo iwconfig eth1 power off
    One thing that I can't figure out how to do, however, is get the fan to slow down/turn off. I know what the temp is and there is no reason that the fan should be on!! I have done a bit of research but haven't yet found a way to control fanspeed. The acerhdf module fails to load because this machine's bios version is not supported.

    This worked on 10.10 (though I am not sure if it was because of the acerhdf module or not)

    Any ideas?

  3. #23
    Join Date
    Jun 2007
    Beans
    15

    Re: Acer Aspire TimelineX AS1830T Thread

    Bump....

    Has anyone found a way to control the fan speed in 11.04? It is driving me a bit crazy!

  4. #24
    Join Date
    Jun 2007
    Location
    Quebec, Canada
    Beans
    55
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Acer Aspire TimelineX AS1830T Thread

    Bump!

    Anyone has viable solutions for mouse pad vertical scrolling?

    Thanks a lot!
    I have a very rare bone disease that prevents me from using Microsoft products.

  5. #25
    Join Date
    Nov 2009
    Beans
    117
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Acer Aspire TimelineX AS1830T Thread

    If you want scrolling to work on 1830T you can download and install this .deb: http://people.canonical.com/~sforshee/alps-touchpad/psmouse-alps-0.10/psmouse-alps-dkms_0.10_all.deb
    Then restart. I have tested this with 11.10.

    As per: https://bugs.launchpad.net/ubuntu/+s...ux/+bug/737051

    Might still have a few issues as reported but I find it works fine and am so happy with finally having two finger scrolling! And you can also choose edge scrolling in Touchpad settings as of now.

  6. #26
    Join Date
    Nov 2009
    Beans
    117
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Acer Aspire TimelineX AS1830T Thread

    I just wanted to share these power saving tweaks as I've been testing out various combinations to lower power to get longer battery and more quiet fan. I got the info from here: http://www.phoronix.com/scan.php?pag...15_power&num=1

    The problem was I was seeing a idling power consumption of around 10-14W on my 1830TZ which was much higher than when I first got Ubuntu on it. I remember seeing battery times of around 8 hours on idling and I wanted it back! Before these tweaks I had abt 4 hours. I know it can be tweaked even more but I'm no fanatic, just want a reasonable time and not waste power on unnecessary things but without lowering the usability.

    Background is there was a power regression in the Linux kernel starting some time ago, read more on the link I gave if you're interested. This affects also Ubuntu 11.10. The biggest problem is PCI Express Active-State Power Management (PCI-E ASPM) that can again be activated, it's probably not active in your kernel. The reason it was removed by default was some hardware incompatibility so these tweaks may or may not work on your laptop. I don't know what different hardware spec the 1830 comes with but I'll share mine and if yours are the same you should see the same gain as I have seen. If yours is not the same it might still work or you should try any combination of the kernel parameters.

    So, here we go. My hardware first:

    Code:
    System Information
        Manufacturer: Acer
        Product Name: Aspire 1830T
        Version: V1.11
        Wake-up Type: Power Switch
        SKU Number: Calpella_CRB
        Family: Intel_Mobile
    BIOS Information
        Vendor: INSYDE
        Version: V1.11
        Release Date: 06/04/2010
        ROM Size: 2048 kB
        Characteristics:
            PCI is supported
            BIOS is upgradeable
            BIOS shadowing is allowed
            Boot from CD is supported
            Selectable boot is supported
            EDD is supported
            Japanese floppy for NEC 9800 1.2 MB is supported (int 13h)
            Japanese floppy for Toshiba 1.2 MB is supported (int 13h)
            5.25"/360 KB floppy services are supported (int 13h)
            5.25"/1.2 MB floppy services are supported (int 13h)
            3.5"/720 KB floppy services are supported (int 13h)
            3.5"/2.88 MB floppy services are supported (int 13h)
            8042 keyboard services are supported (int 9h)
            CGA/mono video services are supported (int 10h)
            ACPI is supported
            USB legacy is supported
            BIOS boot specification is supported
            Targeted content distribution is supported
        BIOS Revision: 11.240
    Processor Information
        Socket Designation: CPU
        Type: Central Processor
        Family: <OUT OF SPEC>
        Manufacturer: Intel(R) Corporation
        ID: 55 06 02 00 FF FB EB BF
        Version: Intel(R) Pentium(R) CPU        U5400  @ 1.20GHz
        Voltage: 0.0 V
        External Clock: 1066 MHz
        Max Speed: 1200 MHz
        Current Speed: 1193 MHz
        Status: Populated, Enabled
        Upgrade: ZIF Socket
        L1 Cache Handle: 0x0031
        L2 Cache Handle: 0x0030
        L3 Cache Handle: 0x002E
        Serial Number: Not Specified
        Asset Tag: FFFF
        Part Number: Not Specified
        Core Count: 2
        Core Enabled: 2
        Thread Count: 2
        Characteristics:
            64-bit capable
    If you want to read more about the options before you try just click the link to Phoronix above.
    To test these changes out press 'e' when you see grub. move to the line (kernel boot) that ends with 'silent splash' and add:

    Code:
    pcie_aspm=force i915.lvds_downclock=1 i915.i915_enable_rc6=1
    These are the options that works best with my setup. I know a lot of 1830 comes with iX processors. If you have one of these you could also try adding:
    Code:
    i915.i915_enable_fbc=1
    I did not have any luck with this option, it worked but froze my screen after a while. I believe if you have an iX proccessor you will have better luck with this option but I have not tested it since I don't have that processor.

    If the computer seems unstable after adding any or all of these options you can just reboot and everything will be back to normal. If you have freezes like I had you can try pressing ctrl+alt+F1, login at the prompt and do either 'skill -KILL -u username' or just 'reboot' or 'sudo reboot'. If it seems unstable you can try adding just one or any combination of the boot options.

    If you decide that you want to make the changes permanent you can edit /etc/default/grub and edit the line: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash". Add the options that works for you, save and then run 'sudo update-grub'.

    My result, idling is with WiFi enabled and connected and Firefox started with 5 tabs open but not touching anything:
    Idling before tweak: 12-14W
    Idling after tweak: ~7W

    Idling without Firefox and wifi:
    Before: ~11W
    After: 5.8W

    The results are pretty amazing, it's up to 50% power save. And it runs much cooler and is finally quiet again. If you have any other tweaks or suggestions I'm all ears.

    EDIT: I forgot to say that I have also ran PowerTop before measuring my power consumption, and enabled all the tunables, it does quite a difference as well.
    Last edited by scarleo; November 26th, 2011 at 11:36 AM.

Page 3 of 3 FirstFirst 123

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •