Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Cant Connect

  1. #1
    Join Date
    Jun 2010
    Beans
    8

    Cant Connect

    I am using a Belkin wireless card and at&t service. I cant connect to it. It asks for my password and it trys to connect but doesnt and then asks for password again. Any help would be great.

    Thanks

    Chong

  2. #2
    Join Date
    Jun 2008
    Location
    New York
    Beans
    139
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Cant Connect

    Quote Originally Posted by Chong112193 View Post
    I am using a Belkin wireless card and at&t service. I cant connect to it. It asks for my password and it trys to connect but doesnt and then asks for password again. Any help would be great.

    Thanks

    Chong
    Can you provide the model of your Belkin wireless card?

    It also might help if you post the output of the terminal command 'lspci -v'. Please post this in code tags.

  3. #3
    anewguy is offline I Ubuntu, Therefore, I Am
    Join Date
    Jun 2007
    Location
    Sometimes I visit earth
    Beans
    5,440
    Distro
    Ubuntu 12.04 Precise Pangolin

    Wink Re: Cant Connect

    Also, is it asking for your password, or is it asking for the network password?

    Dave

  4. #4
    Join Date
    Jun 2010
    Beans
    8

    Re: Cant Connect

    Quote Originally Posted by Zeike View Post
    Can you provide the model of your Belkin wireless card?

    It also might help if you post the output of the terminal command 'lspci -v'. Please post this in code tags.
    I have no idea what you mean or how to do what you want. It is a Belkin F5D 8053 N Wireless USB. When i go to connect the box that pops up is the Wireless Network Authentication Required, The setting is WPA personal. I hope this helps. I havent been able to find anything that really helps me. I am brand new to Linux.

  5. #5
    Join Date
    Jun 2010
    Beans
    8

    Re: Cant Connect

    Ok I figured out how to do lspci and i do not see my wireless card listed. I also turned off security on my router and that did not help. where can i find a driver for Belkin F5D 8053?

  6. #6
    anewguy is offline I Ubuntu, Therefore, I Am
    Join Date
    Jun 2007
    Location
    Sometimes I visit earth
    Beans
    5,440
    Distro
    Ubuntu 12.04 Precise Pangolin

    Wink Re: Cant Connect

    Please see the following link for information on getting this adapter working. If you have ANY questions on how to do the things in that link, please post back! We all know how confusing/intimidating some of this can appear when you are new to it, so we are here to help you!

    Belkin F5D 8053 N Wireless USB

    EDIT: I should add that after the driver is installed, you still have to provide the encryption type and the password/passphrase associated with it in order to connect to the router.

    Dave

    PS - Since your adapter is a USB device, it won't show in the output of lspci. "ls" stands for "list" and "pci" means the PCI devices on your system, so "lspci" no matter what options are added will only show PCI devices.

    There is a similar command for USB devices, like your adapter - lsusb. Again, the "ls" stands for "list" and "usb" means the USB devices on your system, so "lsusb" will list the USB devices on your system.

    For both of these commands there are also options that can be used to isolate on a specific device, get more detail, etc. Most of the time when we are trying to help we just want the standard output.

    There may be exceptions:

    for example, to list the network adapters, we may ask you to do the following or others:

    lspci

    ifconfig
    Last edited by anewguy; June 23rd, 2010 at 09:05 PM.

  7. #7
    Join Date
    Jun 2010
    Beans
    8

    Re: Cant Connect

    when i type lsusb i get
    kids@ubuntu:~$ lsusb
    Bus 002 Device 003: ID 058f:9360 Alcor Micro Corp. 8-in-1 Media Card Reader
    Bus 002 Device 002: ID 04fc:0003 Sunplus Technology Co., Ltd CM1092 Optical Scroller Mouse
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 001 Device 005: ID 050d:815c Belkin Components
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    kids@ubuntu:~$

    when i type i get

    eth0 Link encap:Ethernet HWaddr 00:15:58:1c:b9:67
    inet addr:192.168.1.105 Bcast:192.168.1.255 Mask:255.255.255.0
    inet6 addr: fe80::215:58ff:fe1c:b967/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:6078 errors:0 dropped:0 overruns:0 frame:0
    TX packets:2766 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:4446986 (4.4 MB) TX bytes:411992 (411.9 KB)
    Interrupt:20

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:436 errors:0 dropped:0 overruns:0 frame:0
    TX packets:436 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:33000 (33.0 KB) TX bytes:33000 (33.0 KB)

    wlan0 Link encap:Ethernet HWaddr 00:22:75:3c:c4:bd
    inet6 addr: fe80::222:75ff:fe3c:c4bd/64 Scope:Link
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:139 errors:0 dropped:0 overruns:0 frame:0
    TX packets:10 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:39526 (39.5 KB) TX bytes:2016 (2.0 KB)

    I ran a cord from my router upstairs thru the house so i am online but i would like to be wireless. When i copy the link above this is the address i get http://Belkin F5D 8053 N Wireless USB

    I also found http://swiss.ubuntuforums.org/showthread.php?t=1382798 but it might as well be written in chinese. So far all i Know is ls

  8. #8
    anewguy is offline I Ubuntu, Therefore, I Am
    Join Date
    Jun 2007
    Location
    Sometimes I visit earth
    Beans
    5,440
    Distro
    Ubuntu 12.04 Precise Pangolin

    Wink Re: Cant Connect

    Sorry about messing up the link - indeed the thread you found, http://swiss.ubuntuforums.org/showthread.php?t=1382798, is the link I was trying to point to. If you are confused by this thread, please let us know where you get lost and we'll help you through it.

    Dave

  9. #9
    anewguy is offline I Ubuntu, Therefore, I Am
    Join Date
    Jun 2007
    Location
    Sometimes I visit earth
    Beans
    5,440
    Distro
    Ubuntu 12.04 Precise Pangolin

    Wink Re: Cant Connect

    Okay, I'm going to see if I can walk you through this. Be aware I don't have your adapter, so I'm trying to take the instructions in the post and hopefully put things in a way you can follow. Please remember that Linux is case sensitive, so you must put in uppercase when shown.

    (1) While hard wired to your to your router so you can get on the net, copy and paste this into the address line and press enter:

    http://www.ralink.com.tw/support.php?s=2

    This will get you to the ralink support page for downloading Linux drivers. Look down that page to about the 7th entry or so - the title should read:

    RT2870USB(RT2870/RT2770)

    Click on this title to begin the download of the file containing the driver for your wireless adapter.

    Wait until this has finished before proceeding.

    (2) Open a terminal window (Applications/Accessories/Terminal)

    (3) My Ubuntu defaults to downloading into a folder called Downloads, so I'm going to assume yours does as well. With this in mind, type:

    cd Downloads <press enter>

    (4) Type:

    ls <press enter>

    You should see a file there called "RT2870_LinuxSTA_V2.3.0.0.tar.tar.bz2". If you don't see this file, STOP here and post back.

    (5) Type:

    tar xfj RT2870_LinuxSTA_V2.3.0.0.tar.tar.bz2 <press enter>

    This will decompress the downloaded driver file and create a folder called "RT2870_LinuxSTA_v2.3.0.0" in the Downloads folder.

    (6) Type:

    cd RT2870_LinuxSTA_V2.3.0.0 <press enter>

    This "c"hanges your default "d"irectory to the newly created folder containing all of the driver information.

    (7) Now you must configure the driver. To do this, you must edit a config file. The instructions in the link say to use nano, but since you do have a GUI, you can use gedit instead:

    gedit os/linux/config.mk <press enter>

    This will call up the editor and open the config.mk file supplied with the driver information. Search for about the section beginning with the 4th leading "#" character. You should see the following:

    # Support Wpa_Supplicant
    HAS_WPA_SUPPLICANT=n

    # Support Native WpaSupplicant for Network Maganger
    HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=n


    These 2 items are describing whether or not the driver supports WPA supplicant (used for encryption). You need to change both "=n" sequences to "=y" for these 2 items only. The result should be a section that looks like the following:

    # Support Wpa_Supplicant
    HAS_WPA_SUPPLICANT=y

    # Support Native WpaSupplicant for Network Maganger
    HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y


    Don't change or delete any other part of the file. Now save the file and exit the editor.

    (8\) Now the driver must be built. This requires a couple of packages to be installed first. Type:

    sudo apt-get install build-essential linux-headers-generic <press enter>


    This will ask for a password - just type in your regular password. As you are typing your password nothing will show on the screen but don't worry. This is a security feature so someone else cannot see your password or know the length. Just press enter after you have typed your password. It may prompt you saying it needs to use xxx of disk space and ask if this is ok - just press y and press enter. Wait for this to complete and return you to the prompt.

    Now to build the driver:

    make <press enter>

    This step actually compiles the driver.

    (9) Now to install the driver:

    sudo make install <press enter>

    If prompted again for your password, just enter it as per step (8\).

    (10) Now the default drivers for the adapter delivered in 10.04 must be made not to load, so as not to step on the new driver. To do so, we add the default driver modules to a "black list" file. This file is used at boot to tell Ubuntu not to load the certain kernel modules. The link says to do this in a different file, but I know I don't have that file, and I know the following WILL work - type:

    sudo gedit /etc/modprobe.d/blacklist.conf <press enter>

    Again, this will open the editor with the file blacklist.conf showing. Go to the bottom of this file and add the following lines:

    # Blacklist the default usb drivers for rslink card
    blacklist rt2500usb
    blacklist rt2800usb

    Save the file and exit the editor.

    (11) The link shows part of the code needed to manually remove the existing modules and load the new ones, but the easiest way, as stated in the link, is to just reboot.

    (12) Now right click on the network manager icon and be sure "Enable Wireless" is checked.

    (13) Click on the network manager icon and see if wireless networks now show. If so, you're good to go. Be sure to set up your connection to match the encryption and password/passphrase used on the router, and add your adapters' MAC address to the router MAC address table if you are using MAC filtering on the router.

    My EXTREME thanks to user Compu-king for his thread (the link) the contained all of this information. I just tried ( I *hope* successfully) to make it more friendly to the absolute beginning user.

    Please post back letting us know if this worked or not. Once it is working, please also open the link to the howto and thank compu-king there.

    Dave
    Last edited by anewguy; June 24th, 2010 at 06:55 AM.

  10. #10
    Join Date
    Mar 2009
    Location
    Lima, Peru
    Beans
    46
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Cant Connect

    @anewguy nice explanation! .@Chong112193 If you still have problems maybe...just maybe (I'm trying to cover all posibilities) your wireless connection on your laptop isn't configured well. Problems may arise when using a Dynamic IP address when DHCP is disabled or only "well-known" IPs are allowed on your router. Or when using Static IP address when DHCP is enabled and that IP is out of the allowed pool of IPs.

    If you tell us that everything is fine with the wired connection,check if both wired and wireless connection have the same configuration. To do this right-click over the wireless network icon on top of your desktop. Go to "Edit Connections", in the window that pops up chose the tab Wired, your connections name should be "ethernet" choose it and the "Edit" button on your right will be enabled, click "Edit" choose the tab "IPv4 Settings" and check the "Method" value. If "Automatic (DHCP)" is selected or "Manual", you have to verify you have the same "Method" enabled in you Wireless connection.
    To check it just repeat all the steps above, take note that under Wireless Tab you may find several connections, just choose YOURS and follow the steps. Remember you must have the same "Method" as wired (Because you say Wired connection is working).

    I hope it helps and good luck!
    The information is free, share it!
    Linux User #488015 Ubuntu User #26785

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •