Results 1 to 8 of 8

Thread: 11.10 does not recognize my cable connection

  1. #1
    Join Date
    May 2008
    Beans
    8

    11.10 does not recognize my cable connection

    Hello everybody,
    this is my little problem: i upgraded today from 11.04 to 11.10 and ubuntu doesn't se my internet connection anymore.
    The only way to get the internet to work is to open a terminal and write: <<sudo dhclient eth0 up>>, terminal answers saying that it <<cannot find device "up">>, but in that moment the network manager starts working and I manage to browse the internet.
    Does anybody have an idea how to fix this?
    Thank you for your help.

  2. #2
    Join Date
    Jul 2011
    Beans
    3

    Re: 11.10 does not recognize my cable connection

    I haven't got a solution I'm afraid but can confirm the issue on 11.10 and your workaround helped me out for now. thanks

  3. #3
    Join Date
    Jan 2008
    Location
    Manchester UK
    Beans
    13,635
    Distro
    Ubuntu

    Re: 11.10 does not recognize my cable connection

    Moved to Networking.

  4. #4
    Join Date
    May 2005
    Location
    Malvern, UK
    Beans
    245
    Distro
    Ubuntu

    Re: 11.10 does not recognize my cable connection

    Just a quick bump that this workaround has helped to resolve my networking issues on my secondary machine.

  5. #5
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,175
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: 11.10 does not recognize my cable connection

    @baffodoro,
    If you are still having the problem and are looking for solution, please post outputs of:
    Code:
    cat /etc/network/interfaces
    ifconfig -a
    sudo dhclient
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags
    Am I not replying you? Perhaps this is why.

  6. #6
    Join Date
    Jul 2011
    Beans
    3

    Re: 11.10 does not recognize my cable connection

    cat /etc/network/interfaces
    ifconfig -a
    sudo dhclient

    Before invoking sudo dhclient eth0 up:

    Code:
    george@george-laptop:~$ cat /etc/network/interfaces
    auto lo
    iface lo inet loopback
    george@george-laptop:~$ 
    george@george-laptop:~$ ifconfig -a
    eth0      Link encap:Ethernet  HWaddr 00:16:d4:9a:9b:e2  
              BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
              Interrupt:16 
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:296 errors:0 dropped:0 overruns:0 frame:0
              TX packets:296 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:23072 (23.0 KB)  TX bytes:23072 (23.0 KB)
    
    vboxnet0  Link encap:Ethernet  HWaddr 0a:00:27:00:00:00  
              BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
    
    wlan0     Link encap:Ethernet  HWaddr 00:18:de:ad:ce:15  
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
    george@george-laptop:~$ 
    george@george-laptop:~$ sudo dhclient
    [sudo] password for george: 
    george@george-laptop:~$
    After invoking sudo dhclient eth0 up:
    Code:
    george@george-laptop:~$ ifconfig -a
    eth0      Link encap:Ethernet  HWaddr 00:16:d4:9a:9b:e2  
              inet addr:192.30.0.68  Bcast:192.30.0.255  Mask:255.255.255.0
              inet6 addr: fe80::216:d4ff:fe9a:9be2/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:347 errors:0 dropped:0 overruns:0 frame:0
              TX packets:181 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:67254 (67.2 KB)  TX bytes:28227 (28.2 KB)
              Interrupt:16 
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:616 errors:0 dropped:0 overruns:0 frame:0
              TX packets:616 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:48408 (48.4 KB)  TX bytes:48408 (48.4 KB)
    
    vboxnet0  Link encap:Ethernet  HWaddr 0a:00:27:00:00:00  
              BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
    
    wlan0     Link encap:Ethernet  HWaddr 00:18:de:ad:ce:15  
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
    
    george@george-laptop:~$ sudo dhclient
    Rather than invoking init scripts through /etc/init.d, use the service(8)
    utility, e.g. service smbd reload
    
    Since the script you are attempting to invoke has been converted to an
    Upstart job, you may also use the reload(8) utility, e.g. reload smbd
    RTNETLINK answers: File exists
    george@george-laptop:~$
    sudo dhclient eth0 up returns:
    Code:
    george@george-laptop:~$ sudo dhclient eth0 up
    Cannot find device "up"
    but causes the cable in the ethernet slot to be detected.
    Thanks

  7. #7
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,175
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: 11.10 does not recognize my cable connection

    The error message is because dhclient only takes 'interfaces' (their logical names) as arguments. As such, the command should be either sudo dhclient only or sudo dhclient eth0 (where eth0 is logical name for Ethernet interface, may be different in some cases).


    The command dhclient not returning any outputs is somewhat confusing to me, although I am experiencing the same on my Natty VM. So it seems like maybe its behaviour has changed in 11.04 onwards, but am not sure.

    As for the problem, right-click on the network manager icon and make sure there is a tick-mark beside "Enable Networking". Another thing in Network Manager to make sure is that the default wired connection is set to "Connect Automatically". To check that, right-click on NetworkManager icon > Click "Edit Connections" > double click the connection-name under "Wired" tab (usually it is Auto eth0) > make sure the "Connect Automatically" check box is checked. If both these options are already ticked, please post the output of:
    Code:
    cat /etc/NetworkManager/NetworkManager.conf
    Also, please confirm whether you have configured the IP address manually or is set to 'Automatic' (default)?
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags
    Am I not replying you? Perhaps this is why.

  8. #8
    Join Date
    May 2008
    Beans
    8

    Re: 11.10 does not recognize my cable connection

    Thank you, i am checking the rest, see this output, thanks a lot:

    Code:
    jeanpierre@jeanpierre-desktop:~$ ifconfig -a
    eth0      Link encap:Ethernet  HWaddr 00:1a:a0:8e:2d:d6  
              BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisioni:0 txqueuelen:1000 
              Byte RX:0 (0.0 B)  Byte TX:0 (0.0 B)
              Interrupt:20 Memoria:fdfc0000-fdfe0000 
    
    lo        Link encap:Loopback locale  
              indirizzo inet:127.0.0.1  Maschera:255.0.0.0
              indirizzo inet6: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:8 errors:0 dropped:0 overruns:0 frame:0
              TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
              collisioni:0 txqueuelen:0 
              Byte RX:480 (480.0 B)  Byte TX:480 (480.0 B)
    
    jeanpierre@jeanpierre-desktop:~$ sudo dhclient
    [sudo] password for jeanpierre: 
    jeanpierre@jeanpierre-desktop:~$ sudo dhclient
    jeanpierre@jeanpierre-desktop:~$ cat /etc/network/interfaces
    auto lo
    iface lo inet loopback

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •