Page 2 of 5 FirstFirst 1234 ... LastLast
Results 11 to 20 of 42

Thread: Trouble getting JACK to work in UbuntuStudio 10.04

  1. #11
    Join Date
    Jan 2009
    Location
    The Netherlands
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Trouble getting JACK to work in UbuntuStudio 10.04

    Thanks for the info. You have an AC'97 onboard card. So you'll probably have to raise your Frames/Period setting way higher like 1024, maybe 512 but don't expect to get it any lower without JACK nagging
    These old onboard chipsets aren't well suited for realtime audio stuff.

  2. #12
    Join Date
    Jun 2010
    Beans
    32
    Distro
    Ubuntu Studio 10.04 Lucid Lynx

    Re: Trouble getting JACK to work in UbuntuStudio 10.04

    I have raised my Frames per period to 1024 and then even to 4096, but it is still not working.

  3. #13
    Join Date
    May 2009
    Beans
    Hidden!

    Re: Trouble getting JACK to work in UbuntuStudio 10.04

    what boggles me is the "`default' server already active" message in the first post. it should normally indicate that a jack server with the server name "default" is already running (I think jackd is designed to run multiple instances, each with its own name...), but the "ps ax | grep jackd" gives no result (other than grep running with that parm)! ...but I'm no command line wiz, maybe that ps command won't list jackd's startet as root?

    does jack still fail with that particular message?

    now I've seen that the o.p. mentioned the "run jack at startup" option, please try to disable it, reboot & use qjackctl or terminal instead to fire up jack manually. something goes wrong there somehow

  4. #14
    Join Date
    Jun 2008
    Location
    Gipuzkoa, Spain
    Beans
    732
    Distro
    Ubuntu Studio 10.04 Lucid Lynx

    Re: Trouble getting JACK to work in UbuntuStudio 10.04

    Oops! I meant "ulimit -l" for the memlock value. a stands for "all", so the info is there, all the same. PAM limits are not the problem here.

    I don't see why jack doesn't start with 1024 frames or even more. Anyway, please, give the info on your jack settings when you post. These are reflected in a command line that you can see (from a default user terminal) with:

    $ cat .jackdrc

    Or else, paste the whole messages window.

    Also, please, complete the info with these commands:

    $ cat /proc/asound/modules
    $ aplay -l


    Another question, have you tried with the realtime kernel?

    Consider joining #ubuntustudio IRC channel on irc.freenode.net to get help in real time (no pun intended). You can use pidgin or xchat, or even the internet browser, URL:
    http://webchat.freenode.net/

    EDIT: RaumTrug, I think he refers to the option in the "Others" Tab, so that the jack server starts when you start qjackctl, without the need of pressing the "Start" button. This is for convenience but it doesn't make any difference.

    Cheers! Pablo
    Last edited by Pablo_F; June 23rd, 2010 at 10:42 PM.

  5. #15
    Join Date
    Jun 2008
    Location
    Gipuzkoa, Spain
    Beans
    732
    Distro
    Ubuntu Studio 10.04 Lucid Lynx

    Re: Trouble getting JACK to work in UbuntuStudio 10.04

    what boggles me is the "`default' server already active" message in the first post.
    Aham, but maybe the "default server" refers not to jack but to another server? Pulseaudio?

    It is weird because qjackctl launches pasuspender.

    With that error, what is the output of

    $ ps ax | grep pulse
    $ ps ax | grep alsa


    ?

  6. #16
    Join Date
    Jun 2010
    Beans
    32
    Distro
    Ubuntu Studio 10.04 Lucid Lynx

    Re: Trouble getting JACK to work in UbuntuStudio 10.04

    Right, sorry for not replying for a little while, GCSEs have required my full attention.

    cat .jackdrc gives:
    /usr/bin/jackd -p128 -t1000 -dalsa -dhw:0,0 -r44100 -p1024 -n3

    cat /proc/asound/modules gives:
    0 snd_intel8x0

    aplay -l gives:
    **** List of PLAYBACK Hardware Devices ****
    card 0: I82801DBICH4 [Intel 82801DB-ICH4], device 0: Intel ICH [Intel 82801DB-ICH4]
    Subdevices: 0/1
    Subdevice #0: subdevice #0
    card 0: I82801DBICH4 [Intel 82801DB-ICH4], device 4: Intel ICH - IEC958 [Intel 82801DB-ICH4 - IEC958]
    Subdevices: 1/1
    Subdevice #0: subdevice #0

    Pablo_F, no, I have not tried running it with RT-kernel. Or at least I don't think I have.

    When I press start in qjackctl, I get the following message:
    22:43:30.473 Startup script...
    22:43:30.474 artsshell -q terminate
    sh: artsshell: not found
    22:43:30.877 Startup script terminated with exit status=32512.
    22:43:30.878 JACK is starting...
    22:43:30.878 /usr/bin/jackd -p128 -t1000 -dalsa -dhw:0,0 -r44100 -p4096 -n3
    jackd 0.118.0
    Copyright 2001-2009 Paul Davis, Stephane Letz, Jack O'Quinn, Torben Hohn and others.
    jackd comes with ABSOLUTELY NO WARRANTY
    This is free software, and you are welcome to redistribute it
    under certain conditions; see the file COPYING for details
    Memory locking is unlimited - this is dangerous. You should probably alter the line:
    @audio - memlock unlimited
    in your /etc/limits.conf to read:
    @audio - memlock 563640
    22:43:30.910 JACK was started with PID=2177.
    no message buffer overruns
    JACK compiled with System V SHM support.
    `default' server already active
    22:43:31.219 JACK was stopped with exit status=1.
    22:43:31.220 Post-shutdown script...
    22:43:31.220 killall jackd
    22:43:31.644 Post-shutdown script terminated successfully.
    22:43:32.953 Could not connect to JACK server as client. - Overall operation failed. - Unable to connect to server. Please check the messages window for more info.

    The System Monitor now tells me that I am running the process jackd, but that it has a "zombie" status. While I'm guessing this isn't as sinister as the name suggests, is it bad?


    Finally:

    ps ax | grep pulse gives:
    1471 ? S<sl 0:04 /usr/bin/pulseaudio --start --log-target=syslog
    1481 ? S 0:00 /usr/lib/pulseaudio/pulse/gconf-helper
    2211 pts/0 S+ 0:00 grep --color=auto pulse

    ps ax | grep alsa gives:
    2213 pts/0 S+ 0:00 grep --color=auto alsa

    Hope this extra info helps!

  7. #17
    Join Date
    May 2009
    Beans
    Hidden!

    Re: Trouble getting JACK to work in UbuntuStudio 10.04

    I've just had some boredom & sparetime and checked the sources of jack 0.118.0 (not the apt-get source "ubuntu version", but the release version from the official jack website due to lack of a running lucid) out of curiosity, it seems this message is indeed related to another jack server with the same "server name" already existant in the system. at least it should be, normally... ;D

    I think other programs like alsa servers or pulseaudio can't interfere there.

    some technical stuff:

    look in jack sources, jackd.c line 728, there a new server is about to be registered, and when return value suggests there's another with the same name, the above error message will be generated & exit.

    further in, in shm.c line 410 is the only place where the return value that indicates another jack existing is triggered from the registering function, when in the jack transprocess-sharedmem infothingie there's another server with the same name (in this case "default"), that reacts to being sent signal "0" (probe signal if I understand correctly).

    so there must be either another jack server running on the system, or something got really messed up elsewhere (in the jack shm info, for example, or corrupted data somewhere, a jackd process refusing to be killed, another "user" running jack...)

    smitherenz, could you reboot your pc, and try starting jack again, having made sure you disabled automatic jack startup _everywhere_, and using conservative parameters/settings befor starting it? does it still give the "`default' server already active" msg the first time you try starting then?

    if it does, can you try to start jackd with an additional "-n test" parameter (tries to give the new server the name "test", choose any...)?

    edit: okie, kill that zombie & try again!
    Last edited by RaumTrug; June 24th, 2010 at 11:02 PM. Reason: aha...

  8. #18
    Join Date
    Jun 2010
    Beans
    32
    Distro
    Ubuntu Studio 10.04 Lucid Lynx

    Re: Trouble getting JACK to work in UbuntuStudio 10.04

    So here is what I just did:
    • Rebooted.
    • Checked the system monitor, and jackd was not running.
    • Loaded qjackctl, and left the settings as shown in the print screen attachment.
    • Tried to start JACK and got the normal message:
      23:27:11.933 Startup script...
      23:27:11.933 artsshell -q terminate
      sh: artsshell: not found
      23:27:12.336 Startup script terminated with exit status=32512.
      23:27:12.337 JACK is starting...
      23:27:12.337 /usr/bin/jackd -p128 -t1000 -dalsa -dhw:0,0 -r44100 -p4096 -n3
      jackd 0.118.0
      Copyright 2001-2009 Paul Davis, Stephane Letz, Jack O'Quinn, Torben Hohn and others.
      jackd comes with ABSOLUTELY NO WARRANTY
      This is free software, and you are welcome to redistribute it
      under certain conditions; see the file COPYING for details
      23:27:12.361 JACK was started with PID=2022.
      Memory locking is unlimited - this is dangerous. You should probably alter the line:
      @audio - memlock unlimited
      in your /etc/limits.conf to read:
      @audio - memlock 563640
      no message buffer overruns
      JACK compiled with System V SHM support.
      loading driver ..
      apparent rate = 44100
      creating alsa driver ... hw:0,0|hw:0,0|4096|3|44100|0|0|nomon|swmeter|-|32bit
      control device hw:0
      23:27:13.070 JACK was stopped successfully.
      23:27:13.071 Post-shutdown script...
      23:27:13.071 killall jackd
      23:27:13.073 JACK has crashed.
      jackd: no process found
      23:27:13.737 Post-shutdown script terminated with exit status=256.
      23:27:14.574 Could not connect to JACK server as client. - Overall operation failed. - Unable to connect to server. Please check the messages window for more info.


    So not much luck there. After this there was no sign of the zombie, but when it is here, I am unable to stop the process.

    Where do I need to use the -n test??? Do I need to run i from the terminal, and if so, with what?
    Attached Images Attached Images

  9. #19
    Join Date
    May 2009
    Beans
    Hidden!

    Re: Trouble getting JACK to work in UbuntuStudio 10.04

    nah, forget about the "-n servername" test, it could be added to the server path thing I guess, but as you found the "zombie" it's probably more important to get rid of the cause of it instead of creating yet more....maybe you can add "--verbose" to the jackd path to get more info, but I'm not sure if that would work this way

    maybe it could run with 2 periods/buffer, and also 512 frames/period, and 48000 sampling rate as a start. mine card crashes with certain settings, too, like 3 periods or too many frames/period. and I remember some hda_intel cards can't really run 44100 but only 48000 stable.

    good luck!

  10. #20
    Join Date
    Jul 2008
    Location
    Sydney Australia
    Beans
    339

    Re: Trouble getting JACK to work in UbuntuStudio 10.04

    `default' server already active
    You might be trying to start a second instance of jack

Page 2 of 5 FirstFirst 1234 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •