Page 53 of 115 FirstFirst ... 343515253545563103 ... LastLast
Results 521 to 530 of 1141

Thread: HOW TO Set Up the Bamboo Pen & Touch in Lucid

  1. #521
    Join Date
    Apr 2008
    Beans
    110

    Re: HOW TO Set Up the Bamboo Pen & Touch in Lucid

    Quote Originally Posted by dr4ziw View Post
    0.8.8-10 provides you with the stable kernel module, while -- as far as I know -- input-wacom-0.10.10 is more experimental.
    Ok, thanks for clearing that up.

    Quote Originally Posted by dr4ziw View Post
    As for the tablet no longer working with newer kernel versions... Did you rebuild the wacom.ko kernel module after upgrading the kernel?
    No... I didn't.

    I rebuilt (using both input-wacom-0.10.10 and linuxwacom-0.8.8-10, the latter of which is currently installed) and now I get the tablet mostly working again, but the pad buttons still move the cursor to the top left of the screen.

    I'll note that I saw this problem with my old Bamboo (just Bamboo, not Pen or Pen&Touch) and that the problem went away after upgrading the driver. Also, I'll note that the P&T works on my laptop, but not on my desktop. The only difference between the two systems (both run Lucid with all updates and, essentially, the exact same set of packages installed), is that one has an ATI gfx card and the other an Nvidia. I'm not sure, but is the x-server implemented by the proprietary driver? Is this the reason it works on one computer and not the other?

  2. #522
    Join Date
    Nov 2008
    Beans
    9,635
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: HOW TO Set Up the Bamboo Pen & Touch in Lucid

    Hi cheshirekow,

    They all have to go through the Xserver/Xwindow. The proprietary drivers can affect things but not usually something like the pad/tablet buttons.

    On the non-working Desktop system, since you've recompiled the wacom.ko (& recloned xf86-input-wacom?), check in /usr/local/bin for xsetwacom (it should be in /usr/bin). This may mean you forgot the '--prefix=/usr' flag on the xf86-input-wacom configure line. In which case you may have a xsetwacom executable in both locations and are experiencing version conflict. Delete the one in the wrong location, i.e. /usr/local/bin.

  3. #523
    Join Date
    Oct 2009
    Beans
    89

    Re: HOW TO Set Up the Bamboo Pen & Touch in Lucid

    Quote Originally Posted by cheshirekow View Post
    now I get the tablet mostly working again, but the pad buttons still move the cursor to the top left of the screen.
    Quote Originally Posted by Favux View Post
    They all have to go through the Xserver/Xwindow. The proprietary drivers can affect things but not usually something like the pad/tablet buttons.
    cheshirekow, did you configure the pad buttons at all, e.g. with the example .xsetwacom.sh script you can find in the very first posting of this thread?
    (very likely you'd have to change the device IDs according to 'xinput --list', or use the devices' full names)

    In any case, checking for a duplicate xsetwacom, as Favux suggests, and removing the one from /usr/local/bin (if there is one), wouldn't hurt. It just happens too easily that you forget to pass '--prefix=/usr' as an option to ./autogen.sh or ./configure...

    Cheers,
    - dr4ziw -

  4. #524
    Join Date
    Apr 2008
    Beans
    110

    Re: HOW TO Set Up the Bamboo Pen & Touch in Lucid

    Quote Originally Posted by Favux View Post
    On the non-working Desktop system, since you've recompiled the wacom.ko (& recloned xf86-input-wacom?), check in /usr/local/bin for xsetwacom (it should be in /usr/bin). This may mean you forgot the '--prefix=/usr' flag on the xf86-input-wacom configure line. In which case you may have a xsetwacom executable in both locations and are experiencing version conflict.
    Good call... that was the problem. Forgot --prefix=/usr

    Now the pad is mostly working, but every once in a while the cursor jumps around very far. It seems that clicks are registered randomly, and the buttons may or may not actually register a click. I'm pretty sure I've seen these symptoms elsewhere on this thread so I'll try all the xsetwacom settings and see if I can't fix stuff.

    By the way, I compiled the xserver driver from xf86-input-0.10.10 and not from the git because when I use the git version I get the following:

    Code:
    /usr/share/aclocal/xorg-macros.m4:39: XORG_MACROS_VERSION is expanded from...
    configure.ac:44: the top level
    despite having apt-get install'ed all the required packages.

  5. #525
    Join Date
    Nov 2008
    Beans
    9,635
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: HOW TO Set Up the Bamboo Pen & Touch in Lucid

    Not sure what that's about. Check /usr/share/aclocal/ and make sure xorg-macros.m4 v. 1.8 has the date you compiled it if you have Lucid. Also check that you don't have two copies. If you are in Maverick you could try making a backup and compiling a new 1.8 in it's place.

    You don't want 0.10.10 because it has a known bug for the pad. You want it a few commits later when that was fixed, i.e. clone the git.

  6. #526
    Join Date
    Mar 2008
    Location
    Kortrijk (Belgium)
    Beans
    7
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Question Re: HOW TO Set Up the Bamboo Pen & Touch in Lucid

    Hi,

    I'm quite new to Ubuntu and have recently installed ubuntu 10.10

    upon connecting my Wacom Bamboo one (CTF-430) it worked immediately but there is a small thing that i'd like to change

    the two buttons on my stylus are not having the function like they have standard in Windows

    my main issue is that i'm used to that the upper button has the function "rightclick"

    right now it is doubleclick
    and the first button is now rightclick


    I was hoping you could help me changing this ?


    thanks for the help

  7. #527
    Join Date
    Jan 2011
    Location
    Barcelona
    Beans
    3
    Distro
    Ubuntu Studio 10.10 Maverick Meerkat

    Re: HOW TO Set Up the Bamboo Pen & Touch in Lucid

    Sorry to let you know that I haven't succeed

    What I have done:
    follow HOW TO: Install a LinuxWacom Kernel Driver for Tablet PC's

    First try:
    Section 1 - The LWP's linuxwacom: Download source code, compile, and install linuxwacom and the USB kernel driver/module wacom.ko. For Lucid and Maverick install just the wacom.ko (do not do 'sudo make install').

    Second try:
    Alternate Section 1 - The LinuxWacom's input-wacom: For Natty Narwhal (11.04) or kernels 2.6.36 and 2.6.37. Download source code, compile, and install the USB kernel driver/module wacom.ko. Only needed by USB tablets.
    [Right now the default wacom.ko in the 2.6.37 kernel is probably preferrable to input-wacom-0.10.10]

    And
    Section 2 - Xorg's xf86-input-wacom: Clone (download source code), compile, and install for Lucid and Maverick.

    but still:
    cht@ubucht2:~/wacom$ xinput --list
    ⎡ Virtual core pointer id=2 [master pointer (3)]
    ⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
    ⎜ ↳ Logitech USB Optical Mouse id=10 [slave pointer (2)]
    ⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Power Button id=6 [slave keyboard (3)]
    ↳ Power Button id=7 [slave keyboard (3)]
    ↳ NOVATEK USB Keyboard id=8 [slave keyboard (3)]
    ↳ NOVATEK USB Keyboard id=9 [slave keyboard (3)]
    ↳ PWC snapshot button id=11 [slave keyboard (3)]
    cht@ubucht2:~/wacom$ xsetwacom -v --list dev
    ... Display is '(null)'.
    ... 'list' requested.

    I'm lost

  8. #528
    Join Date
    Nov 2008
    Beans
    9,635
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: HOW TO Set Up the Bamboo Pen & Touch in Lucid

    Hi andreschandia,

    Sorry to hear that. What I've done is gathered the stuff for adding a new model and put it in one place, post #2, at the beginning of the HOW TO. It's a stand alone mini HOW TO on adding one of the new models. I still have to check a few things but I think it is usable now.

    Since you appear to be using Ubuntu Studios that may be the difficulty. We've had problems with it. Unfortunately it seems different each time. First check the Troubleshooting section. See what kernel you are running and whether you need the 64-bit flag.


    Hi Tercesje,

    The lines to do that are in the sample xsetwacom script .xsetwacom.sh. They look like:
    Code:
    xsetwacom set 9 Button2 "3"  # right mouse click
    xsetwacom set 9 Button3 "2"  # middle mouse click
    in the stylus section. If you want the button assignments reversed change them like so:
    Code:
    xsetwacom set 9 Button2 "2"  # middle mouse click
    xsetwacom set 9 Button3 "3"  # right mouse click
    Using your "Device name" from 'xinput --list' for the ID #9 that the example shows.
    Last edited by Favux; January 10th, 2011 at 12:07 AM.

  9. #529
    Join Date
    Nov 2008
    Beans
    9,635
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: HOW TO Set Up the Bamboo Pen & Touch in Lucid

    Hi everyone,

    Several commits that should affect the Bamboo P & T have just landed in the xf86-input-wacom git repository. I'll reclone it and see if I notice any improvement.

  10. #530
    Join Date
    Jan 2011
    Location
    Barcelona
    Beans
    3
    Distro
    Ubuntu Studio 10.10 Maverick Meerkat

    Re: HOW TO Set Up the Bamboo Pen & Touch in Lucid

    Description: Ubuntu 10.10
    Codename: maverick
    Linux 2.6.35-24-generic #42-Ubuntu SMP Thu Dec 2 01:41:57 UTC 2010 i686 GNU/Linux
    Intel(R) Pentium(R) 4 CPU 2.80GHz

    No Ubuntustudio

    agpgart-intel 0000:00:00.0: Intel 865 Chipset

    xserver-xorg-video-intel 2:2.12.0-1ubuntu5.1

    I will try again with the mini how to, you mention

Page 53 of 115 FirstFirst ... 343515253545563103 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •