Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Squares instead of text

  1. #1
    Join Date
    Jun 2010
    Beans
    27

    Squares instead of text

    Installed 10.04, getting squares instead of text in certain places.

    Sorry for the sixe of the pic. Any ideas?

    Edit bodhi.zazen: Please do not post such large screenshots. Either post a part of the screen or use thumbnails.
    Last edited by davidogg; June 21st, 2010 at 09:05 PM. Reason: photoshop work :P

  2. #2
    Join Date
    Dec 2007
    Location
    The last place I look
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Squares instead of text

    have you changed your fonds recently?
    Things are rarely just crazy enough to work, but they're frequently just crazy enough to fail hilariously.

  3. #3
    Join Date
    Mar 2010
    Location
    Norway
    Beans
    674

    Re: Squares instead of text

    Yes, you could try to change the font the system uses, i don't remember how to do that in gnome, but you will probably find it pretty easily.

  4. #4
    Join Date
    May 2010
    Beans
    20

    Re: Squares instead of text

    I had the smae problem, i cant remember exactly what resolved it im afraid, i know there were alot of system restarts involved (always puts my mind at ease). If you go to the ubuntu software centre and remove the 'installer for microsoft truetype core fonts' if its installed, restart your machine and install it again, your problem should be sorted (i hope) good luck

  5. #5
    Join Date
    Jun 2010
    Beans
    27

    Re: Squares instead of text

    Haven't messed with fonts, but for giggles and kicks I changed them and back to default again, still have the squares. It's really wierd because they are kind of random, and in places where they are working, some lines will be squares, even though they should be using the same font as the lines around it... like here in the Main Menu prefs

    Edit bodhi.zazen: Please do not post such large screenshots. Either post a part of the screen or use thumbnails.
    Last edited by bodhi.zazen; June 21st, 2010 at 08:37 PM.

  6. #6
    Join Date
    Feb 2008
    Location
    United States
    Beans
    326
    Distro
    Xubuntu 13.04 Raring Ringtail

    Re: Squares instead of text

    Quote Originally Posted by davidogg View Post
    Sorry for the sixe of the pic. Any ideas
    Resize in F-Spot.

    As for the fonts, I'd try to reinstall the font packages.

  7. #7
    Join Date
    Apr 2006
    Location
    Montana
    Beans
    Hidden!
    Distro
    Kubuntu Development Release

    Re: Squares instead of text

    Did you change fonts ?

    Tell us more about your installation, is this a minimal install ?

    Are you using or did you enable apparmor ?
    There are two mistakes one can make along the road to truth...not going all the way, and not starting.
    --Prince Gautama Siddharta

    #ubuntuforums web interface

  8. #8
    Join Date
    Jun 2010
    Beans
    27

    Re: Squares instead of text

    Quote Originally Posted by bodhi.zazen View Post
    Did you change fonts ?

    Tell us more about your installation, is this a minimal install ?

    Are you using or did you enable apparmor ?
    Haven't changed any fonts from default. regular install with a few extra packages added for ms codecs. Haven't touched apparmor, unless it's enabled by default. Enabled compiz. Installed debian grub graphics. pretty much stock.

    That Debian icon in my main menu prefs... is that kosher, or possbly something inadvertantly installed with the debian graphics?

    Reinstalling fonts now

  9. #9
    Join Date
    Apr 2006
    Location
    Montana
    Beans
    Hidden!
    Distro
    Kubuntu Development Release

    Re: Squares instead of text

    How did you install the msfonts ?

    Do you have a custom /etc/X11/xorg.conf ?

    Usually one sees blocks in place of text when there is a problem with fonts, either the path is off (set in xorg.conf) or apparmor is blocking access or the fonts have been altered in some way.
    There are two mistakes one can make along the road to truth...not going all the way, and not starting.
    --Prince Gautama Siddharta

    #ubuntuforums web interface

  10. #10
    Join Date
    Jun 2010
    Beans
    27

    Re: Squares instead of text

    Quote Originally Posted by bodhi.zazen View Post
    How did you install the msfonts ?

    Do you have a custom /etc/X11/xorg.conf ?

    Usually one sees blocks in place of text when there is a problem with fonts, either the path is off (set in xorg.conf) or apparmor is blocking access or the fonts have been altered in some way.
    "ttf-mscorefonts-installer" in Software Center. That's removed now, since the fonts are default anyway.

    /etc/X11/xorg.conf ;
    Section "Screen"
    Identifier "Default Screen"
    DefaultDepth 24
    EndSection

    Section "Module"
    Load "glx"
    EndSection

    Section "Device"
    Identifier "Default Device"
    Driver "nvidia"
    Option "NoLogo" "True"
    EndSection

    does that seem a bit sparse?

    the only font's I'm using are the default sans-10, sans bold-10, and monospace-10, I reinstalled the package "ttf-freefont" but still have squares.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •