Results 1 to 5 of 5

Thread: Shift-home, Shift -end not working

  1. #1
    Join Date
    Jun 2010
    Beans
    2

    Shift-home, Shift -end not working

    I have both an inspiron 1721 and a vostro 1700. Both have the numeric key pad on the keyboard.

    I wish to use the windows-style shift-home and shift-end shortcuts (select text to beginning of line and select to end of line from the current cursor position), but they don't seem to work in the test area, nor in gedit.

    I went into Preferences > Keyboard and enabled the windows number pad behavior, but it still doesn't work. I even rebooted.

    What do I have to do to get it to work?

    Thanks!

  2. #2
    Join Date
    Jun 2010
    Beans
    2

    Re: Shift-home, Shift -end not working

    http://geekozoid.blogspot.com/2008/0...t-working.html

    Why is this option is enabled by default is beyond me!

  3. #3
    Join Date
    Jan 2011
    Beans
    3

    Re: Shift-home, Shift -end not working

    Digging up an old post, but i had this problem with a fresh install of 11.04. The above didnt solve my problem as it was un-ticked by default.

    My solution was to go into Keyboard Layout Options, and under "Miscellaneous compatibility options" to tick the box called

    "Shift with numeric keypad works as in MS Windows"

    Fixed and working fine now

  4. #4
    Join Date
    Jun 2011
    Beans
    6
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Shift-home, Shift -end not working

    @Scorp1us, I totally agree. This has been bugging me for a long time and I think I haven't tried to google this bug and today I did and got the solution. It should be enabled by default because it's such a pain to turn the NUM lock on.

    @joe606, thank you so much. Your solution really worked. I have been using Ubuntu since 11.04 but never knew there was a fix to this nuisance. I'm very happy now.

  5. #5
    Join Date
    May 2008
    Location
    Toronto, Ontario, Canada
    Beans
    736
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Shift-home, Shift -end not working

    HI,

    Just installed Ubuntu 13.10 and went to set my keyboard options - as described above and as I have done for every installation of ubuntu since 8.04. There is no longer any setting that will allow me to do this - the Layout Options are now very funky but I cannot find the one that will let me set the Miscellaneous compatibility options. Any help would be much appreciated.

    Thanks,
    "Always take the high road! That way, nothing will hit you when the brown, gooey stuff hits the fan."
    Setup some common software: http://wiki.ubuntu.com/fballem

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •