Page 4 of 7 FirstFirst ... 23456 ... LastLast
Results 31 to 40 of 69

Thread: OpenOffice Open/Save extrmely slow

  1. #31
    Join Date
    Jun 2010
    Location
    South Africa
    Beans
    63
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: OpenOffice Open/Save extrmely slow

    Quote Originally Posted by SwedishWings View Post
    Tombgeek, thanks for helping out!
    Quote Originally Posted by robert shearer View Post
    seconded !
    Glad to help. But I did not even do much. I just sent an issue report.
    Plus anyway, I want this problem fixes as much as you guys. I have a novel to write and I do not really like Abiword that much (and manuscript editing in Abiword sucks, I prefer setting up margins and headers in OpenOffice).

    Sorry Abiword fans, just my opinion.

  2. #32
    Join Date
    Nov 2007
    Location
    New Zealand
    Beans
    1,222
    Distro
    Ubuntu Development Release

    Re: OpenOffice Open/Save extrmely slow

    All beyond me I'm afraid.
    Though from the mention of realpath and the line..

    #2 __realpath (name=0xee6d60f4 "/home/hd114770/tmp/tausch", resolved=0xfffba140 "/net/somehost") at canonicalize.c:162
    does it refer to this ???

    https://www.securecoding.cert.org/co...rusted+sources

  3. #33
    Join Date
    Jun 2010
    Location
    South Africa
    Beans
    63
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: OpenOffice Open/Save extrmely slow

    Quote Originally Posted by robert shearer View Post
    All beyond me I'm afraid.
    Though from the mention of realpath and the line..



    does it refer to this ???

    https://www.securecoding.cert.org/co...rusted+sources
    I don't know.
    All that is beyond me as well.

    hdu said that the attachment was "typical stack during the multisecond "hang"."
    Last edited by Tombgeek; June 21st, 2010 at 01:11 PM.

  4. #34
    Join Date
    Jun 2010
    Location
    South Africa
    Beans
    63
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: OpenOffice Open/Save extrmely slow

    @mav: I looked into the problem again and the problem seems to be in linux running into a timeout
    when it lstats the automounter part of the realpath() result. So it was not the many lookups that were
    the problem, but the one lookup that timed out. Here is the relevant excerpt from strace, which shows
    the 12sec hang:

    14:56:51.25 lstat64("/net", {st_mode=S_IFDIR|0755, st_size=0, ...}) = 0
    14:56:51.25 lstat64("/net/xyz-server-01", <unfinished ...>
    14:57:03.77 <... lstat64 resumed>) = -1 ENOENT (No such file or directory)

    Ceterum censeo: realpath() has no value add in the file-open/save scenario that would be worth a
    multi-second hang
    Also, on there was some letter from a user. This guy experienced the exact same issues.
    But it is in Dutch, so you guys might not understand.
    http://nl.openoffice.org/servlets/Re...rs&msgNo=10601

    Seems the problem is with etc/hosts file

    I don't know, what do you guys think?

  5. #35
    Join Date
    Jun 2010
    Location
    South Africa
    Beans
    63
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: OpenOffice Open/Save extrmely slow

    Another piece in the puzzle: There was a soft-link to a file on a dead server in my default-save dir. You
    can reproduce the problem by creating such a soft-link e.g. in the home directory
    ln -s /net/xyz-server-01/somefile ~/
    and make sure the xyz-server-01 is a known server that is not available. Doing a file-open in OOo for
    e.g. the home directory then triggers a realpath-lookup of the file on the dead server, which results in the
    hang until the lookup timeouts.
    Looks like they found the problem.

  6. #36
    Join Date
    Nov 2007
    Location
    New Zealand
    Beans
    1,222
    Distro
    Ubuntu Development Release

    Re: OpenOffice Open/Save extrmely slow

    Thanks for keeping this alive Tombgeek.

    I have been following it (and your posts) on
    http://www.openoffice.org/issues/show_bug.cgi?id=112546

    and hope for a resolution soon.

    (bumping for the attention of anyone else affected )

  7. #37
    Join Date
    Jul 2009
    Location
    NC, South Africa
    Beans
    212
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: OpenOffice Open/Save extrmely slow

    I am subscribing to this thread, having experienced the same annoying issue.

    I am running Lucid on a home network. If the Internet connection is down (eg. unplugging the router from the LAN), there is a delay of about 20 seconds when opening an OpenOffice word document. If the network is disabled, it opens immediately, but then I lose connection to other PC's.

  8. #38
    Join Date
    Jul 2008
    Beans
    65

    Re: OpenOffice Open/Save extrmely slow

    I am also having this problem with my LTSP users, i have tried turning JAVA off also but problem is still. There is no more load average on server.

  9. #39
    Join Date
    Apr 2008
    Beans
    1

    Re: OpenOffice Open/Save extrmely slow

    Ok, so I am using OOO-3.2 Kubuntu 10.04 but I did not install openoffice.org-kde package but I did install openoffice.org-gtk. Document opening and saving etc was OK but during drawing Xorg was gorging over my CPU. So I thought its probably because of lack of kde customizations i.e. openoffice.org-kde. So I installed it and then the problem of slow opening, save-as-ing, exporting (anything with dialog box) appeared. While exporting a doc the OOO assistant complained that I dont have openoffice help installed. From this forum I got that this slow down problem is some sort of network or database problem. I thought OOO might be looking for the help. So I installed the help files openoffice.org-help-en-us and voila slow down problem gone although Xorg stills shoots up when I do any drawing related movement but I guess we have a resolution on the slow down issue. Please do let all know if it works for you.

  10. #40
    Join Date
    Nov 2007
    Location
    New Zealand
    Beans
    1,222
    Distro
    Ubuntu Development Release

    Re: OpenOffice Open/Save extrmely slow

    So I installed the help files openoffice.org-help-en-us and voila slow down problem gone
    I checked and those were already installed.
    Still, clutching at straws here, I reinstalled.

    I can now report that this package has no affect on the slow file opening and closing on my system.

    I am happy that you have noticed an improvement on yours.

Page 4 of 7 FirstFirst ... 23456 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •