Page 3 of 7 FirstFirst 12345 ... LastLast
Results 21 to 30 of 69

Thread: OpenOffice Open/Save extrmely slow

  1. #21
    Join Date
    Oct 2008
    Beans
    171
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: OpenOffice Open/Save extrmely slow

    Quote Originally Posted by robert shearer View Post
    Looking through all the options for OOorg I get the impression that there is some preload that involves Evolution and am wondering if any of you use or have Evolution on your system ??

    I do not use it so purged it (and all the other social networking gubbins too).

    I wonder now if this has broken a link that involves OOorg so would be interested to know if you are using Evolution or if this is a commonality that may point to a cause.
    Yes, i use Evolution, but the problem is still there.

  2. #22
    Join Date
    Oct 2008
    Beans
    171
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: OpenOffice Open/Save extrmely slow

    Accidentally, i was hooking up on another wireless network yesterday and was surprised to see that the problem was gone while connected in that particular network.

    I have absolutely no idea what the difference was - but the point is that exactly the same configuration seem to work in some networks and not on others.

    Could it be a DNS issue? Or that some ports need to be open in order for OO to open/save properly? Either way, OO is doing something that it should not, that's for sure.
    Last edited by SwedishWings; June 19th, 2010 at 07:11 AM.

  3. #23
    Join Date
    Jun 2010
    Location
    South Africa
    Beans
    63
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: OpenOffice Open/Save extrmely slow

    Quote Originally Posted by SwedishWings View Post
    Accidentally, i was hooking up on another wireless network yesterday and was surprised to see that the problem was gone while connected in that particular network.

    I have absolutely no idea what the difference was - but the point is that exactly the same configuration seem to work in some networks and not on others.

    Could it be a DNS issue? Or that some ports need to be open in order for OO to open/save properly? Either way, OO is doing something that it should not, that's for sure.
    Could be, I have a ADSL connection, so it seems it may be a bug that is only triggured by wired connections.
    Does anyone have an account on www.OpenOffice.org?
    Should I send an e-mail to them and report the bug?

  4. #24
    Join Date
    Oct 2008
    Beans
    171
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: OpenOffice Open/Save extrmely slow

    Quote Originally Posted by Tombgeek View Post
    Should I send an e-mail to them and report the bug?
    I would appreciate that, i have no account.

    Can this be related to network printers? That's the only thing i can imagine that OO might need to see before loading a document. Why save is slow, still is a mystery though.

  5. #25
    Join Date
    Jun 2010
    Location
    South Africa
    Beans
    63
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: OpenOffice Open/Save extrmely slow

    Quote Originally Posted by SwedishWings View Post
    I would appreciate that, i have no account.

    Can this be related to network printers? That's the only thing i can imagine that OO might need to see before loading a document. Why save is slow, still is a mystery though.

    I created an accout. I am just waiting for an email that will verify my login details.
    I did have a look at the Issue Tracker. Someone did mention something about slow saving and loading times, and did mention that it may be a problem that is related to his network printer. But his issue is on Windows XP and I did not check which version of OpenOffice it was. I will get back to you on that one.
    No one has mentioned any issue on Ubuntu about slow loading or saving times. But I will search a bit more.

  6. #26
    Join Date
    Jun 2010
    Location
    South Africa
    Beans
    63
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: OpenOffice Open/Save extrmely slow

    I have sent in an issue report. Hopefully they will get back to me soon.

  7. #27
    Join Date
    Jun 2010
    Location
    South Africa
    Beans
    63
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: OpenOffice Open/Save extrmely slow

    Are there perhaps any Ubuntu 9.10 users who installed OpenOffice 3.2.0 or 3.2.1 and experienced the same bug?

    Here is the report on the OpenOffice.org site:
    http://www.openoffice.org/issues/show_bug.cgi?id=112546

  8. #28
    Join Date
    Oct 2008
    Beans
    171
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: OpenOffice Open/Save extrmely slow

    Tombgeek, thanks for helping out!

  9. #29
    Join Date
    Nov 2007
    Location
    New Zealand
    Beans
    1,222
    Distro
    Ubuntu Development Release

    Re: OpenOffice Open/Save extrmely slow

    Quote Originally Posted by SwedishWings View Post
    Tombgeek, thanks for helping out!
    seconded !

  10. #30
    Join Date
    Jun 2010
    Location
    South Africa
    Beans
    63
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: OpenOffice Open/Save extrmely slow

    Hey guys.

    So they have gotten back to me (as you can see in the link). It seems they have been able to discover the issue. However, due to the fact I am not too experienced with programming (I only know the basics of Delphi and Pascal, and I don't even know how to do loops and string handling), I have absolutly do idea whatsoever of what this guy is talking about. Perhaps you guys know. His username is "hdu":

    Confirming on Debian for doing the file open dialog. Adjusting the priority as the multisecond hang is
    quite bad. Profiling shows that the culprit seems to be the excessive use of "realpath()" on EACH file of the
    active directory:
    - is that level of detail needed when the file name alone should suffice to fill the open/close dialogs?
    - why on each file in the directory?
    Then he placed an attachment:

    #1 ___lxstat64 (vers=3, name=0xfffba140 "/net/hs-eham02-01", buf=0xfffba09c) at sysdeps/unix/sysv/linux/lxstat64.c:48
    #2 __realpath (name=0xee6d60f4 "/home/hd114770/tmp/tausch", resolved=0xfffba140 "/net/somehost") at canonicalize.c:162
    #3 ?? () libuno_sal.so.3
    #4 ?? () from libuno_sal.so.3
    #5 osl_getFileStatus () from libuno_sal.so.3
    #6 osl::DirectoryItem::getFileStatus(osl::FileStatus& ) () from libucpfile1.so
    #7 fileaccess::shell::getv(fileaccess::Notifier*, com::sun::star::uno::Sequence<com::sun::star::bean s::Property> const&, osl::DirectoryItem&, rtl::OUString&, unsigned char&) () from libucpfile1.so
    #8 fileaccess::XResultSet_impl::OneMore() () from libucpfile1.so
    #9 fileaccess::XResultSet_impl::next() () from libucpfile1.so
    #10 svt::FileViewContentEnumerator::enumerateFolderCon tent() () from libsvtli.so
    #11 svt::FileViewContentEnumerator::enumerateFolderCon tentSync(svt::FolderDescriptor const&, IUrlFilter const*, com::sun::star::uno::Sequence<rtl::OUString> const&) () from libsvtli.so
    #12 SvtFileView_Impl::GetFolderContent_Impl(svt::Folde rDescriptor const&, FileViewAsyncAction const*, com::sun::star::uno::Sequence<rtl::OUString> const&) () from libsvtli.so
    #13 SvtFileView_Impl::GetFolderContent_Impl(String const&, FileViewAsyncAction const*, com::sun::star::uno::Sequence<rtl::OUString> const&) () from libsvtli.so
    #14 SvtFileView::ExecuteFilter(String const&, FileViewAsyncAction const*) () from libsvtli.so
    #15 SvtFileView::Initialize(String const&, String const&, FileViewAsyncAction const*, com::sun::star::uno::Sequence<rtl::OUString> const&) ()

Page 3 of 7 FirstFirst 12345 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •