Page 2 of 7 FirstFirst 1234 ... LastLast
Results 11 to 20 of 69

Thread: OpenOffice Open/Save extrmely slow

  1. #11
    Join Date
    Jun 2010
    Location
    South Africa
    Beans
    63
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: OpenOffice Open/Save extrmely slow

    Quote Originally Posted by robert shearer View Post
    Not that I know of. How would I check ?

    Edit, from wikipedia

    Well New Zealand is both an island nation and we do pay for allocation/Mb so it may apply. Must check with ISP.

    Though, why would Open Office be trying to access the web when I am opening local documents ?? Seems rather 'odd' behavior.

  2. #12
    Join Date
    Jul 2007
    Location
    UK
    Beans
    16,808
    Distro
    Ubuntu Development Release

  3. #13
    Join Date
    Nov 2007
    Location
    New Zealand
    Beans
    1,222
    Distro
    Ubuntu Development Release

    Re: OpenOffice Open/Save extrmely slow

    Quote Originally Posted by philinux View Post
    Well, it runs faster as per the link tweaks but won't load files any faster so problem remains the same.

    While the file is being loaded(or waiting to be loaded) there are several activity spikes for the network as viewed in Gnome system monitor.

    As SwedishWings pointed out this causes a timeout and slows file loading.
    Disconnect or disable networking and files load fast.

    So, is that indicative of some sort of database lookup (that we can disable. I cannot find anything in OOorgs options), or a sync to something like Ubuntu One, or is it something more sinister ??

    Of course the fix is to never be online when using Open Office but its not too practical.

  4. #14
    Join Date
    Oct 2008
    Beans
    171
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: OpenOffice Open/Save extrmely slow

    Quote Originally Posted by philinux View Post
    This made no difference for me at all.

    I spent a fair amount of time searching for a solution, but failed. Strange that it only affects some users.

  5. #15
    Join Date
    Jul 2007
    Location
    UK
    Beans
    16,808
    Distro
    Ubuntu Development Release

    Re: OpenOffice Open/Save extrmely slow

    Quote Originally Posted by SwedishWings View Post
    This made no difference for me at all.

    I spent a fair amount of time searching for a solution, but failed. Strange that it only affects some users.
    Very odd. OO opens in less than 2 seconds here.

    Double check in system>network proxy.

    Try running it from a terminal see if there are any messages.

    Code:
    ooffice -writer

  6. #16
    Join Date
    Oct 2008
    Beans
    171
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: OpenOffice Open/Save extrmely slow

    Quote Originally Posted by philinux View Post
    Are you guys using a proxy?
    nope. i'm having the same issue both at home and at my office, with two different operators, so it seem to be network independent.

  7. #17
    Join Date
    Oct 2008
    Beans
    171
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: OpenOffice Open/Save extrmely slow

    Quote Originally Posted by philinux View Post
    Very odd. OO opens in less than 2 seconds here.

    Double check in system>network proxy.

    Try running it from a terminal see if there are any messages.

    Code:
    ooffice -writer
    i tried that, but get no messages at all. is there a debug switch or something for OO?

    You said "opens". I mean opening a document, and sometimes when saving. Are we talking about the same thing here?

  8. #18
    Join Date
    Jul 2007
    Location
    UK
    Beans
    16,808
    Distro
    Ubuntu Development Release

    Re: OpenOffice Open/Save extrmely slow

    Quote Originally Posted by SwedishWings View Post
    i tried that, but get no messages at all. is there a debug switch or something for OO?

    You said "opens". I mean opening a document, and sometimes when saving. Are we talking about the same thing here?
    Yes, I usually double click on a document. So OO opens itself and opens the doc in a flash.

    Might be worth renaming ~/.openoffice.org and let it create a new default profile.
    Last edited by philinux; June 18th, 2010 at 02:03 PM.

  9. #19
    Join Date
    Jun 2010
    Location
    South Africa
    Beans
    63
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: OpenOffice Open/Save extrmely slow

    Quote Originally Posted by robert shearer View Post
    Well, it runs faster as per the link tweaks but won't load files any faster so problem remains the same.

    While the file is being loaded(or waiting to be loaded) there are several activity spikes for the network as viewed in Gnome system monitor.

    As SwedishWings pointed out this causes a timeout and slows file loading.
    Disconnect or disable networking and files load fast.

    So, is that indicative of some sort of database lookup (that we can disable. I cannot find anything in OOorgs options), or a sync to something like Ubuntu One, or is it something more sinister ??

    Of course the fix is to never be online when using Open Office but its not too practical.
    The same thing happens with OpenOffice 3.2.1
    I tried it just now. I disconnected my wired network, and it took a second to load a file.
    <sigh>

    Does anyone know how to fix this?

  10. #20
    Join Date
    Nov 2007
    Location
    New Zealand
    Beans
    1,222
    Distro
    Ubuntu Development Release

    Re: OpenOffice Open/Save extrmely slow

    Looking through all the options for OOorg I get the impression that there is some preload that involves Evolution and am wondering if any of you use or have Evolution on your system ??

    I do not use it so purged it (and all the other social networking gubbins too).

    I wonder now if this has broken a link that involves OOorg so would be interested to know if you are using Evolution or if this is a commonality that may point to a cause.

    Other than that paranoia threatens. Is Oracle or Canonical or some other 'icle 'acle collecting usage stats for OOorg.

    Sufficed to say that until it is sorted I won't be online when using Oorg simply on principle.

    --Phil, I tried opening in console early on but got no messages.

    If it is any help, when this happens there is no extra resource use shown in Gnome monitor (other than network).
    However the entire screen greys out (everything else is still responsive and I can open and use other apps while I wait)

    The only other time I see the greyed out screen is when I install something from a Deb file.

Page 2 of 7 FirstFirst 1234 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •