Results 1 to 6 of 6

Thread: 10.04 service mess up

  1. #1

    Exclamation 10.04 service mess up

    after some upgrade or after install bum(had been removed) or after once open samba share dirctory. service become mess now.

    Code:
    ● nmap me
    
    Starting Nmap 5.00 ( http://nmap.org ) at 2010-06-15 15:33 CST
    Interesting ports on localhost (127.0.0.1):
    Not shown: 996 closed ports
    PORT    STATE SERVICE
    22/tcp  open  ssh
    111/tcp open  rpcbind
    139/tcp open  netbios-ssn
    445/tcp open  microsoft-ds
    
    Nmap done: 1 IP address (1 host up) scanned in 0.17 seconds
    those service like portmap, smbd,nmbd, privoxy, ssh, and so on, is actived. but i does not need those services.

    within sysv-rc-conf, none of those is be set actived, so how can disable those.

    Code:
    ● sudo sysv-rc-conf --list|grep ':on'
    acpi-support 1:off	2:on	3:on	4:on	5:on
    apparmor     S:on
    avahi-daemon 2:on	3:on	4:on	5:on
    binfmt-suppo 2:on	3:on	4:on	5:on
    cron         0:off	1:off	2:on	3:on	4:on	5:on	6:off
    dns-clean    1:on	2:off	3:off	4:off	5:off
    early-readah S:on
    fancontrol   2:on	3:on	4:on	5:on
    grub-common  2:on	3:on	4:on	5:on
    halt         0:on
    incron       0:off	1:off	2:on	3:on	4:on	5:on	6:off
    joystick     0:off	1:off	2:on	3:on	4:on	5:on	6:off
    killprocs    1:on
    klogd        1:off	2:on	3:on	4:on	5:on
    laptop-mode  0:off	1:off	2:on	3:on	4:on	5:on	6:off
    later-readah S:on
    linux-restri 0:on	6:on	S:on
    lm-sensors   S:on
    networking   0:on	6:on
    nvidia-kerne 1:off	2:on	3:on	4:on	5:on
    ondemand     2:on	3:on	4:on	5:on
    policykit    1:off	2:on	3:on	4:on	5:on
    pppd-dns     1:on	2:off	3:off	4:off	5:off
    pulseaudio   0:on	1:off	2:on	3:on	4:on	5:on
    rc.local     2:on	3:on	4:on	5:on
    readahead    S:on
    readahead-de S:on
    reboot       6:on
    screen-clean S:on
    sendsigs     0:on	6:on
    single       1:on
    stop-readahe 2:on	3:on	4:on	5:on
    stop-readahe 0:off	1:off	2:on	3:on	4:on	5:on	6:off
    sysklogd     1:off	2:on	3:on	4:on	5:on
    umountfs     0:on	6:on
    umountroot   0:on	6:on
    unattended-u 0:on	6:on
    urandom      0:on	6:on	S:on
    wpa-ifupdown 0:on	6:on
    x11-common   S:on
    fvwm is the best wm.

  2. #2
    Join Date
    Jun 2010
    Beans
    7

    Re: 10.04 service mess up

    update-rc -f servicename remove

    or go to system>administration>BootUpManager then select which service you want to disable

  3. #3

    Re: 10.04 service mess up

    Code:
    ● sudo update-rc.d -f ssh remove 
     Removing any system startup links for /etc/init.d/ssh ...
    i had done this. those.

    service still here.

    BootUpManager had been removed, and before remove, i had check all its items, and i sure all those services are not active.

    and i think sysv-rc-conf is also follow update-rc.d' rules. this is first time i see sysv-rc-conf become useless.

    thanks.
    fvwm is the best wm.

  4. #4
    Join Date
    Dec 2005
    Location
    Western Australia
    Beans
    11,469
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: 10.04 service mess up

    Quote Originally Posted by eexpress View Post
    Code:
    ● sudo update-rc.d -f ssh remove 
     Removing any system startup links for /etc/init.d/ssh ...
    i had done this. those.

    service still here.

    BootUpManager had been removed, and before remove, i had check all its items, and i sure all those services are not active.

    and i think sysv-rc-conf is also follow update-rc.d' rules. this is first time i see sysv-rc-conf become useless.

    thanks.
    Ubuntu doesn't usee init scripts anymore, so there's little point to those oldd programs like BUM and sysv-rc-conf.

    If you don't need ssh-server and privoxy, then remove them from the system. Some of the other things you mention are required for Samba. If youu don't use Samba then feel free to remove these also.
    I try to treat the cause, not the symptom. I avoid the terminal in instructions, unless it's easier or necessary. My instructions will work within the Ubuntu system, instead of breaking or subverting it. Those are the three guarantees to the helpee.

  5. #5

    Re: 10.04 service mess up

    i do not want remove those applications.

    today, i find bum made a lot of K80 service here. so i remove them.

    sudo rm /etc/rc?.d/K80ssh
    sudo rm /etc/rc?.d/K80nmbd
    ....


    wait for next reboot to see if become ok.

    fvwm is the best wm.

  6. #6

    Re: 10.04 service mess up

    /etc/init
    ● sudo mv smbd.conf ssh.conf nmbd.conf portmap.conf ~
    fvwm is the best wm.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •