krishnik: that's strange. It looks like it could be an issue with the source code. It might help to choose an older version of the code to download from http://linuxwireless.org/download/compat-wireless-2.6/. You have the snapshot from October 22, which may have happened to have errors. The code gets updated every day and some days introduce bugs that prevent it from compiling. It looks like the snapshots from early September worked for others, so I would give those a try.

If that doesn't help, let me know