Anyone else having a problem with nouveau working, not using xorg-edgers ppa.

(II) [drm] nouveau interface version: 0.0.16
(EE) [drm] wrong version, expecting 0.0.1

Did a quick google search and found this mailing list entry, http://lkml.org/lkml/2010/3/4/305

Seems to me that libdrm hasn't been bad backward compatible.