Page 1 of 4 123 ... LastLast
Results 1 to 10 of 37

Thread: Acer Aspire TimelineX 3820TG sound problems

  1. #1
    Join Date
    Jun 2010
    Beans
    9

    Question Acer Aspire TimelineX 3820TG sound problems

    Hello Forum
    When I plug in some external speakers in the headphone jack, the sound disappears. If I unplug them I can hear the sound again...

    Does anyone know how to workaround this problem?

    I got two sound options:
    1. The HDMI digital sound output of my ATI Mobility Radeon HD 5650
    2. Analog sound output

    I am using the analog sound in duplex mode (one stereo input one stereo output)

    A quick solution would be great The sound of the internal speakers is really horrible xD

  2. #2
    Join Date
    Jun 2010
    Beans
    9

    Re: Acer Aspire TimelineX 3820TG sound problems

    *push*

  3. #3
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,904
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: Acer Aspire TimelineX 3820TG sound problems

    Can you post the output of these terminal commands for me please:
    Code:
    uname -a
    aplay -l
    cat /proc/asound/version
    head -n 1 /proc/asound/card*/codec#*
    Terminal="Applications->Accessories->Terminal"
    Please also include the make/model of your PC/Laptop.
    Please post text output using code tags (the # in toolbar)

  4. #4
    Join Date
    Jun 2010
    Beans
    9

    Re: Acer Aspire TimelineX 3820TG sound problems

    Code:
    audiocrush@debistorm:~$ uname -a
    Linux debistorm 2.6.32-22-generic #36-Ubuntu SMP Thu Jun 3 19:31:57 UTC 2010 x86_64 GNU/Linux
    audiocrush@debistorm:~$ aplay -l
    **** Liste der Hardware-Geräte (PLAYBACK) ****
    Karte 0: Intel [HDA Intel], Gerät 0: ALC269 Analog [ALC269 Analog]
      Sub-Geräte: 0/1
      Sub-Gerät #0: subdevice #0
    Karte 0: Intel [HDA Intel], Gerät 1: ALC269 Digital [ALC269 Digital]
      Sub-Geräte: 1/1
      Sub-Gerät #0: subdevice #0
    Karte 1: Generic [HD-Audio Generic], Gerät 3: ATI HDMI [ATI HDMI]
      Sub-Geräte: 1/1
      Sub-Gerät #0: subdevice #0
    audiocrush@debistorm:~$ cat /proc/asound/version
    Advanced Linux Sound Architecture Driver Version 1.0.21.
    audiocrush@debistorm:~$ head -n1 /proc/asound/card*/codec#*
    ==> /proc/asound/card0/codec#0 <==
    Codec: Realtek ALC269
    
    ==> /proc/asound/card1/codec#0 <==
    Codec: ATI R6xx HDMI
    how can I find out the make or model of my laptop?
    I only know that it is an acer aspire timelineX 3820TG ._.

  5. #5
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,904
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: Acer Aspire TimelineX 3820TG sound problems

    I would try an alsa upgrade via the link in my sig. Then try the following.

    Using a Terminal="Applications->Accessories->Terminal"
    Open this file for editing:
    Code:
     gksudo gedit /etc/modprobe.d/alsa-base.conf
    Insert this line at the bottom:
    Code:
     options snd-hda-intel model=acer
    Save. Close. Reboot. Check your levels in alsamixer.
    Code:
     alsamixer
    Press <F6> to select the correct soundcard.
    Press <F3> to show playback levels. <F4> selects capture levels [or use <Tab>]
    Use the left/right arrow keys to select and up/down arrow keys to change levels. <M> to mute/unmute.

    No help there replace acer with 'acer-aspire' or 'auto'

  6. #6
    Join Date
    Jun 2010
    Beans
    9

    Re: Acer Aspire TimelineX 3820TG sound problems

    wuhuauuuu

    I followed your alsa upgrade tutorial and it worked very well for me :]
    I want to help you and give you the information you need for a supported hardware list^^

  7. #7
    Join Date
    Jun 2006
    Beans
    Hidden!

    Re: Acer Aspire TimelineX 3820TG sound problems

    Quote Originally Posted by lidex View Post
    I would try an alsa upgrade via the link in my sig. Then try the following.
    Hello lidex and other users of Acer Aspire 3820TG
    I have the same configuration as "audiocrush". I can confirm that just upgrading alsa via your ling (http://ubuntuforums.org/showthread.p...10#post6589810) solved problem with no sound from headphone jack. No further modifications as you suggested
    Code:
     gksudo gedit /etc/modprobe.d/alsa-base.conf
    is necessary.
    Thank you for your work and sharing your knowledge!

    For all other users: if you don't have any sound (even from internal speakers) don't forget to change device for sound output in sound preferences (Gnome: left click on speaker icon -> Sound Preferences -> tab "Outpup" -> choose "Internal Audio Analog Stereo".

  8. #8
    Join Date
    Jun 2010
    Beans
    3

    Re: Acer Aspire TimelineX 3820TG sound problems

    I have Acer Aspire 3820TG and was also strugling with the audio. I saw this thread and even though I am using debian lenny 2.6.32 I thought I should give your script a shot

    At first it did not work, the driver simply wouldn't compile. I found out that headers were missing as reported in this bug here http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=540307

    As a final desperate measure I did the following:

    Code:
    cd /usr/src
    mv linux-headers-2.6.32-bpo.5-amd64 linux-headers-2.6.32-bpo.5-amd64.orig
    mkdir linux-headers-2.6.32-bpo.5-amd64
    cp linux-headers-2.6.32-bpo.5-amd64.orig/* linux-headers-2.6.32-bpo.5-amd64/
    cp linux-headers-2.6.32-bpo.5-common/* linux-headers-2.6.32-bpo.5-amd64/
    Then I run your script again. It worked like a charm. It seems that somehow the compilation process looks for the headers in the wrong folder.

    Thx for your script now I have headphones :] And special thx to my husband who did most of the work-around process

  9. #9
    Join Date
    Aug 2010
    Beans
    4

    Re: Acer Aspire TimelineX 3820TG sound problems

    Thanks a lot! It works after upgrading! Headphones in 3820 are working now!
    But there is problem with built-in microphone - it doesn't work at all. Can anybody help me?

    Tnx!

  10. #10
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,904
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: Acer Aspire TimelineX 3820TG sound problems

    Quote Originally Posted by petunder View Post
    Thanks a lot! It works after upgrading! Headphones in 3820 are working now!
    But there is problem with built-in microphone - it doesn't work at all. Can anybody help me?

    Tnx!
    First, for mic problem, check this.
    Gnome-alsamixer
    Using Alt+F2 run dialog
    Code:
     gnome-alsamixer
    Use 'Edit -> Sound Card Properties' menu to enable elements.
    Soundcard tab to select / adjust levels.
    To install:
    Code:
    sudo apt-get install gnome-alsamixer
    Then go to 'Sound Preferences' to select and unmute your mic in 'Input' tab.
    Make sure you have selected a profile with 'duplex' or 'analog input' for the correct sound device on the 'Hardware' tab.
    Use Pulse Audio Volume Control (pavucontrol) to unlock stereo sliders for the mic in 'Input Devices' tab. Drag the right slider down to zero. The mic is a mono device.

    From alsa documentation:
    Capture Problems
    ~~~~~~~~~~~~~~~~
    The capture problems are often because of missing setups of mixers.
    Thus, before submitting a bug report, make sure that you set up the
    mixer correctly. For example, both "Capture Volume" and "Capture
    Switch" have to be set properly in addition to the right "Capture
    Source" or "Input Source" selection. Some devices have "Mic Boost"
    volume or switch.

    When the PCM device is opened via "default" PCM (without pulse-audio
    plugin), you'll likely have "Digital Capture Volume" control as well.
    This is provided for the extra gain/attenuation of the signal in
    software, especially for the inputs without the hardware volume
    control such as digital microphones. Unless really needed, this
    should be set to exactly 50%, corresponding to 0dB -- neither extra
    gain nor attenuation. When you use "hw" PCM, i.e., a raw access PCM,
    this control will have no influence, though.

Page 1 of 4 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •