Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Getting WiFi to work an MSI U160

  1. #1
    Join Date
    Apr 2008
    Beans
    13
    Distro
    Ubuntu

    Unhappy Getting WiFi to work an MSI U160

    Just bought a shiny new MSI Wind U160. I've installed Ubuntu Netbook Edition 10.04 on it, the install was pretty smooth (after I finally managed to get the USB stick to be bootable and boot), however wireless networking doesn't work. Probably other stuff is not working too, but without the network it is hard to check. I can get to network using Ethernet cable, but it is not comfortable so in the end I use now mostly Windows 7 on my new netbook.

    Question 1: how to get the damn WiFi on an MSI U160 to work?
    Question 2: how to get the built-in 3G modem (from Huawei) to work?

  2. #2
    dino99's Avatar
    dino99 is offline Ubuntu addict and loving it
    Join Date
    Jun 2006
    Location
    Nux Jam
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Getting WiFi to work an MSI U160

    first question
    As root:

    mkdir -p /etc/Wireless/RT2860STA/
    touch /etc/Wireless/RT2860STA/RT2860STA.dat
    service network-manager restart

    It is then possible to connect via network manager.

    2d question:
    http://ubuntuforums.org/showthread.php?p=9237905
    Last edited by dino99; May 24th, 2010 at 11:01 AM.

  3. #3
    Join Date
    Apr 2008
    Beans
    13
    Distro
    Ubuntu

    Unhappy Re: Getting WiFi to work an MSI U160

    Quote Originally Posted by dino99 View Post
    first question
    As root:

    mkdir -p /etc/Wireless/RT2860STA/
    touch /etc/Wireless/RT2860STA/RT2860STA.dat
    service network-manager restart

    It is then possible to connect via network manager.
    Thanks for your reply!

    Did that (c&p-ed what you posted) but it didn't work. After restarting the network manager the dropdown in the upper-right corner of the screen was saying "Device not ready" in the "Wireless network" section. Did a reboot to be sure, after reboot it was like before - "Not connected" there. Interestingly, nothing touched the empty RT2860STA.dat file I created after I did. I checked after the reboot and last changed timestamp didn't change.


    Quote Originally Posted by dino99 View Post
    Thanks will look into it, but WiFi is a priority of course.

  4. #4
    Join Date
    Apr 2008
    Beans
    13
    Distro
    Ubuntu

    Re: Getting WiFi to work an MSI U160

    *sigh* still stuck with Windows...

  5. #5
    dino99's Avatar
    dino99 is offline Ubuntu addict and loving it
    Join Date
    Jun 2006
    Location
    Nux Jam
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Thumbs down Re: Getting WiFi to work an MSI U160

    maybe you are able to read the MSI manual:

    ***Switch to wireless networking at the click of a button

    With the U160, you can connect to or disconnect from a wireless network just be pressing a button, making for relaxed, convenient Internet usage.

    Easy, convenient upgrading

    The U160’s user-friendly design makes upgrading device RAM or other modules incredibly simple.

    *****

    http://www.msi.com/index.php?func=pr...5&prod_no=1986

  6. #6
    Join Date
    Apr 2008
    Beans
    13
    Distro
    Ubuntu

    Re: Getting WiFi to work an MSI U160

    Quote Originally Posted by dino99 View Post
    maybe you are able to read the MSI manual:
    I don't understand why you are being rude. Your solution doesn't work - that doesn't imply I'm an idiot.

    In fact, your response makes me think you have never ever seen an MSI U160. If you did play with it you would know WiFi modem is switched on by a slider on the left side and its operation is signaled by a diode on the front. I'm not as stupid as to try to use a device that is switched off on the hardware level.

    OK - is there anyone here who:
    - did get MSI U160's WiFi to work under Ubuntu,
    - is willing to help?
    Last edited by ibuclaw; May 31st, 2010 at 11:12 AM. Reason: removed insult.

  7. #7
    Join Date
    Jan 2008
    Beans
    4,757

    Re: Getting WiFi to work an MSI U160

    There seems to be a bug raised on this in Launchpad that may be related to your issue:
    https://bugs.launchpad.net/ubuntu/+s...ux/+bug/577147
    https://bugs.launchpad.net/ubuntu/+s...ux/+bug/541620

    Could you post the output of:
    Code:
    dmesg
    In [CODE] [/CODE] tags so can have a look to confirm this?

    Regards

  8. #8
    Join Date
    Jun 2010
    Beans
    4

    Lightbulb Re: Getting WiFi to work an MSI U160

    I bought the msi u160. The reason why the wifi card doesn't work is because the driver for this card (Ralink rt3090)are not in the kernel (or not detected) and they are not available in the "normal" repositories. The solution is to do:
    * You will need a working wired connection while you do that.

    1) Add these line into the file /etc/apt/sources.list
    Code:
    ### They are used with karmic instead of lucid because they are  unavailable for lucid.
    deb http://ppa.launchpad.net/markus-tisoft/rt3090/ubuntu karmic main
    deb-src http://ppa.launchpad.net/markus-tisoft/rt3090/ubuntu karmic main
    2) Update your sources with synaptic, apt-get or your your favorite package manager
    Code:
    sudo apt-get update
    3) Install the package rt3090-dkms with your package manager.
    Code:
    sudo apt-get install rt3090-dkms
    It should compile the driver without problem. It took about three minutes or less on mine.

    edit: I actually forgot to add the GPG key, just do: sudo add-apt-repository ppa:markus-tisoft/ppa
    and do an update with your favorite package manager.
    Last edited by znuxor; June 2nd, 2010 at 04:43 AM. Reason: forgot to add the gpg key

  9. #9
    Join Date
    Jun 2010
    Beans
    4

    Re: Getting WiFi to work an MSI U160

    Should this work on the standard version too?
    Tried it on a standard 10.04 install on a Wind U160 and it doesnt seem to work.
    'I get a module license 'unspecified' taints kernel message' searching dmesg for rt3 and 'initialized fail' for rt2

    Cheers,

    Pete

  10. #10
    Join Date
    Jan 2008
    Beans
    4,757

    Re: Getting WiFi to work an MSI U160

    Quote Originally Posted by pbf View Post
    Should this work on the standard version too?
    Tried it on a standard 10.04 install on a Wind U160 and it doesnt seem to work.
    'I get a module license 'unspecified' taints kernel message' searching dmesg for rt3 and 'initialized fail' for rt2

    Cheers,

    Pete
    Could you post the entire dmesg log? Telling it in abstract says absolutely nothing about what is going on.

    Regards

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •