Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: alsamixer startup "speaker" level (and screen brightness startup level)

  1. #1
    Join Date
    May 2008
    Location
    Italy
    Beans
    77
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Red face alsamixer startup "speaker" level (and screen brightness startup level)

    Hi everyone!
    so, I just upgraded to the 10.04 and everything works just fine as before (except for skype but that really doesn't matters as it has already been 3 years I'm using ubuntu and I managed to get it to work only once, for miracle I believe ^^).
    The only real issue I have is this:
    when I start up my laptop, after the log-in, no sound will be heared as the "speaker" volume level in alsamixer is set to 0; if I raise it from the terminal running alsamixer (as I don't know any other alternative) everything plays just fine, but the next time I boot I do have to do it all over again...
    So, how can I change the default startup level of the "speaker" in alsamixer?

    thanks for the help! I know it is not such an important problem but it is very annoying ...

    PS: by the way I do have the very same issue with the screen luminosity but the other way round as is always starts at maximum brightness and I can't manage to get it to start at the minimum, as it did before. At least reducing the backlight if far more quick but a couple of times I forget it and the battery lasted something like half an hour
    If you can tell me how to fix also this one, well, you're just great!

    thanks!


    EDIT: solution here

    EDIT: thanks to T_038 you can find a really faster solution here! Kudos
    Last edited by balta; July 22nd, 2010 at 09:07 PM.
    .balta

  2. #2
    Join Date
    Jul 2006
    Location
    Here
    Beans
    10,545

    Re: alsamixer startup "speaker" level (and screen brightness startup level)

    are you using gnome?

  3. #3
    Join Date
    May 2008
    Location
    Italy
    Beans
    77
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: alsamixer startup "speaker" level (and screen brightness startup level)

    Quote Originally Posted by kerry_s View Post
    are you using gnome?
    yes sir!
    .balta

  4. #4
    Join Date
    May 2010
    Beans
    71
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: alsamixer startup "speaker" level (and screen brightness startup level)

    Try, after having set your alsamixer levels: "sudo alsactl store". This should store your mixer settings and have them restored when you reboot.
    Your skype problems might have to do with mixer settings too, make sure that the right mic is selected in the gnome volume settings control, you should be able to see if it's working when you speak into the mic on the level indicator, also uncheck the box which says "allow skype to change mixer settings" in the skype sound devices dialogue, it tends to mess things up.

  5. #5
    Join Date
    May 2008
    Location
    Italy
    Beans
    77
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: alsamixer startup "speaker" level (and screen brightness startup level)

    thanks, hope in my next reboot everything will be fine!
    sadly my mic can't hear me but well it's not such a great deal as i still have windows really just for skype, hope however i'll fix it ... sooner or later
    (or maybe the nice guys at skype could make a nice new version as we poor linux users still have the ver 2 and on windows they released the 4 looooooong time ago )
    thanks for the help!
    .balta

  6. #6
    Join Date
    May 2008
    Location
    Italy
    Beans
    77
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: alsamixer startup "speaker" level (and screen brightness startup level)

    sadly
    Code:
    sudo alsactl store
    didn't store the speaker level and still when I boot all is silent ...
    ... any more clues?
    .balta

  7. #7
    Join Date
    Mar 2007
    Beans
    97

    Re: alsamixer startup "speaker" level (and screen brightness startup level)

    Hey, actually this affects me too. Everytime I restart the dang thing is back down to 0 volume. "sudo alsactl store" also failed here. I tried that a while back. I would be very interested if anyone could offer up a solution.

    A bit more information, this is a regression as it did not happen back in 9.04. Not sure if it started with the Lucid Beta, or 9.10, but I believe it was the upgrade to Karmic that introduced this bug. Headphones play fine, but the speakers have *no* volume. Oddly, this doesn't happen if I don't log in and play music (via a terminal), so I'd suspect it's a problem with gnome.

  8. #8
    Join Date
    Mar 2008
    Beans
    12

    Re: alsamixer startup "speaker" level (and screen brightness startup level)

    This is an issue to me too.

    I had used 9.10 since it came out, but the problem started with (or after, I'm not exactly sure about the first time it happen) the upgrade to Lucid. It seems that the setting for the master volume is stored between sessions, but the Speaker is always at 0.

    Because I'm not sure if it was the upgrade itself that triggered the problem, I have a theory (totally unattested and speculative). The first time I plugged the headphones, somehow the system understood that I wanted to mute Speakers. But that change was erroneously made permanent...

  9. #9
    Join Date
    May 2008
    Location
    Italy
    Beans
    77
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Lightbulb Re: alsamixer startup "speaker" level (and screen brightness startup level)

    Hi there!
    Lately I've been playing around with alsamixer's config file

    Code:
    /var/lib/alsa/asound.state
    but I didn't manage nor to properly understand it's meaning neither to usefully modify it...

    I'll post it's content ... maybe someone can teach me how to correctly modify the file ... if it can be useful

    Code:
    state.Intel {
    	control.1 {
    		comment.access 'read write'
    		comment.type INTEGER
    		comment.count 2
    		comment.range '0 - 64'
    		comment.dbmin -6400
    		comment.dbmax 0
    		iface MIXER
    		name 'Speaker Playback Volume'
    		value.0 57
    		value.1 57
    	}
    	control.2 {
    		comment.access 'read write'
    		comment.type BOOLEAN
    		comment.count 2
    		iface MIXER
    		name 'Speaker Playback Switch'
    		value.0 false
    		value.1 false
    	}
    	control.3 {
    		comment.access 'read write'
    		comment.type INTEGER
    		comment.count 2
    		comment.range '0 - 64'
    		comment.dbmin -6400
    		comment.dbmax 0
    		iface MIXER
    		name 'Headphone Playback Volume'
    		value.0 64
    		value.1 64
    	}
    	control.4 {
    		comment.access 'read write'
    		comment.type BOOLEAN
    		comment.count 2
    		iface MIXER
    		name 'Headphone Playback Switch'
    		value.0 false
    		value.1 false
    	}
    	control.5 {
    		comment.access 'read write'
    		comment.type INTEGER
    		comment.count 2
    		comment.range '0 - 31'
    		comment.dbmin -3450
    		comment.dbmax 1200
    		iface MIXER
    		name 'Front Mic Playback Volume'
    		value.0 24
    		value.1 24
    	}
    	control.6 {
    		comment.access 'read write'
    		comment.type BOOLEAN
    		comment.count 2
    		iface MIXER
    		name 'Front Mic Playback Switch'
    		value.0 false
    		value.1 false
    	}
    	control.7 {
    		comment.access 'read write'
    		comment.type INTEGER
    		comment.count 2
    		comment.range '0 - 3'
    		comment.dbmin 0
    		comment.dbmax 3000
    		iface MIXER
    		name 'Front Mic Boost'
    		value.0 3
    		value.1 3
    	}
    	control.8 {
    		comment.access 'read write'
    		comment.type BOOLEAN
    		comment.count 2
    		iface MIXER
    		name 'Capture Switch'
    		value.0 true
    		value.1 true
    	}
    	control.9 {
    		comment.access 'read write'
    		comment.type INTEGER
    		comment.count 2
    		comment.range '0 - 31'
    		comment.dbmin -1650
    		comment.dbmax 3000
    		iface MIXER
    		name 'Capture Volume'
    		value.0 0
    		value.1 31
    	}
    	control.10 {
    		comment.access 'read write'
    		comment.type INTEGER
    		comment.count 2
    		comment.range '0 - 31'
    		comment.dbmin -3450
    		comment.dbmax 1200
    		iface MIXER
    		name 'Beep Playback Volume'
    		value.0 0
    		value.1 0
    	}
    	control.11 {
    		comment.access 'read write'
    		comment.type BOOLEAN
    		comment.count 2
    		iface MIXER
    		name 'Beep Playback Switch'
    		value.0 false
    		value.1 false
    	}
    	control.12 {
    		comment.access 'read write'
    		comment.type INTEGER
    		comment.count 1
    		comment.range '0 - 64'
    		comment.dbmin -6400
    		comment.dbmax 0
    		iface MIXER
    		name 'Master Playback Volume'
    		value 52
    	}
    	control.13 {
    		comment.access 'read write'
    		comment.type BOOLEAN
    		comment.count 1
    		iface MIXER
    		name 'Master Playback Switch'
    		value false
    	}
    	control.14 {
    		comment.access 'read write user'
    		comment.type INTEGER
    		comment.count 2
    		comment.range '0 - 255'
    		comment.tlv '0000000100000008ffffec1400000014'
    		comment.dbmin -5100
    		comment.dbmax 0
    		iface MIXER
    		name 'PCM Playback Volume'
    		value.0 254
    		value.1 254
    	}
    	control.15 {
    		comment.access 'read write user'
    		comment.type INTEGER
    		comment.count 2
    		comment.range '0 - 120'
    		comment.tlv '0000000100000008fffff44800000032'
    		comment.dbmin -3000
    		comment.dbmax 3000
    		iface MIXER
    		name 'Digital Capture Volume'
    		value.0 60
    		value.1 60
    	}
    }
    Hope it can lead us to a solution!

    EDIT:
    Ok, I've been fooling around and I can tell that configurations are correctly stored with
    Code:
    alsact store
    and loaded with
    Code:
    alsactl restore
    , which I imagine is called during the boot as I can clearly hear the TR-TR-TR (lol) drum sound on the login screen, it seems that something after the log in modifies it (as I don't hear the desktop landing medley).
    I don't think the problem can be headphone related as unplugging the headphones should restore speakers volume as permanently as it was muted.
    Can maybe it be a conflict with pulse?
    I'll keep on trying! Please post any ideas or clues you may have. Thanks!

    EDIT:
    Btw, I fixed my mic problem, I just muted it's volume left component as my mic is mono and pretending it was stereo caused it no to work ... odd but functional, now I can finally fully use Skype
    Last edited by balta; July 15th, 2010 at 03:11 PM.
    .balta

  10. #10
    Join Date
    May 2008
    Location
    Italy
    Beans
    77
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Arrow Re: alsamixer startup "speaker" level (and screen brightness startup level)

    Ok guys, sorry for the double post but it seems that I somehow managed to solve this.
    Apparently is was a conflict between alsa and pulse.
    What I did was:
    - install "PulseAudio Device Chooser" (which cames with a bunch of other programs) from the Ubuntu repositories.
    - reboot, everything silent as before.
    - before messing with alsamixer start the program.
    - left click on the traycon >> volume control >> output devices tab
    - from the drop down I choose "Analog speakers" (before it was analog output).
    - close.
    - reboot, speakers are now on, and also aslamixer confirms that.

    I think that the program is just a nice GUI and in theory the trick could be done without the "pulse suit" and only using the terminal in a faster way ... well I don't care, this method I found is quite fast and you can set also your mic levels once you are there

    Hope this sort of "guide" can help you

    ... Now for the brightness ... well that's another story
    Last edited by balta; July 16th, 2010 at 10:55 AM.
    .balta

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •