Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: Connection established, yes IP, yes ping, but won't browse

  1. #11
    Join Date
    Mar 2005
    Location
    Isle of Bute, Scotland
    Beans
    365
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Connection established, yes IP, yes ping, but won't browse

    Quote Originally Posted by Crowd Control View Post
    Is there any new input for this problem?
    what happens when you ping google.com now?
    With nameservers available browsing should work now.

  2. #12
    Join Date
    May 2008
    Location
    home
    Beans
    24
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Connection established, yes IP, yes ping, but won't browse

    Pinging google didn't work. Also the connection establishes almost always now, but still kicks out every now and then.

    Furthermore I have checked to see if I could update or something (using the internet), but to no avail.

    I am completely puzzled by this. I just downloaded another flavour of Ubuntu to see if that makes any difference.

  3. #13
    Join Date
    Aug 2008
    Beans
    488

    Re: Connection established, yes IP, yes ping, but won't browse


  4. #14
    Join Date
    May 2008
    Location
    home
    Beans
    24
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Connection established, yes IP, yes ping, but won't browse

    Zomg! Could it be this simple? I wouldn't possibly think to look in that direction though. Again, it's normal Ubuntu didn't pick this one up?

    Anyway, I will most definitely give this a try.

    Thanks.



    edit:

    Ok, I read up on changing the DNS servers. I haven't actually tried that DNS server but Google's as it slightly worked before. Now I had to look up how to override resolv.conf in dhclient.conf which actually worked, so upon reboot I had 8.8.8.8 set as DNS. The wireless connected to the accesspoint but instantly disconnected as soon as I opened Firefox. So then I messed around (only slightly) more in dhclient, because I have a STRONG feeling we are poking the problem by looking at that.

    This is how it looked:
    # Configuration file for /sbin/dhclient, which is included in Debian's
    # dhcp3-client package.
    #
    # This is a sample configuration file for dhclient. See dhclient.conf's
    # man page for more information about the syntax of this file
    # and a more comprehensive list of the parameters understood by
    # dhclient.
    #
    # Normally, if the DHCP server provides reasonable information and does
    # not leave anything out (like the domain name, for example), then
    # few changes must be made to this file, if any.
    #

    option rfc3442-classless-static-routes code 121 = array of unsigned integer 8;

    send host-name "<hostname>";
    #send dhcp-client-identifier 1:0:a0:24:ab:fb:9c;
    #send dhcp-lease-time 3600;
    #supersede domain-name "fugue.com home.vix.com";
    #prepend domain-name-servers 127.0.0.1;
    request subnet-mask, broadcast-address, time-offset, routers,
    domain-name, domain-name-servers, domain-search, host-name,
    netbios-name-servers, netbios-scope, interface-mtu,
    rfc3442-classless-static-routes, ntp-servers;
    #require subnet-mask, domain-name-servers;
    #timeout 60;
    #retry 60;
    #reboot 10;
    #select-timeout 5;
    #initial-interval 2;
    #script "/etc/dhcp3/dhclient-script";
    #media "-link0 -link1 -link2", "link0 link1";
    #reject 192.33.137.209;

    #alias {
    # interface "eth0";
    # fixed-address 192.5.5.213;
    # option subnet-mask 255.255.255.255;
    #}

    #lease {
    # interface "eth0";
    # fixed-address 192.33.137.200;
    # medium "link0 link1";
    # option host-name "andare.swiftmedia.com";
    # option subnet-mask 255.255.255.0;
    # option broadcast-address 192.33.137.255;
    # option routers 192.33.137.250;
    # option domain-name-servers 127.0.0.1;
    # renew 2 2000/1/12 00:00:01;
    # rebind 2 2000/1/12 00:00:01;
    # expire 2 2000/1/12 00:00:01;
    #}
    So I removed the request domain-name-servers, removed the hash before the 'prepend' line. That didn't work as stated above. But there are several options to try (to remove or not, to change 127.0.0.1 to preset DNS, etc. I could sure use help setting up this file, as I think the solution lies somewhere in here.



    edit2: I rechecked with the Window$ partition to compare numbers. It appears the original DNS server in resolv.conf is the same as in Ubuntu's (when not set to Google's). So maybe we there are some other addresses we need to change in dhcp?
    I uploaded a screeny with the available info here.
    Last edited by Crowd Control; May 31st, 2010 at 10:23 AM.

  5. #15
    Join Date
    May 2008
    Location
    home
    Beans
    24
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Connection established, yes IP, yes ping, but won't browse

    Any new ideas on this? I have the feeling we are close!

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •