Page 1 of 33 12311 ... LastLast
Results 1 to 10 of 327

Thread: FLASH-AID: remove conflicting plugins and install proper flash plugin version

  1. #1
    Join Date
    Aug 2008
    Location
    Brazil
    Beans
    12,497
    Distro
    Ubuntu Studio 12.04 Precise Pangolin

    FLASH-AID: remove conflicting plugins and install proper flash plugin version

    Flash issues are very common and threads asking for help are posted several times a week.

    In order to provide an easy solution for new users to install Flash and solve some common issues, I have created FLASH-AID, which is a Firefox extension that automates the process of removing conflicting plugins and installing the proper version of Flash according to browser architecture.

    https://addons.mozilla.org/en-US/fir...ddon/flash-aid

    Last edited by lovinglinux; February 11th, 2012 at 01:01 PM.

  2. #2
    Join Date
    Aug 2008
    Location
    Brazil
    Beans
    12,497
    Distro
    Ubuntu Studio 12.04 Precise Pangolin

    Re: FLASH-AID: remove conflicting plugins and install proper flash plugin version

    I had to release version 1.0.1 to fix a bug if you install the 32bit version on a 64bit machine. Links on the first post are updated.

    If you have a 32bit version and it doesn't install properly, grab the new version too.

    Sorry for the inconvenience.

  3. #3
    Join Date
    Oct 2009
    Location
    Canada
    Beans
    28
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: FLASH-AID: remove conflicting plugins and install proper flash plugin version

    I have been having a real problem getting flash working since trying to install the 64-bit version. I'm running 10.04 x64 and 64-bit Firefox 3.6.3 ... whatever I do I can't get it to recognize the plugin. Flash-aid tells me that I'm running 32-bit architecture and tries to install the 32-bit plugin... which doesn't work. Whatever I do I get the message saying "plugin required" ... and "aboutlugins" says none are installed.

  4. #4
    Join Date
    Aug 2008
    Location
    Brazil
    Beans
    12,497
    Distro
    Ubuntu Studio 12.04 Precise Pangolin

    Re: FLASH-AID: remove conflicting plugins and install proper flash plugin version

    Quote Originally Posted by Superluke View Post
    I have been having a real problem getting flash working since trying to install the 64-bit version. I'm running 10.04 x64 and 64-bit Firefox 3.6.3 ... whatever I do I can't get it to recognize the plugin. Flash-aid tells me that I'm running 32-bit architecture and tries to install the 32-bit plugin... which doesn't work. Whatever I do I get the message saying "plugin required" ... and "aboutlugins" says none are installed.
    Could you please click "Help >> About Firefox", take a screenshot of that window and post it here?

    Also please post the output of these commands:

    Code:
    uname -a
    Code:
    locate libflashplayer.so

  5. #5
    Join Date
    Oct 2009
    Location
    Canada
    Beans
    28
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: FLASH-AID: remove conflicting plugins and install proper flash plugin version

    About Firefox:

    Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3

    uname -a:

    Linux luke-desktop 2.6.32-22-generic #33-Ubuntu SMP Wed Apr 28 13:28:05 UTC 2010 x86_64 GNU/Linux

    locate libflashplayer.so shows it wherever I put it.... the /plugins directories...

  6. #6
    Join Date
    Oct 2009
    Location
    Canada
    Beans
    28
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: FLASH-AID: remove conflicting plugins and install proper flash plugin version

    /home/luke/.limewire/browser/xulrunner/plugins/libflashplayer.so
    /home/luke/.limewire/browser/xulrunner/plugins/npwrapper.libflashplayer.so
    /home/luke/.mozilla/plugins/libflashplayer.so
    /home/luke/.mozilla_backup_2009-10-15T12:59:55-0400/plugins/libflashplayer.so
    /usr/lib/firefox/plugins/libflashplayer.so
    /usr/lib/firefox-addons/plugins/libflashplayer.so
    /usr/lib/mozilla/plugins/libflashplayer.so
    /usr/lib/xulrunner-addons/plugins/libflashplayer.so
    /usr/share/ubufox/plugins/npwrapper.libflashplayer.so
    /var/lib/flashplugin-installer/npwrapper.libflashplayer.so

  7. #7
    Join Date
    Aug 2008
    Location
    Brazil
    Beans
    12,497
    Distro
    Ubuntu Studio 12.04 Precise Pangolin

    Re: FLASH-AID: remove conflicting plugins and install proper flash plugin version

    Quote Originally Posted by Superluke View Post
    About Firefox:

    Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3

    uname -a:

    Linux luke-desktop 2.6.32-22-generic #33-Ubuntu SMP Wed Apr 28 13:28:05 UTC 2010 x86_64 GNU/Linux

    locate libflashplayer.so shows it wherever I put it.... the /plugins directories...
    Thanks. I will upload a new version in a couple of minutes that should fix the architecture detection and allow you to install the 64bit flash. The fix is already in place, I just need to upload it to the mozilla server.

    BTW, how did you install Firefox?

  8. #8
    Join Date
    Aug 2008
    Location
    Brazil
    Beans
    12,497
    Distro
    Ubuntu Studio 12.04 Precise Pangolin

    Re: FLASH-AID: remove conflicting plugins and install proper flash plugin version

    Version 1.0.3 is available for download.

    Please tell me know if it works for you.
    Last edited by lovinglinux; May 31st, 2010 at 05:19 AM.

  9. #9
    Join Date
    Oct 2009
    Location
    Canada
    Beans
    28
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: FLASH-AID: remove conflicting plugins and install proper flash plugin version

    Quote Originally Posted by lovinglinux View Post
    Version 1.0.3 is available for download.

    Please tell me know if it works for you.
    It does detect the correct version now (Progress!) but I still get the "install missing plugins" message and I still show nothing under "aboutlugins" ...

    I've installed Firefox a few different ways (I am worried that there might be traces of other installations hiding around...) but the latest is just 3.5.3 from the repositories. I had installed "Namoroka" (the development version) and for whatever reason my launcher still says that but I don't think it's still on here anywhere

    I'm sure I've screwed it up mainly by trying different scripts and such that I've found around the web... just like I tend to do with my audio configuration (Which is still messed up too!)

    Thanks for your help!

    Edit: I can't seem to get Firefox to recognize ANY plugins... whatever I try to add asks me to install it, then says it's already installed.
    Last edited by Superluke; May 31st, 2010 at 04:16 PM. Reason: thought of somehting else...

  10. #10
    Join Date
    Apr 2009
    Location
    Houston, TX
    Beans
    916
    Distro
    Ubuntu Development Release

    Re: FLASH-AID: remove conflicting plugins and install proper flash plugin version

    Thank you, it worked perfectly for me, and now I have the correct version and 64-bit version installed!! Thanks for taking the hassle out of probably the only thing that I have found 'annoying' (for lack of a better word), it's because of people like you that more and more will come to love Ubuntu/Linux! Good work and thanks again.
    Earl S. Sharp----------------------------------------
    Ubuntu User # 27653 |Linux user # 491157 | LPI # 183649
    Please mark threads as solved...

Page 1 of 33 12311 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •