Page 4 of 6 FirstFirst ... 23456 LastLast
Results 31 to 40 of 58

Thread: Linksys WUSB600N Problems in 10.04 Lucid, and Zombies

  1. #31
    Join Date
    Aug 2007
    Beans
    22

    Re: Linksys WUSB600N Problems in 10.04 Lucid, and Zombies

    Quote Originally Posted by ReginaldPerrin3 View Post
    I have solved this by ....
    Blacklisted the default Ubuntu drivers, added the (slightly modified) Ralink driver, rebooted, and bingo it all works properly.
    I can correctly connect to my 300Mbps 5GHz 802.11n network.
    Same here, and that's 5GHz with WPA2 even (which never worked before, with either driver).

    HOWEVER... the performance is unusable. Frequent (as in about 25% of requests) huge lags plague both HTML and even SSH requests. A couple pages will work fine then one will hang for several seconds. Yet thruput and ping are good when doing a speedtest. I changed back to 2.4GHz (which gets interrupted every time the cordless phone is used) and it works fine.

  2. #32
    Join Date
    Jun 2010
    Beans
    12

    Re: Linksys WUSB600N Problems in 10.04 Lucid, and Zombies

    Performance on my test machines is just fine. Can happily achieve TCP rates somewhere around 80Mbps and UDP around 130Mbps. Equipment used is a Cisco 1252 Access Point, and an Apple Airport Extreme, as well as several WUSB600Ns.
    I used Netperf to get these results.

    Best results come using the 5GHz network, obviously. The 2.4GHz networks will always be plagued by cordless telephones, baby monitors, garage door openers, microwave ovens, and of course all the other 2.4GHz home networks within any sort of range.

  3. #33
    Join Date
    Jun 2010
    Beans
    12

    Re: Linksys WUSB600N Problems in 10.04 Lucid, and Zombies

    And now I realise, of course, that the process of ensuring that Ubuntu is using the correct driver should be repeated (ie: the driver reinstalled) with every update to the kernel. This only means altering the command (in previous posts) to insert the driver (rt2870sta) into the correct kernel-version folders.
    It would be nice to write a script to do all of that automatically upon detection of kernel version change, but I am not familiar enough with scripting to write one up.
    I suppose that the script would have to be somewhat customised seeing as how the compiled driver may not be stored in the same place in all people's computers.

    I will give this much thought, and see what I can come up with (open source of course!).

    I have some test machines that I can sort of afford to break a few times, so this will not be much of a problem.

  4. #34
    Join Date
    May 2010
    Beans
    16
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Linksys WUSB600N Problems in 10.04 Lucid, and Zombies

    Originally Posted by ReginaldPerrin3
    I suppose that the script would have to be somewhat customised seeing as how the compiled driver may not be stored in the same place in all people's computers
    Not necessarily, especially if the guide itself is revised. Here's how to modify the source code from scratch, then install the user-compiled rt2870 driver via BASH script. The first three steps here are identical to those of the original instructions on the first page of this thread.

    1. Download the rt2870USB driver to your downloads file from the Ralink website: http://www.ralinktech.com/support.php?s=2
    Right click to extract the file. Rename the extracted file "RT2870".

    2. Open the source code file "~/Downloads/R2870/os/linux/config.mk" and change the following two values from "=n" to "=y" so that the result is:
    Code:
    HAS_WPA_SUPPLICANT=y
    HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y
    Save and exit.

    3. Open "~/Downloads/R2870/common/cmm_wpa.c" and change the character encoding to Western if needed. Use control+f to search for
    Code:
    MIX_CIPHER_NOTUSE
    Highlight MIX_CIPHER_NOTUSE and copy-paste
    Code:
    WPA_TKIPAES_WPA2_TKIPAES
    into its place. Save and exit.

    4. In Terminal, run
    Code:
    gksudo gedit /etc/modules
    and add
    Code:
    rt2870sta
    at the bottom to tell Ubuntu to load the driver at startup.

    Now you've modified the source files in the same was as in the first guide. I'm working on a way to automate this, but it will have to be manual for now.

    4. It would be annoying to edit that code every time the driver needed recompiling, so we want to put it somewhere permanently.
    Code:
    sudo mv ~/Downloads/RT2870 /usr/src/
    5. Now for the script. It reads from the /usr/src/RT2870 directory no matter what kernel version you have. Copy and paste the following into a blank gedit document. Save it as "rt2870_install.sh" in your Documents directory.

    Code:
    #!/bin/bash
    
    cd /usr/src/RT2870
    make
    make install
    ifconfig wlan0 down
    rmmod rt2870sta
    
    cd /lib/modules/`uname -r`/kernel/drivers/staging/rt2870/
    sudo mv rt2870sta.ko rt2870sta.ko.dist
    
    cd /usr/src/RT2870/os/linux
    sudo cp rt2870sta.ko /lib/modules/`uname -r`/kernel/drivers/staging/rt2870/
    
    modprobe rt2870sta
    exit 0
    6. Any time you need to reinstall the modified driver, open up Terminal and type
    Code:
    sudo sh ~/Documents/rt2870_install.sh
    which will run the script and do the dirty work for you.

    *About the script: the modprobe rt2870sta is intended to start the modified driver immediately, without having to reboot. However, I've always had to reboot to initialize the module. Also, I have found a way to determine if there has been a kernel update through a bash script and then automatically reinstall the modified driver, but I don't know how to use Upstart to initialize it with root privileges at startup. If anyone knows how to do this or clean up the above script, let us know!
    Last edited by Dev0; July 1st, 2010 at 05:27 PM.

  5. #35
    Join Date
    Aug 2007
    Location
    Paris
    Beans
    5,538
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Linksys WUSB600N Problems in 10.04 Lucid, and Zombies

    This only means altering the command (in previous posts) to insert the driver (rt2870sta) into the correct kernel-version folders.
    Just to be clear, you can't simply copy the rt2870sta.ko file into the new kernel folder under /lib/modules; you have to recompile the module against the new kernel (i.e., you have to compile it while running the new kernel, or pass arguments to the compiler to specify which kernel the module needs to work with before it gets compiled) or it won't work with that kernel.

    Dev0's instructions above should help you out. If you wanted, I suppose you could follow them so that you could recompile the module with one simple command. Then you could create a boot script that would test during boot to see if your currently running kernel has the rt2870sta module installed, and if not, compile and install it automatically. Of course, there are plenty of other ways you do this; that's just an idea.

  6. #36
    Join Date
    Jul 2010
    Beans
    7
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Linksys WUSB600N Problems in 10.04 Lucid, and Zombies

    Quote Originally Posted by Dev0 View Post
    Not necessarily, especially if the guide itself is revised. Here's how to modify the source code from scratch, then install the user-compiled rt2870 driver via BASH script. The first three steps here are identical to those of the original instructions on the first page of this thread.

    1. Download the rt2870USB driver to your downloads file from the Ralink website: http://www.ralinktech.com/support.php?s=2
    Right click to extract the file. Rename the extracted file "RT2870".

    2. Open the source code file "~/Downloads/R2870/os/linux/config.mk" and change the following two values from "=n" to "=y" so that the result is:
    Code:
    HAS_WPA_SUPPLICANT=y
    HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y
    Save and exit.

    3. Open "~/Downloads/R2870/common/cmm_wpa.c" and change the character encoding to Western if needed. Use control+f to search for
    Code:
    MIX_CIPHER_NOTUSE
    Highlight MIX_CIPHER_NOTUSE and copy-paste
    Code:
    WPA_TKIPAES_WPA2_TKIPAES
    into its place. Save and exit.

    4. In Terminal, run
    Code:
    gksudo gedit /etc/modules
    and add
    Code:
    rt2870sta
    at the bottom to tell Ubuntu to load the driver at startup.

    Now you've modified the source files in the same was as in the first guide. I'm working on a way to automate this, but it will have to be manual for now.

    4. It would be annoying to edit that code every time the driver needed recompiling, so we want to put it somewhere permanently.
    Code:
    sudo mv ~/Downloads/RT2870 /usr/src/
    5. Now for the script. It reads from the /usr/src/RT2870 directory no matter what kernel version you have. Copy and paste the following into a blank gedit document. Save it as "rt2870_install.sh" in your Documents directory.

    Code:
    #!/bin/bash
    
    cd /usr/src/RT2870
    make
    make install
    ifconfig wlan0 down
    rmmod rt2870sta
    
    cd /lib/modules/`uname -r`/kernel/drivers/staging/rt2870/
    sudo mv rt2870sta.ko rt2870sta.ko.dist
    
    cd /usr/src/RT2870/os/linux
    sudo cp rt2870sta.ko /lib/modules/`uname -r`/kernel/drivers/staging/rt2870/
    
    modprobe rt2870sta
    exit 0
    6. Any time you need to reinstall the modified driver, open up Terminal and type
    Code:
    sudo sh ~/Documents/rt2870_install.sh
    which will run the script and do the dirty work for you.

    *About the script: the modprobe rt2870sta is intended to start the modified driver immediately, without having to reboot. However, I've always had to reboot to initialize the module. Also, I have found a way to determine if there has been a kernel update through a bash script and then automatically reinstall the modified driver, but I don't know how to use Upstart to initialize it with root privileges at startup. If anyone knows how to do this or clean up the above script, let us know!

    I followed the below steps but still nothing. There is an error when running the "sudo sh ~/Documents/rt2870_install.sh" command in the terminal

    The following is the error i get when installing the source code from the script.

    make -C tools
    make[1]: Entering directory `/usr/src/RT2870/tools'
    gcc -g bin2h.c -o bin2h
    make[1]: Leaving directory `/usr/src/RT2870/tools'
    /usr/src/RT2870/tools/bin2h
    cp -f os/linux/Makefile.6 /usr/src/RT2870/os/linux/Makefile
    make -C /lib/modules/2.6.32-24-generic/build SUBDIRS=/usr/src/RT2870/os/linux modules
    make[1]: Entering directory `/usr/src/linux-headers-2.6.32-24-generic'
    CC [M] /usr/src/RT2870/os/linux/../../common/rtmp_mcu.o
    LD [M] /usr/src/RT2870/os/linux/rt2870sta.o
    Building modules, stage 2.
    MODPOST 1 modules
    LD [M] /usr/src/RT2870/os/linux/rt2870sta.ko
    make[1]: Leaving directory `/usr/src/linux-headers-2.6.32-24-generic'
    make -C /usr/src/RT2870/os/linux -f Makefile.6 install
    mkdir: cannot create directory `/etc/Wireless': File exists
    make[1]: Entering directory `/usr/src/RT2870/os/linux'
    rm -rf /etc/Wireless/RT2870STA
    mkdir /etc/Wireless/RT2870STA
    cp /usr/src/RT2870/RT2870STA.dat /etc/Wireless/RT2870STA/.
    install -d /lib/modules/2.6.32-24-generic/kernel/drivers/net/wireless/
    install -m 644 -c rt2870sta.ko /lib/modules/2.6.32-24-generic/kernel/drivers/net/wireless/
    /sbin/depmod -a 2.6.32-24-generic
    make[1]: Leaving directory `/usr/src/RT2870/os/linux'
    wlan0: ERROR while getting interface flags: No such device


    That is the entire output of the command when run. This output is the second time running the script. I originally did all the steps and then ran the script and it got errors similar to the one above but it also listed a directory not found. Following rebooting the computer, and wireless still not working i ran the script again and the above is the entire output.

    Please help as to what i'm doing wrong, or how to fix this flag error.

  7. #37
    Join Date
    Aug 2007
    Location
    Paris
    Beans
    5,538
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Linksys WUSB600N Problems in 10.04 Lucid, and Zombies

    That is the entire output of the command when run. This output is the second time running the script. I originally did all the steps and then ran the script and it got errors similar to the one above but it also listed a directory not found. Following rebooting the computer, and wireless still not working i ran the script again and the above is the entire output.

    Please help as to what i'm doing wrong, or how to fix this flag error.
    I suspect you're getting that error message because of the line in the script that reads:
    Code:
    ifconfig wlan0 down
    It looks like the interface 'wlan0' doesn't exist. Chances are it's named 'wlan1' or something similar on your computer--this is normal. Changing the script accordingly should allow it to complete without errors.

    To find the name of your wireless interface, type:
    Code:
    ifconfig -a
    You'll get output that looks something like:

    Code:
    wlan0      Link encap:Ethernet  HWaddr 00:19:21:85:0d:87  
              inet addr:192.168.2.6  Bcast:192.168.2.255  Mask:255.255.255.0
              inet6 addr: fe80::219:21ff:fe85:d87/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:1501422 errors:0 dropped:0 overruns:0 frame:0
              TX packets:1037223 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:1840839745 (1.8 GB)  TX bytes:161668870 (161.6 MB)
              Interrupt:20 Base address:0xe800 
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:61419 errors:0 dropped:0 overruns:0 frame:0
              TX packets:61419 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:16715204 (16.7 MB)  TX bytes:16715204 (16.7 MB)

    In the example above, the name of my interface is in bold. Look for an interface in your outupt whose name starts with 'wlan...', then edit your script so that the name of this interface replaces 'wlan0', then try running the script again. Does this work?

  8. #38
    Join Date
    Jul 2010
    Beans
    7
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Linksys WUSB600N Problems in 10.04 Lucid, and Zombies

    The following is the output of the terminal of the iwconfig command and ifconfig -a command.

    output:

    ~$ iwconfig
    lo no wireless extensions.

    eth0 no wireless extensions.



    ~$ ifconfig -a
    eth0 Link encap:Ethernet HWaddr 00:1f:e2:3c:58:3c
    inet addr:192.168.1.145 Bcast:192.168.1.255 Mask:255.255.255.0
    inet6 addr: fe80::21f:e2ff:fe3c:583c/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:29788 errors:0 dropped:0 overruns:0 frame:0
    TX packets:20857 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:42320515 (42.3 MB) TX bytes:1808534 (1.8 MB)
    Interrupt:17

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:12 errors:0 dropped:0 overruns:0 frame:0
    TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:720 (720.0 B) TX bytes:720 (720.0 B)

    not sure what i'm looking for when it comes to getting the information about what the right flag is. it doesn't look like any wireless exists. how would i go about getting that to show up that i have plugged in a wireless device and that i have another device to show up in this list.



    Many Thanks,

    Ons

  9. #39
    Join Date
    Nov 2005
    Beans
    37

    Re: Linksys WUSB600N Problems in 10.04 Lucid, and Zombies

    Quote Originally Posted by Ons308 View Post
    The following is the output of the terminal of the iwconfig command and ifconfig -a command.

    output:

    ~$ iwconfig
    lo no wireless extensions.

    eth0 no wireless extensions.



    ~$ ifconfig -a
    eth0 Link encap:Ethernet HWaddr 00:1f:e2:3c:58:3c
    inet addr:192.168.1.145 Bcast:192.168.1.255 Mask:255.255.255.0
    inet6 addr: fe80::21f:e2ff:fe3c:583c/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:29788 errors:0 dropped:0 overruns:0 frame:0
    TX packets:20857 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:42320515 (42.3 MB) TX bytes:1808534 (1.8 MB)
    Interrupt:17

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:12 errors:0 dropped:0 overruns:0 frame:0
    TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:720 (720.0 B) TX bytes:720 (720.0 B)

    not sure what i'm looking for when it comes to getting the information about what the right flag is. it doesn't look like any wireless exists. how would i go about getting that to show up that i have plugged in a wireless device and that i have another device to show up in this list.



    Many Thanks,

    Ons
    Post #46 on page 5 of thread Re: Howto: Ralink RT2860 (m)PCI(e) (RT2760/RT2790/RT2860/RT2890) on Intrepid
    will supply a once and for all definitive solution to any Ralink RT2860 Wireless (WPA2 encrypted) not working with Ubuntu 10.04 Netbook Edition.

    Your travails trying to understand the Linux world remind me of the agony I used to suffer before I went back to "Simple is beautiful". There is nothing easier than installing Ubuntu 10.04 as a virtual machine in VMware Player 3.1.1, which is completely free for home or personal non-profit use.

    Anybody who says this is overkill is correct but I don't need to waste any time trying to get things to work, they just do... straight out of the box.

  10. #40
    Join Date
    May 2010
    Beans
    16
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Linksys WUSB600N Problems in 10.04 Lucid, and Zombies

    Quote Originally Posted by daibak View Post
    Post #46 on page 5 of thread Re: Howto: Ralink RT2860 (m)PCI(e) (RT2760/RT2790/RT2860/RT2890) on Intrepid
    will supply a once and for all definitive solution to any Ralink RT2860 Wireless (WPA2 encrypted) not working with Ubuntu 10.04 Netbook Edition.
    Hi daibak. I believe this is what you are referring to:
    http://ubuntuforums.org/showthread.p...83#post9716483

    A virtual OS is one of many possible solutions because it avoids the problem of dealing with a Linux driver entirely. However, this thread has been focused on getting the RT2870 chipset to function properly on a physical machine, sans Windows or any other OS to hold Ubuntu's hand. Lucid should be versatile enough to run on its own, and we're trying to get it there

Page 4 of 6 FirstFirst ... 23456 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •