Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: Acer Aspire 5100 mic problems

  1. #1
    Join Date
    Oct 2009
    Beans
    11

    Acer Aspire 5100 mic problems

    hey guys, so i just installed the new Lucid Lynx (10.04) and am really liking it so far with the little i've done, but i installed skype and my built-in microphone isn't working. in fact, i went to check stuff and it doesn't appear to be working at all...any advice? and please include easy to follow steps. thank you!

  2. #2
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,904
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: Acer Aspire 5100 mic problems

    For Skype:
    Try this. Use a terminal="Applications->Accessories->Terminal"
    Enter these commands, one line at a time:
    Code:
    sudo add-apt-repository ppa:ubuntu-audio-dev/ppa
    sudo apt-get update
    sudo apt-get install linux-alsa-driver-modules-$(uname -r)
    Reboot.

    Get to know your mixers.
    Alsamixer
    Using a Terminal="Applications->Accessories->Terminal"
    Code:
     alsamixer
    Press <F6> to select the correct soundcard.
    Press <F3> to show playback levels. <F4> selects capture levels [or use <Tab>]
    Use the left/right arrow keys to select and up/down arrow keys to change levels. <M> to mute/unmute.

    Gnome-alsamixer
    Using Alt+F2 run dialog
    Code:
     gnome-alsamixer
    Use 'Edit -> Sound Card Properties' menu to enable elements.
    Soundcard tab to select / adjust levels.

  3. #3
    Join Date
    Oct 2009
    Beans
    11

    Re: Acer Aspire 5100 mic problems

    i did all that and it doesn't seem to have helped at all...i tried using sound recorder and it didn't seem to work and i tried Skype but that doesn't work, and the only Audio options available are PulseAudio...any other suggestions?

  4. #4
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,904
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: Acer Aspire 5100 mic problems

    Is this an upgrade?
    Can you post the output of these terminal commands for me please:
    Code:
    uname -a
    aplay -l
    cat /proc/asound/version
    head -n 1 /proc/asound/card*/codec#*
    Terminal="Applications->Accessories->Terminal"
    Also helpful is the make/model of your PC/Laptop.
    Please post text output using code tags (the # in toolbar)

  5. #5
    Join Date
    Oct 2009
    Beans
    11

    Re: Acer Aspire 5100 mic problems

    I'm using the Acer Aspire 5100 and here's the code in the order you asked for them:
    Code:
    atwilly@musical-bumJR:~$ uname -a
    Linux musical-bumJR 2.6.32-22-generic #33-Ubuntu SMP Wed Apr 28 13:28:05 UTC 2010 x86_64 GNU/Linux
    Code:
    twilly@musical-bumJR:~$ aplay -l
    **** List of PLAYBACK Hardware Devices ****
    card 0: SB [HDA ATI SB], device 0: ALC883 Analog [ALC883 Analog]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: SB [HDA ATI SB], device 1: ALC883 Digital [ALC883 Digital]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    Code:
    twilly@musical-bumJR:~$ cat /proc/asound/version
    Advanced Linux Sound Architecture Driver Version 1.0.23.
    Compiled on May 19 2010 for kernel 2.6.32-22-generic (SMP).
    Code:
    twilly@musical-bumJR:~$ head -n 1 /proc/asound/card*/codec#*
    ==> /proc/asound/card0/codec#0 <==
    Codec: Realtek ALC883
    
    ==> /proc/asound/card0/codec#1 <==
    Codec: Conexant ID 2c06
    hope this helps...

  6. #6
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,904
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: Acer Aspire 5100 mic problems

    Using a Terminal="Applications->Accessories->Terminal"
    Open this file for editing:
    Code:
     gksudo gedit /etc/modprobe.d/alsa-base.conf
    Insert this line at the bottom:
    Code:
     options snd-hda-intel model=acer
    Save. Close. Reboot. Check your levels in alsamixer.
    Code:
     alsamixer
    Press <F6> to select the correct soundcard.
    Press <F3> to show playback levels. <F4> selects capture levels [or use <Tab>]
    Use the left/right arrow keys to select and up/down arrow keys to change levels. <M> to mute/unmute.
    Go to "System ->Preferences ->Sound" and make sure the correct soundcard is default.

  7. #7
    Join Date
    Nov 2006
    Location
    Gloucester, ENGLAND
    Beans
    201

    Re: Acer Aspire 5100 mic problems

    The machine got a GMA500 chipset? Mic input doesn't work on these chipsets yet...
    Have a go at hacking with a Gnome version of BackTrack called GnackTrack.co.uk

  8. #8
    Join Date
    Jan 2009
    Beans
    2

    Talking Re: Acer Aspire 5100 mic problems

    For those looking for the solution to getting your Acer Aspire 5100 mic to work, this is the thread that solved the problem for me. After looking through 3 or 4 threads I found this thread. I followed lidex's directions and my mic now works!

  9. #9
    Join Date
    Jan 2011
    Beans
    12

    Angry Re: Acer Aspire 5100 mic problems

    Exact same machine, Aspire 5100, Ubuntu 10.10 latest build.
    Latest version Skype (Beta) 2.1.0.81

    Did all the things above, no result
    Still same problem, Skype test call records nothing.

    But also cannot change any setting in Skype Sound Devices options which are all set to PulseAudio Server (local).

    All the settings above seem to use ALSA as sound server so I guess I have to convince Skype to use ALSA, but how? (BTW, sound output is OK, even if Skype is configured for PulseAudio).

    Suggestions?

  10. #10
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,904
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: Acer Aspire 5100 mic problems

    Quote Originally Posted by DutchieR View Post
    Exact same machine, Aspire 5100, Ubuntu 10.10 latest build.
    Latest version Skype (Beta) 2.1.0.81

    Did all the things above, no result
    Still same problem, Skype test call records nothing.

    But also cannot change any setting in Skype Sound Devices options which are all set to PulseAudio Server (local).

    All the settings above seem to use ALSA as sound server so I guess I have to convince Skype to use ALSA, but how? (BTW, sound output is OK, even if Skype is configured for PulseAudio).

    Suggestions?
    You did this:
    http://ubuntuforums.org/showpost.php...7&postcount=30

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •